summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2004-04-15 14:48:48 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2004-04-15 14:48:48 +0000
commit6d791a54cb3b8b9ea0e8299cb34f3e44c28e5813 (patch)
tree0450ed27ef80173f2c093948cbe41aa82795818c /games-action/bzflag/bzflag-1.10.4.ebuild
parentApply fix for CAN-2004-0109, ISO vuln. (diff)
downloadhistorical-6d791a54cb3b8b9ea0e8299cb34f3e44c28e5813.tar.gz
historical-6d791a54cb3b8b9ea0e8299cb34f3e44c28e5813.tar.bz2
historical-6d791a54cb3b8b9ea0e8299cb34f3e44c28e5813.zip
~amd64
Diffstat (limited to 'games-action/bzflag/bzflag-1.10.4.ebuild')
-rw-r--r--games-action/bzflag/bzflag-1.10.4.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/games-action/bzflag/bzflag-1.10.4.ebuild b/games-action/bzflag/bzflag-1.10.4.ebuild
index 6161b25a47da..81fd63558ed0 100644
--- a/games-action/bzflag/bzflag-1.10.4.ebuild
+++ b/games-action/bzflag/bzflag-1.10.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/bzflag-1.10.4.ebuild,v 1.1 2004/01/26 11:05:50 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/bzflag-1.10.4.ebuild,v 1.2 2004/04/15 14:48:48 kugelfang Exp $
inherit games
@@ -13,10 +13,20 @@ SRC_URI="mirror://sourceforge/bzflag/${MY_P}.tar.bz2"
IUSE=""
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ppc"
+KEYWORDS="x86 ppc ~amd64"
DEPEND="virtual/opengl"
+src_compile () {
+ if [ "`use amd64`" ]; then
+ sed -e "s/-mcpu=\$host_cpu//" configure > configure.new
+ mv configure.new configure
+ chmod +x configure
+ fi
+ egamesconf || die
+ emake || die
+}
+
src_install () {
make DESTDIR=${D} install || die "make install failed"
dodoc AUTHORS README.UNIX TODO README ChangeLog BUGS PORTING || \