summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-08-25 17:36:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-08-25 17:36:52 +0000
commit56498b35e4df005ffb5e7d826395dce15ef56035 (patch)
treef16922ddd3b554954ea7b564cafc4d41392865fb /games-arcade/bloboats
parentwhitespace (diff)
downloadhistorical-56498b35e4df005ffb5e7d826395dce15ef56035.tar.gz
historical-56498b35e4df005ffb5e7d826395dce15ef56035.tar.bz2
historical-56498b35e4df005ffb5e7d826395dce15ef56035.zip
Initial commit - ebuild submitted by Santiago M. Mola via bug #143733
Package-Manager: portage-2.1.8.3/cvs/Linux i686
Diffstat (limited to 'games-arcade/bloboats')
-rw-r--r--games-arcade/bloboats/ChangeLog10
-rw-r--r--games-arcade/bloboats/Manifest4
-rw-r--r--games-arcade/bloboats/bloboats-1.0.1.ebuild44
-rw-r--r--games-arcade/bloboats/metadata.xml5
4 files changed, 63 insertions, 0 deletions
diff --git a/games-arcade/bloboats/ChangeLog b/games-arcade/bloboats/ChangeLog
new file mode 100644
index 000000000000..47236c8de38a
--- /dev/null
+++ b/games-arcade/bloboats/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-arcade/bloboats
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/bloboats/ChangeLog,v 1.1 2010/08/25 17:36:52 mr_bones_ Exp $
+
+*bloboats-1.0.1 (25 Aug 2010)
+
+ 25 Aug 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +bloboats-1.0.1.ebuild, +metadata.xml:
+ Initial commit - ebuild submitted by Santiago M. Mola via bug #143733
+
diff --git a/games-arcade/bloboats/Manifest b/games-arcade/bloboats/Manifest
new file mode 100644
index 000000000000..e3b5341f062a
--- /dev/null
+++ b/games-arcade/bloboats/Manifest
@@ -0,0 +1,4 @@
+DIST bloboats-1.0.1.tar.gz 7603140 RMD160 0a64d658e187393dbf001242b43af00c6f018720 SHA1 c53646090dee7420f624760a1f645d2a5c5f02ea SHA256 bbaf9b4774e42c1ec1b2473fca7e957c0b2b61448be4ba5e5023863e14d92242
+EBUILD bloboats-1.0.1.ebuild 1220 RMD160 03ac56648e1a2e4070287d1256fffb56a46a2471 SHA1 e7ca0f9ac3bcb03059f23267bab9d30d5b4e9bc1 SHA256 3e74e3f2064aac6f185480f3802673dbc117969e8781499df249917e5ba5dc27
+MISC ChangeLog 418 RMD160 8dfaaa9de3776ce61dca7b667c68bd1d9edb36dc SHA1 36677535974d2f14e2e703f951598a653e30becd SHA256 9b63d67b582d1b76978c29fe317a0d31b5207102ae343c9fa76b6704ce74be1b
+MISC metadata.xml 158 RMD160 cbd9984bb6b426c8c9cee5022fe0a26261612fea SHA1 be5251fa1dacef5c41b74761bb1c8c54fb633b9e SHA256 1423a4fdd4a79b1728a2056d9e300f7e1074253095d82726218d9e9b953888a3
diff --git a/games-arcade/bloboats/bloboats-1.0.1.ebuild b/games-arcade/bloboats/bloboats-1.0.1.ebuild
new file mode 100644
index 000000000000..6cffff41b223
--- /dev/null
+++ b/games-arcade/bloboats/bloboats-1.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/bloboats/bloboats-1.0.1.ebuild,v 1.1 2010/08/25 17:36:52 mr_bones_ Exp $
+
+EAPI=2
+inherit games
+
+DESCRIPTION="arcade-like boat racing game combining platform jumpers and elastomania / x-moto like games"
+HOMEPAGE="http://bloboats.dy.fi/"
+SRC_URI="http://mirror.kapsi.fi/bloboats.dy.fi/${P}.tar.gz"
+
+LICENSE="GPL-2 CCPL-Sampling-Plus-1.0"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-image[png]
+ media-libs/sdl-net
+ media-libs/libvorbis"
+
+src_prepare() {
+ sed -i \
+ -e "/PREFIX/s://:${D}:" \
+ -e "/DATADIR/s:/usr/games/bloboats/data:${GAMES_DATADIR}/${PN}:" \
+ -e "/BINARYDIR/s:/usr/bin:${GAMES_BINDIR}:" \
+ -e "/CONFIGDIR/s:/etc:${GAMES_SYSCONFDIR}:" \
+ -e "/CXXFLAGS_DEFAULT/s:-O2:${CXXFLAGS} \$(LDFLAGS):" \
+ -e "/^CXX[ _]/d" \
+ -e '/STRIP/d' \
+ Makefile \
+ || die 'sed Makefile failed'
+}
+
+src_install() {
+ dogamesbin bin/bloboats || die
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/* || die
+ insinto "$GAMES_SYSCONFDIR"
+ doins bloboats.dirs || die
+ dodoc readme.txt
+ prepgamesdirs
+}
diff --git a/games-arcade/bloboats/metadata.xml b/games-arcade/bloboats/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/bloboats/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>