summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-01-29 00:00:28 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-01-29 00:00:28 +0000
commita2ef0c02d047a3fd68c424561dc30d56ed2931bb (patch)
tree134766ef1ef5731e2879a7e2e2c3af357aa3534b /games-arcade/monster-masher
parentVersion bump. (diff)
downloadhistorical-a2ef0c02d047a3fd68c424561dc30d56ed2931bb.tar.gz
historical-a2ef0c02d047a3fd68c424561dc30d56ed2931bb.tar.bz2
historical-a2ef0c02d047a3fd68c424561dc30d56ed2931bb.zip
Fix this category's dependencies to work with modular X.
Package-Manager: portage-2.1_pre4
Diffstat (limited to 'games-arcade/monster-masher')
-rw-r--r--games-arcade/monster-masher/ChangeLog8
-rw-r--r--games-arcade/monster-masher/monster-masher-1.7.ebuild18
-rw-r--r--games-arcade/monster-masher/monster-masher-1.8.ebuild18
3 files changed, 34 insertions, 10 deletions
diff --git a/games-arcade/monster-masher/ChangeLog b/games-arcade/monster-masher/ChangeLog
index 11015122cd27..8a49adaeed53 100644
--- a/games-arcade/monster-masher/ChangeLog
+++ b/games-arcade/monster-masher/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/monster-masher
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/monster-masher/ChangeLog,v 1.12 2005/11/08 05:53:20 mr_bones_ Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/monster-masher/ChangeLog,v 1.13 2006/01/29 00:00:27 joshuabaergen Exp $
+
+ 28 Jan 2006; Joshua Baergen <joshuabaergen@gentoo.org>
+ monster-masher-1.7.ebuild, monster-masher-1.8.ebuild:
+ Add modular X dependencies.
*monster-masher-1.8 (08 Nov 2005)
diff --git a/games-arcade/monster-masher/monster-masher-1.7.ebuild b/games-arcade/monster-masher/monster-masher-1.7.ebuild
index b4c80a46afdd..970e2e0245ee 100644
--- a/games-arcade/monster-masher/monster-masher-1.7.ebuild
+++ b/games-arcade/monster-masher/monster-masher-1.7.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/monster-masher/monster-masher-1.7.ebuild,v 1.4 2005/08/24 05:46:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/monster-masher/monster-masher-1.7.ebuild,v 1.5 2006/01/29 00:00:27 joshuabaergen Exp $
+
+inherit eutils
DESCRIPTION="Squash the monsters with your levitation worker gnome"
HOMEPAGE="http://www.cs.auc.dk/~olau/monster-masher/"
@@ -11,12 +13,20 @@ SLOT="0"
KEYWORDS="~ppc x86"
IUSE=""
-DEPEND="virtual/x11
+DEPEND="|| ( x11-libs/libSM virtual/x11 )
=dev-cpp/gtkmm-2.4*
=dev-cpp/libgnomemm-2.6*
=dev-cpp/libgnomeuimm-2.6*
=dev-cpp/gconfmm-2.6*
- =dev-cpp/libglademm-2.4*"
+ =dev-cpp/libglademm-2.4*
+ gnome-base/libgnome"
+
+pkg_setup() {
+ if ! built_with_use gnome-base/libgnome esd
+ then
+ die "You need to compile gnome-base/libgnome with esd USE flag!"
+ fi
+}
src_install() {
make DESTDIR="${D}" install || die "make install failed"
diff --git a/games-arcade/monster-masher/monster-masher-1.8.ebuild b/games-arcade/monster-masher/monster-masher-1.8.ebuild
index 17d8ebc0e5ae..c3d69723270a 100644
--- a/games-arcade/monster-masher/monster-masher-1.8.ebuild
+++ b/games-arcade/monster-masher/monster-masher-1.8.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/monster-masher/monster-masher-1.8.ebuild,v 1.1 2005/11/08 05:53:20 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/monster-masher/monster-masher-1.8.ebuild,v 1.2 2006/01/29 00:00:27 joshuabaergen Exp $
+
+inherit eutils
DESCRIPTION="Squash the monsters with your levitation worker gnome"
HOMEPAGE="http://www.cs.auc.dk/~olau/monster-masher/"
@@ -11,11 +13,19 @@ SLOT="0"
KEYWORDS="~ppc ~x86"
IUSE=""
-DEPEND="virtual/x11
+DEPEND="|| ( x11-libs/libSM virtual/x11 )
=dev-cpp/gtkmm-2.6*
=dev-cpp/gconfmm-2.6*
=dev-cpp/libglademm-2.4*
- =dev-cpp/libgnomecanvasmm-2.6*"
+ =dev-cpp/libgnomecanvasmm-2.6*
+ gnome-base/libgnome"
+
+pkg_setup() {
+ if ! built_with_use gnome-base/libgnome esd
+ then
+ die "You need to compile gnome-base/libgnome with esd USE flag!"
+ fi
+}
src_install() {
make DESTDIR="${D}" install || die "make install failed"