summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-08-09 17:04:03 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-08-09 17:04:03 +0000
commit3acd273b9822792248688e1e8352bb0562b73985 (patch)
tree7580b715b4d0cf1d4f753616384fa509c78e0adf /games-arcade
parentstable amd64 (diff)
downloadhistorical-3acd273b9822792248688e1e8352bb0562b73985.tar.gz
historical-3acd273b9822792248688e1e8352bb0562b73985.tar.bz2
historical-3acd273b9822792248688e1e8352bb0562b73985.zip
Added a patch by Tristan Heaven <tristanheaven@gmail.com> to fix the package with the split openal/freealut.
Package-Manager: portage-2.1.1_pre4-r4
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/apricots/ChangeLog12
-rw-r--r--games-arcade/apricots/apricots-0.2.6-r1.ebuild57
-rw-r--r--games-arcade/apricots/files/apricots-0.2.6-freealut.patch65
-rw-r--r--games-arcade/apricots/files/digest-apricots-0.2.6-r13
4 files changed, 135 insertions, 2 deletions
diff --git a/games-arcade/apricots/ChangeLog b/games-arcade/apricots/ChangeLog
index 7dd8d0489a5a..0beda9792fc2 100644
--- a/games-arcade/apricots/ChangeLog
+++ b/games-arcade/apricots/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-arcade/apricots
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/apricots/ChangeLog,v 1.7 2005/06/15 17:32:25 wolf31o2 Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/apricots/ChangeLog,v 1.8 2006/08/09 17:04:03 wolf31o2 Exp $
+
+*apricots-0.2.6-r1 (09 Aug 2006)
+
+ 09 Aug 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/apricots-0.2.6-freealut.patch, -apricots-0.2.6.ebuild,
+ +apricots-0.2.6-r1.ebuild:
+ Added a patch by Tristan Heaven <tristanheaven@gmail.com> to fix the package
+ with the split openal/freealut.
15 Jun 2005; Chris Gianelloni <wolf31o2@gentoo.org> apricots-0.2.6.ebuild:
Removed INSTALL file.
diff --git a/games-arcade/apricots/apricots-0.2.6-r1.ebuild b/games-arcade/apricots/apricots-0.2.6-r1.ebuild
new file mode 100644
index 000000000000..ab7fb9160b09
--- /dev/null
+++ b/games-arcade/apricots/apricots-0.2.6-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/apricots/apricots-0.2.6-r1.ebuild,v 1.1 2006/08/09 17:04:03 wolf31o2 Exp $
+
+inherit eutils games
+
+DESCRIPTION="Fly a plane around bomb/shoot the enemy. Port of Planegame from Amiga."
+HOMEPAGE="http://www.fishies.org.uk/apricots.html"
+SRC_URI="http://www.fishies.org.uk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc ~sparc x86"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2
+ media-libs/openal
+ media-libs/freealut"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-freealut.patch
+ sed -i \
+ -e 's:-DAP_PATH=\\\\\\"$prefix.*":-DAP_PATH=\\\\\\"${GAMES_DATADIR}/${PN}/\\\\\\"":' \
+ configure.in \
+ || die "sed failed"
+
+ sed -i \
+ -e "s:filename(AP_PATH):filename(\"${GAMES_SYSCONFDIR}/${PN}/\"):" \
+ ${PN}/init.cpp \
+ || die "sed failed"
+ sed -i \
+ -e "s:apricots.cfg:${GAMES_SYSCONFDIR}/${PN}/apricots.cfg:" \
+ README apricots.html \
+ || die "sed failed"
+ eautoconf
+}
+
+src_install() {
+ dodoc AUTHORS README TODO ChangeLog
+ dohtml apricots.html
+ cd ${PN}
+ dogamesbin apricots || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins *.wav *.psf *.shapes || die "doins failed"
+ insinto "${GAMES_SYSCONFDIR}/${PN}"
+ doins apricots.cfg || die "failed to install game config file"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "You can change the game options by editing:"
+ einfo "${GAMES_SYSCONFDIR}/${PN}/apricots.cfg"
+ echo
+}
diff --git a/games-arcade/apricots/files/apricots-0.2.6-freealut.patch b/games-arcade/apricots/files/apricots-0.2.6-freealut.patch
new file mode 100644
index 000000000000..4f663071340a
--- /dev/null
+++ b/games-arcade/apricots/files/apricots-0.2.6-freealut.patch
@@ -0,0 +1,65 @@
+--- apricots/apricots.cpp
++++ apricots/apricots.cpp
+@@ -16,6 +16,7 @@
+ int main(int, char**){
+ #endif
+
++atexit(SDL_Quit);
+ // Initialize data
+ gamedata g;
+ init_data(g);
+
+--- apricots/sampleio.cpp
++++ apricots/sampleio.cpp
+@@ -74,12 +74,9 @@
+ alListenerfv(AL_ORIENTATION, front );
+
+ // Load in samples
+- ALvoid* data = malloc(5 * (512 * 3) * 1024);
+ alGenBuffers(numsamples, samples);
+
+ for (int i = 0; i < numsamples; i++){
+- ALsizei freq;
+- ALboolean fileok;
+ // Evil OpenAL portability fix done here
+ #ifdef _WIN32
+ ALenum format;
+@@ -87,15 +84,12 @@
+ alutLoadWAVFile(filenames[i],&format,&data,&filelen,&freq,&trash);
+ fileok = (alGetError() == AL_NO_ERROR);
+ #else
+- ALsizei format;
+- ALsizei trash;
+- fileok = alutLoadWAV(filenames[i],&data,&format,&filelen,&trash,&freq);
++ samples[i] = alutCreateBufferFromFile(filenames[i]);
+ #endif
+- if (!fileok){
++ if (samples[i] == AL_NONE){
+ cerr << "sampleio: could not open " << filenames[i] << endl;
+ exit(1);
+ }
+- alBufferData(samples[i], format, data, filelen, freq);
+ }
+
+ // Generate Sources
+@@ -107,7 +101,6 @@
+ alSourcefv(sources[j], AL_ORIENTATION, back );
+ }
+
+- free(data);
+
+ }
+
+
+--- configure.in
++++ configure.in
+@@ -100,7 +100,8 @@
+
+ dnl Check for OpenAL
+ AC_CHECK_HEADER(AL/al.h,[CXXFLAGS="$CXXFLAGS -DAP_AUDIO_OPENAL"])
+-AC_CHECK_LIB( openal, alutInit)
++AC_CHECK_LIB( openal, alGetError)
++AC_CHECK_LIB( alut, alutInit)
+
+ KDE_CHECK_EXTRA_LIBS
+ all_libraries="$all_libraries $USER_LDFLAGS"
diff --git a/games-arcade/apricots/files/digest-apricots-0.2.6-r1 b/games-arcade/apricots/files/digest-apricots-0.2.6-r1
new file mode 100644
index 000000000000..9325ad4a567a
--- /dev/null
+++ b/games-arcade/apricots/files/digest-apricots-0.2.6-r1
@@ -0,0 +1,3 @@
+MD5 910828d717e46d8cbd9c24f702d09fbc apricots-0.2.6.tar.gz 768568
+RMD160 54377e287a7ce693a90a2387b4c53860f68487cb apricots-0.2.6.tar.gz 768568
+SHA256 9c408722abbb0cb925384f12a65fe4f6e2b3373d5ce5d0e5afe3aeb738b9cd8f apricots-0.2.6.tar.gz 768568