summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2006-10-12 16:46:29 +0000
committerTristan Heaven <tristan@gentoo.org>2006-10-12 16:46:29 +0000
commitdcbbd210be01495c7a215d6c07461c844efb0c77 (patch)
tree3a436afc453ea0dc582bd5b0af97b957f09c3fcc /games-board/camato/camato-0.7.4.ebuild
parentStable on hppa. (diff)
downloadhistorical-dcbbd210be01495c7a215d6c07461c844efb0c77.tar.gz
historical-dcbbd210be01495c7a215d6c07461c844efb0c77.tar.bz2
historical-dcbbd210be01495c7a215d6c07461c844efb0c77.zip
Version bump
Package-Manager: portage-2.1.2_pre2-r9
Diffstat (limited to 'games-board/camato/camato-0.7.4.ebuild')
-rw-r--r--games-board/camato/camato-0.7.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-board/camato/camato-0.7.4.ebuild b/games-board/camato/camato-0.7.4.ebuild
new file mode 100644
index 000000000000..9583dac1258b
--- /dev/null
+++ b/games-board/camato/camato-0.7.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/camato/camato-0.7.4.ebuild,v 1.1 2006/10/12 16:46:29 nyhm Exp $
+
+inherit versionator games
+
+MY_PV=$(replace_all_version_separators _)
+DESCRIPTION="A map editor for the game gnocatan"
+HOMEPAGE="http://yusei.ragondux.com/loisirs_jdp_catane_camato-en.html"
+SRC_URI="http://yusei.ragondux.com/files/gnocatan/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-ruby/ruby-gtk2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -f Makefile
+ sed -i "s:/usr/share:${GAMES_DATADIR}:" \
+ ${PN} || die "sed failed"
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r *.rb img || die "doins failed"
+ dodoc ChangeLog README
+ prepgamesdirs
+}