summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-03-13 08:29:51 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-03-13 08:29:51 +0000
commitbfc1ca6b47af05cc9f01c0d549641237bc118ce0 (patch)
treea2848094d15e62baf6e747790564344443a7efe6 /games-emulation/darcnes
parentclean old ebuild (diff)
downloadhistorical-bfc1ca6b47af05cc9f01c0d549641237bc118ce0.tar.gz
historical-bfc1ca6b47af05cc9f01c0d549641237bc118ce0.tar.bz2
historical-bfc1ca6b47af05cc9f01c0d549641237bc118ce0.zip
applied joypad emulation patch from Alastair Bridgewater (bug #75391); tid
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'games-emulation/darcnes')
-rw-r--r--games-emulation/darcnes/ChangeLog5
-rw-r--r--games-emulation/darcnes/Manifest4
-rw-r--r--games-emulation/darcnes/darcnes-0401-r2.ebuild37
3 files changed, 25 insertions, 21 deletions
diff --git a/games-emulation/darcnes/ChangeLog b/games-emulation/darcnes/ChangeLog
index 53cc8dadbdf4..8656ebc4e7f1 100644
--- a/games-emulation/darcnes/ChangeLog
+++ b/games-emulation/darcnes/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/darcnes
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/ChangeLog,v 1.10 2005/03/13 08:18:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/ChangeLog,v 1.11 2005/03/13 08:29:51 mr_bones_ Exp $
+
+ 13 Mar 2005; Michael Sterrett <mr_bones_@gentoo.org> darcnes-0401-r2.ebuild:
+ applied joypad emulation patch from Alastair Bridgewater (bug #75391); tidy
13 Mar 2005; Michael Sterrett <mr_bones_@gentoo.org>
-darcnes-0401-r1.ebuild:
diff --git a/games-emulation/darcnes/Manifest b/games-emulation/darcnes/Manifest
index cf0f32644199..8f28d6139a2a 100644
--- a/games-emulation/darcnes/Manifest
+++ b/games-emulation/darcnes/Manifest
@@ -1,5 +1,5 @@
-MD5 9cf4bb497f5e700adcfae539644d20b1 ChangeLog 2126
+MD5 76f781cc726246480c44bfaeb62fe5f5 ChangeLog 2284
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 d682464cbe84bdc0d6739e451c874347 darcnes-0401-r2.ebuild 1501
+MD5 4bd4615a6e140aab2a03e059561c48fe darcnes-0401-r2.ebuild 1556
MD5 97092964e106d48cc1b417ed92a14ed7 files/digest-darcnes-0401-r2 57
MD5 335dea4e38703d1353b5cca128ec34b9 files/darcnes-0401-gcc34.patch 213
diff --git a/games-emulation/darcnes/darcnes-0401-r2.ebuild b/games-emulation/darcnes/darcnes-0401-r2.ebuild
index d6babce42c82..7c3eb8053abd 100644
--- a/games-emulation/darcnes/darcnes-0401-r2.ebuild
+++ b/games-emulation/darcnes/darcnes-0401-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/darcnes-0401-r2.ebuild,v 1.8 2005/03/13 08:18:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/darcnes-0401-r2.ebuild,v 1.9 2005/03/13 08:29:51 mr_bones_ Exp $
inherit eutils games
@@ -10,7 +10,7 @@ SRC_URI="http://www.dridus.com/~nyef/darcnes/download/dn9b${PV}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 -ppc"
+KEYWORDS="-ppc x86"
IUSE="gtk svga X"
DEPEND="svga? ( >=media-libs/svgalib-1.4.2 )
@@ -20,35 +20,36 @@ DEPEND="svga? ( >=media-libs/svgalib-1.4.2 )
virtual/x11
=x11-libs/gtk+-1.2* )"
-S="${WORKDIR}/${PN}"
-
-pkg_setup() {
- build_X=true
- use svga && build_X=false
- use gtk && build_X=false
- use X && build_X=true
- games_pkg_setup
-}
+S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch ${FILESDIR}/${P}-gcc34.patch
+ epatch "${FILESDIR}/${P}-gcc34.patch"
+ # bug #75391
+ sed -i \
+ -e "s/buttons\[0\]/buttons\[\]/" ui.h \
+ || die "sed failed"
}
src_compile() {
+ build_X=true
+ use svga && build_X=false
+ use gtk && build_X=false
+ use X && build_X=true
+
if use svga ; then
- emake TARGET=Linux_svgalib OPTFLAGS="${CFLAGS}" || \
- die "compile target Linux_svgalib failed"
+ emake TARGET=Linux_svgalib OPTFLAGS="${CFLAGS}" \
+ || die "compile target Linux_svgalib failed"
fi
if use gtk ; then
- emake BINFILE=gdarcnes TARGET=Linux_GTK OPTFLAGS="${CFLAGS}" || \
- die "compile target Linux_GTK failed"
+ emake BINFILE=gdarcnes TARGET=Linux_GTK OPTFLAGS="${CFLAGS}" \
+ || die "compile target Linux_GTK failed"
fi
if $build_X ; then
- emake TARGET=Linux_X OPTFLAGS="${CFLAGS}" || \
- die "compile target Linux_X failed"
+ emake TARGET=Linux_X OPTFLAGS="${CFLAGS}" \
+ || die "compile target Linux_X failed"
fi
}