summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-09-02 06:27:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-09-02 06:27:26 +0000
commit786aac66832a49746b87e43ec3aa14290e5c4aa4 (patch)
treecbc11c1166f2e3cf878586adc6fdfac99ab594e3 /games-emulation/gngeo/gngeo-0.7.ebuild
parentAdd udev permissions patch wrt Bug #144010. (diff)
downloadhistorical-786aac66832a49746b87e43ec3aa14290e5c4aa4.tar.gz
historical-786aac66832a49746b87e43ec3aa14290e5c4aa4.tar.bz2
historical-786aac66832a49746b87e43ec3aa14290e5c4aa4.zip
version bump; clean out older ebuild
Package-Manager: portage-2.1.1_rc1-r1
Diffstat (limited to 'games-emulation/gngeo/gngeo-0.7.ebuild')
-rw-r--r--games-emulation/gngeo/gngeo-0.7.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-emulation/gngeo/gngeo-0.7.ebuild b/games-emulation/gngeo/gngeo-0.7.ebuild
new file mode 100644
index 000000000000..50d8fe354df0
--- /dev/null
+++ b/games-emulation/gngeo/gngeo-0.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngeo/gngeo-0.7.ebuild,v 1.1 2006/09/02 06:27:26 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="A NeoGeo emulator"
+HOMEPAGE="http://m.peponas.free.fr/gngeo/"
+SRC_URI="http://download.berlios.de/gngeo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ sys-libs/zlib
+ media-libs/sdl-image
+ >=media-libs/libsdl-1.2"
+# gcc-3.3 gets it wrong - bug #128587
+DEPEND="${RDEPEND}
+ >=sys-devel/gcc-3.4
+ x86? ( >=dev-lang/nasm-0.98 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-execstacks.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS FAQ NEWS README* TODO sample_gngeorc
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "A licensed NeoGeo BIOS copy is required to run the emulator."
+ echo
+}