summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-09-20 15:04:28 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-09-20 15:04:28 +0000
commitc2048f929daf4722a39ef85736cb65b1d8824d56 (patch)
treefc23fb5f7d137b7a0eed91557f32914d547243bf /games-emulation/mupen64-alsasnd
parentBack to ~x86 because of bug 106652 (diff)
downloadhistorical-c2048f929daf4722a39ef85736cb65b1d8824d56.tar.gz
historical-c2048f929daf4722a39ef85736cb65b1d8824d56.tar.bz2
historical-c2048f929daf4722a39ef85736cb65b1d8824d56.zip
remove gtk2 use flag
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'games-emulation/mupen64-alsasnd')
-rw-r--r--games-emulation/mupen64-alsasnd/ChangeLog6
-rw-r--r--games-emulation/mupen64-alsasnd/Manifest6
-rw-r--r--games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild18
3 files changed, 16 insertions, 14 deletions
diff --git a/games-emulation/mupen64-alsasnd/ChangeLog b/games-emulation/mupen64-alsasnd/ChangeLog
index 43f734bff2d7..700649553a80 100644
--- a/games-emulation/mupen64-alsasnd/ChangeLog
+++ b/games-emulation/mupen64-alsasnd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/mupen64-alsasnd
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/ChangeLog,v 1.7 2005/07/07 04:36:55 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/ChangeLog,v 1.8 2005/09/20 15:04:28 mr_bones_ Exp $
+
+ 20 Sep 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ mupen64-alsasnd-0.4.ebuild:
+ remove gtk2 use flag
07 Jul 2005; Caleb Tennis <caleb@gentoo.org> mupen64-alsasnd-0.4.ebuild:
Fix qt dep
diff --git a/games-emulation/mupen64-alsasnd/Manifest b/games-emulation/mupen64-alsasnd/Manifest
index 55dcaaa31bc7..1354fa1279bd 100644
--- a/games-emulation/mupen64-alsasnd/Manifest
+++ b/games-emulation/mupen64-alsasnd/Manifest
@@ -1,6 +1,6 @@
-MD5 4f3af2259fce6b93934050a63df8407e mupen64-alsasnd-0.4.ebuild 1416
-MD5 576fa8ea8f91aeff3187af7708ff9288 ChangeLog 987
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 658b03e564090a62ea13902273e73ae4 files/digest-mupen64-alsasnd-0.4 70
+MD5 28291b6c6c50f516108092d8ba4a7718 mupen64-alsasnd-0.4.ebuild 1267
+MD5 2ac2bbe599446462d1216d232a3ed41f ChangeLog 1100
MD5 49a9052e77c664f4a2c6b092c62b39f6 files/0.4-gentoo.patch 560
MD5 15dd3b6cd3a33e7fcba000b2b38b9bd2 files/0.4-gtk.patch 1203
+MD5 658b03e564090a62ea13902273e73ae4 files/digest-mupen64-alsasnd-0.4 70
diff --git a/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild b/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild
index a4351b21a6db..53e56c74ad4f 100644
--- a/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild
+++ b/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild,v 1.12 2005/07/07 04:36:55 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild,v 1.13 2005/09/20 15:04:28 mr_bones_ Exp $
-inherit games eutils
+inherit eutils games
DESCRIPTION="Alsa plugin for the mupen64 N64 emulator"
HOMEPAGE="http://www.emutalk.net/showthread.php?threadid=16895"
@@ -11,17 +11,16 @@ SRC_URI="mirror://gentoo/alsa-plugin-${PV}fix.tar.bz2"
LICENSE="as-is"
SLOT="0"
KEYWORDS="-* x86"
-IUSE="qt gtk gtk2"
+IUSE="gtk qt"
DEPEND=">=media-libs/alsa-lib-0.9.0
|| (
- gtk? ( !gtk2? ( =x11-libs/gtk+-1* )
- gtk2? ( =x11-libs/gtk+-2* ) )
+ gtk? ( =x11-libs/gtk+-2* )
qt? ( =x11-libs/qt-3* )
=x11-libs/gtk+-2*
)"
-S="${WORKDIR}/alsa_plugin"
+S=${WORKDIR}/alsa_plugin
pkg_nofetch() {
einfo "Please visit this page to download the tarball:"
@@ -32,15 +31,14 @@ pkg_nofetch() {
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${PV}-gentoo.patch" || die "gentoo patch failed"
- epatch "${FILESDIR}/${PV}-gtk.patch" || die "gtk patch failed"
+ epatch "${FILESDIR}/${PV}-gentoo.patch" \
+ "${FILESDIR}/${PV}-gtk.patch"
}
src_compile() {
export GRAPHICAL_INTERFACE=gtk2
use qt && export GRAPHICAL_INTERFACE=qt3
- use gtk && export GRAPHICAL_INTERFACE=gtk1
- use gtk2 && export GRAPHICAL_INTERFACE=gtk2
+ use gtk && export GRAPHICAL_INTERFACE=gtk2
emake || die "make failed"
}