summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-12-26 20:22:09 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-12-26 20:22:09 +0000
commitdfe5a346f2ab0125a80f99e261dc238eb206788f (patch)
treea3871260ce3478bdf4845e27cc84969e22a2e715 /games-emulation/snes9x
parentrepoman: Trim trailing whitespace (diff)
downloadhistorical-dfe5a346f2ab0125a80f99e261dc238eb206788f.tar.gz
historical-dfe5a346f2ab0125a80f99e261dc238eb206788f.tar.bz2
historical-dfe5a346f2ab0125a80f99e261dc238eb206788f.zip
tidy; error check
Package-Manager: portage-2.0.53
Diffstat (limited to 'games-emulation/snes9x')
-rw-r--r--games-emulation/snes9x/Manifest2
-rw-r--r--games-emulation/snes9x/snes9x-1.43-r1.ebuild23
2 files changed, 15 insertions, 10 deletions
diff --git a/games-emulation/snes9x/Manifest b/games-emulation/snes9x/Manifest
index 53f59aa85071..9d51d3417213 100644
--- a/games-emulation/snes9x/Manifest
+++ b/games-emulation/snes9x/Manifest
@@ -5,4 +5,4 @@ MD5 3c7f3eecac089063f960f627df4ac7e5 files/snes9x-1.43-build.patch 1104
MD5 7785101201919ebc94bcd95e2cab6017 files/snes9x-1.43-key-bindings-fix.patch 2526
MD5 48de604e869ca1513f6265f5739d97b1 files/snes9x-1.43-porting.patch 1903
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 6d29d215d6df24607d66cc11188288cc snes9x-1.43-r1.ebuild 2541
+MD5 680d94bab8a9806430fc0302406d2b8b snes9x-1.43-r1.ebuild 2571
diff --git a/games-emulation/snes9x/snes9x-1.43-r1.ebuild b/games-emulation/snes9x/snes9x-1.43-r1.ebuild
index 41eb30efe1fa..09a3aff80d9a 100644
--- a/games-emulation/snes9x/snes9x-1.43-r1.ebuild
+++ b/games-emulation/snes9x/snes9x-1.43-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/snes9x-1.43-r1.ebuild,v 1.4 2005/12/26 19:29:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/snes9x-1.43-r1.ebuild,v 1.5 2005/12/26 20:22:09 mr_bones_ Exp $
# 3dfx support (glide) is disabled because it requires
# glide-v2 while we only provide glide-v3 in portage
@@ -35,15 +35,20 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"/snes9x
- epatch "${FILESDIR}"/nojoy.patch
- epatch "${FILESDIR}"/${P}-porting.patch
- epatch "${FILESDIR}"/${P}-key-bindings-fix.patch #81980
- sed -i 's:png_jmpbuf:png_write_info:g' configure
-
rm offsets # stupid prebuilt file
- sed -i -e 's:-lXext -lX11::' Makefile.in
- sed -i -e '/X_LDFLAGS=/d' configure
- epatch "${FILESDIR}"/${P}-build.patch
+ sed -i \
+ -e 's:-lXext -lX11::' Makefile.in \
+ || die "sed failed"
+ epatch \
+ "${FILESDIR}"/nojoy.patch \
+ "${FILESDIR}"/${P}-porting.patch \
+ "${FILESDIR}"/${P}-key-bindings-fix.patch \
+ "${FILESDIR}"/${P}-build.patch
+
+ sed -i \
+ -e 's:png_jmpbuf:png_write_info:g' \
+ -e '/X_LDFLAGS=/d' \
+ configure || die "sed failed"
autoconf || die
}