summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2007-04-09 17:05:01 +0000
committerTristan Heaven <tristan@gentoo.org>2007-04-09 17:05:01 +0000
commit09e519287bfc2b5558820b944553c7d2427f2ed1 (patch)
tree2f5a3e26e1088067413f53e0d733d6ec54e8f067 /games-emulation
parentMarking stable amd64 (diff)
downloadhistorical-09e519287bfc2b5558820b944553c7d2427f2ed1.tar.gz
historical-09e519287bfc2b5558820b944553c7d2427f2ed1.tar.bz2
historical-09e519287bfc2b5558820b944553c7d2427f2ed1.zip
use games_get_libdir
Package-Manager: portage-2.1.2.3
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/psemu-eternalspu/psemu-eternalspu-1.41-r2.ebuild12
-rw-r--r--games-emulation/psemu-gpupetemesagl/psemu-gpupetemesagl-1.76.ebuild12
-rw-r--r--games-emulation/psemu-gpupetexgl2/files/digest-psemu-gpupetexgl2-2.0.69
-rw-r--r--games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.6.ebuild37
-rw-r--r--games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.8.ebuild16
-rw-r--r--games-emulation/psemu-padjoy/psemu-padjoy-0.82.ebuild16
-rw-r--r--games-emulation/psemu-padxwin/psemu-padxwin-1.6.ebuild10
-rw-r--r--games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.17.ebuild15
8 files changed, 40 insertions, 87 deletions
diff --git a/games-emulation/psemu-eternalspu/psemu-eternalspu-1.41-r2.ebuild b/games-emulation/psemu-eternalspu/psemu-eternalspu-1.41-r2.ebuild
index 1fd3d622b30f..19e1412116c3 100644
--- a/games-emulation/psemu-eternalspu/psemu-eternalspu-1.41-r2.ebuild
+++ b/games-emulation/psemu-eternalspu/psemu-eternalspu-1.41-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-eternalspu/psemu-eternalspu-1.41-r2.ebuild,v 1.3 2006/12/01 21:42:05 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-eternalspu/psemu-eternalspu-1.41-r2.ebuild,v 1.4 2007/04/09 16:52:47 nyhm Exp $
inherit games
@@ -11,17 +11,17 @@ SRC_URI="http://www1.odn.ne.jp/psx-alternative/download/spuEternal${PV//.}_linux
LICENSE="freedist"
SLOT="0"
KEYWORDS="x86"
-RESTRICT="strip"
IUSE=""
+RESTRICT="strip"
RDEPEND="x11-libs/libXext
sys-libs/lib-compat"
-S="${WORKDIR}"
+S=${WORKDIR}
src_install() {
- exeinto "${GAMES_LIBDIR}/psemu/plugins"
- doexe libspuEternal.so.*
+ exeinto "$(games_get_libdir)"/psemu/plugins
+ doexe libspuEternal.so.* || die "doexe failed"
dodoc *.txt
prepgamesdirs
}
diff --git a/games-emulation/psemu-gpupetemesagl/psemu-gpupetemesagl-1.76.ebuild b/games-emulation/psemu-gpupetemesagl/psemu-gpupetemesagl-1.76.ebuild
index a4cba0358797..c19d11bd702e 100644
--- a/games-emulation/psemu-gpupetemesagl/psemu-gpupetemesagl-1.76.ebuild
+++ b/games-emulation/psemu-gpupetemesagl/psemu-gpupetemesagl-1.76.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-gpupetemesagl/psemu-gpupetemesagl-1.76.ebuild,v 1.2 2006/09/19 19:13:37 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-gpupetemesagl/psemu-gpupetemesagl-1.76.ebuild,v 1.3 2007/04/09 16:54:30 nyhm Exp $
inherit games
@@ -11,19 +11,19 @@ SRC_URI="http://www.pbernert.com/gpupetemesagl${PV//./}.tar.gz"
LICENSE="freedist"
SLOT="0"
KEYWORDS="x86"
-RESTRICT="strip"
IUSE=""
+RESTRICT="strip"
DEPEND="virtual/opengl"
S=${WORKDIR}
src_install() {
- exeinto "${GAMES_LIBDIR}/psemu/plugins"
+ exeinto "$(games_get_libdir)"/psemu/plugins
doexe lib* || die "doexe failed"
- exeinto "${GAMES_LIBDIR}/psemu/cfg"
+ exeinto "$(games_get_libdir)"/psemu/cfg
doexe cfgPeteMesaGL || die "doexe failed"
- insinto "${GAMES_LIBDIR}/psemu/cfg"
+ insinto "$(games_get_libdir)"/psemu/cfg
doins gpuPeteMesaGL.cfg || die "doins failed"
dodoc readme.txt version.txt
prepgamesdirs
diff --git a/games-emulation/psemu-gpupetexgl2/files/digest-psemu-gpupetexgl2-2.0.6 b/games-emulation/psemu-gpupetexgl2/files/digest-psemu-gpupetexgl2-2.0.6
deleted file mode 100644
index 1e3fad1ed9ca..000000000000
--- a/games-emulation/psemu-gpupetexgl2/files/digest-psemu-gpupetexgl2-2.0.6
+++ /dev/null
@@ -1,9 +0,0 @@
-MD5 506564c96d06080e94d74771e5b8ee0c gpupetexgl206.tar.gz 187626
-RMD160 849c90e4c3ada89c34abd311db724e0f1ccc7367 gpupetexgl206.tar.gz 187626
-SHA256 39a1c176a85e79a8307eac997426650bfd8d86608b9ebc9f81ee2de14dc82ff1 gpupetexgl206.tar.gz 187626
-MD5 2628e8e11fe638dc599fd5564169d756 pete_ogl2_shader_scale2x.zip 3072
-RMD160 c21bfa1e80120521e270deb325d61ff526e5a28d pete_ogl2_shader_scale2x.zip 3072
-SHA256 435392c94f6b6ad5549a03e58c66a8fc5bca60e9ae2082c616616821cdf5974c pete_ogl2_shader_scale2x.zip 3072
-MD5 2bb81f8164039c97fb1dd92628c6cf8e pete_ogl2_shader_simpleblur.zip 1032
-RMD160 fb0fdd45a56b716ad3f9f6a93dbecef84d8f725e pete_ogl2_shader_simpleblur.zip 1032
-SHA256 52cbb4df75ba2ec08863a937146578bb223bab5b5dc7a2744b45fa2c338c31cc pete_ogl2_shader_simpleblur.zip 1032
diff --git a/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.6.ebuild b/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.6.ebuild
deleted file mode 100644
index 492192983963..000000000000
--- a/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.6.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.6.ebuild,v 1.2 2006/09/19 19:15:42 wolf31o2 Exp $
-
-inherit games
-
-DESCRIPTION="PSEmu XGL2 GPU"
-HOMEPAGE="http://www.pbernert.com/"
-SRC_URI="http://www.pbernert.com/gpupetexgl${PV//.}.tar.gz
- http://www.pbernert.com/pete_ogl2_shader_scale2x.zip
- http://www.pbernert.com/pete_ogl2_shader_simpleblur.zip"
-
-LICENSE="freedist"
-SLOT="0"
-KEYWORDS="x86"
-RESTRICT="strip"
-IUSE=""
-
-RDEPEND="virtual/opengl"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}
-
-src_install() {
- exeinto "${GAMES_LIBDIR}/psemu/plugins"
- doexe lib* || die "doexe failed"
- exeinto "${GAMES_LIBDIR}/psemu/cfg"
- doexe cfgPeteXGL2 || die "doexe failed"
- insinto "${GAMES_LIBDIR}/psemu/cfg"
- doins gpuPeteXGL2.cfg || die "doins failed"
- # now do our shader files!
- insinto "${GAMES_LIBDIR}/psemu/shaders"
- doins *.fp *.vp *.slf *.slv || die "doins failed"
- dodoc *.txt
- prepgamesdirs
-}
diff --git a/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.8.ebuild b/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.8.ebuild
index 69366f56962a..1e62679605e1 100644
--- a/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.8.ebuild
+++ b/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.8.ebuild,v 1.1 2006/09/29 19:41:46 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.8.ebuild,v 1.2 2007/04/09 16:57:33 nyhm Exp $
inherit games
@@ -12,9 +12,9 @@ SRC_URI="http://www.pbernert.com/gpupetexgl${PV//.}.tar.gz
LICENSE="freedist"
SLOT="0"
-KEYWORDS="~x86"
-RESTRICT="strip"
+KEYWORDS="x86"
IUSE=""
+RESTRICT="strip"
RDEPEND="virtual/opengl"
DEPEND="${RDEPEND}
@@ -23,14 +23,14 @@ DEPEND="${RDEPEND}
S=${WORKDIR}
src_install() {
- exeinto "${GAMES_LIBDIR}/psemu/plugins"
+ exeinto "$(games_get_libdir)"/psemu/plugins
doexe lib* || die "doexe failed"
- exeinto "${GAMES_LIBDIR}/psemu/cfg"
+ exeinto "$(games_get_libdir)"/psemu/cfg
doexe cfgPeteXGL2 || die "doexe failed"
- insinto "${GAMES_LIBDIR}/psemu/cfg"
+ insinto "$(games_get_libdir)"/psemu/cfg
doins gpuPeteXGL2.cfg || die "doins failed"
# now do our shader files!
- insinto "${GAMES_LIBDIR}/psemu/shaders"
+ insinto "$(games_get_libdir)"/psemu/shaders
doins *.fp *.vp *.slf *.slv || die "doins failed"
dodoc *.txt
prepgamesdirs
diff --git a/games-emulation/psemu-padjoy/psemu-padjoy-0.82.ebuild b/games-emulation/psemu-padjoy/psemu-padjoy-0.82.ebuild
index f5a0c24fa42d..398fe06af2ea 100644
--- a/games-emulation/psemu-padjoy/psemu-padjoy-0.82.ebuild
+++ b/games-emulation/psemu-padjoy/psemu-padjoy-0.82.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-padjoy/psemu-padjoy-0.82.ebuild,v 1.6 2006/11/23 22:17:48 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-padjoy/psemu-padjoy-0.82.ebuild,v 1.7 2007/04/09 17:00:56 nyhm Exp $
inherit games
@@ -22,14 +22,14 @@ src_unpack() {
cd "${S}"
sed -i \
-e "s:-O2 -fomit-frame-pointer:${CFLAGS}:" Makefile \
- || die "sed Makefile failed"
+ || die "sed failed"
}
src_install() {
- exeinto "${GAMES_LIBDIR}/psemu/plugins"
- doexe libpadJoy-* || die "doexe failed"
- exeinto "${GAMES_LIBDIR}/psemu/cfg"
- doexe cfgPadJoy || die "doexe failed (2)"
- dodoc ../readme.txt || die "dodoc failed"
+ exeinto "$(games_get_libdir)"/psemu/plugins
+ doexe libpadJoy-* || die "doexe failed"
+ exeinto "$(games_get_libdir)"/psemu/cfg
+ doexe cfgPadJoy || die "doexe cfgPadJoy failed"
+ dodoc ../readme.txt
prepgamesdirs
}
diff --git a/games-emulation/psemu-padxwin/psemu-padxwin-1.6.ebuild b/games-emulation/psemu-padxwin/psemu-padxwin-1.6.ebuild
index d47fde594abb..2885e5fe8126 100644
--- a/games-emulation/psemu-padxwin/psemu-padxwin-1.6.ebuild
+++ b/games-emulation/psemu-padxwin/psemu-padxwin-1.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-padxwin/psemu-padxwin-1.6.ebuild,v 1.7 2006/09/26 18:23:37 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-padxwin/psemu-padxwin-1.6.ebuild,v 1.8 2007/04/09 17:02:28 nyhm Exp $
inherit eutils games
@@ -19,7 +19,7 @@ S=${WORKDIR}
src_unpack() {
unpack ${A}
- epatch "${FILESDIR}/${PV}-makefile-cflags.patch"
+ epatch "${FILESDIR}"/${PV}-makefile-cflags.patch
sed -i '/strip/d' src/Makefile || die "sed failed"
}
@@ -31,9 +31,9 @@ src_compile() {
src_install() {
dodoc ReadMe.txt
cd src
- exeinto "${GAMES_LIBDIR}/psemu/plugins"
+ exeinto "$(games_get_libdir)"/psemu/plugins
doexe libpadXwin-* || die "doexe failed"
- exeinto "${GAMES_LIBDIR}/psemu/cfg"
+ exeinto "$(games_get_libdir)"/psemu/cfg
doexe cfgPadXwin || die "doexe failed"
prepgamesdirs
}
diff --git a/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.17.ebuild b/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.17.ebuild
index ffe7e3c787f5..f147d1f8ae38 100644
--- a/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.17.ebuild
+++ b/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.17.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.17.ebuild,v 1.5 2006/10/09 10:36:57 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.17.ebuild,v 1.6 2007/04/09 17:05:01 nyhm Exp $
inherit eutils games
@@ -18,7 +18,6 @@ RDEPEND="=x11-libs/gtk+-1*
DEPEND="${RDEPEND}
dev-util/pkgconfig
x86? ( dev-lang/nasm )
- amd64? ( dev-lang/nasm )
x11-proto/xf86dgaproto
x11-proto/xf86vidmodeproto"
@@ -57,18 +56,18 @@ src_compile() {
sed -i \
-e 's:mk.x11:mk.fpse:g' Makefile \
|| die "sed failed"
- make clean || die "make clean failed"
+ emake clean || die "emake clean failed"
emake OPTFLAGS="${CFLAGS}" || die "sdl build failed"
fi
}
src_install() {
dodoc *.txt
- insinto "${GAMES_LIBDIR}/psemu/cfg"
- doins gpuPeopsSoftX.cfg
- exeinto "${GAMES_LIBDIR}/psemu/plugins"
+ insinto "$(games_get_libdir)"/psemu/cfg
+ doins gpuPeopsSoftX.cfg || die "doins failed"
+ exeinto "$(games_get_libdir)"/psemu/plugins
doexe src/libgpuPeops* || die "doexe failed"
- exeinto "${GAMES_LIBDIR}/psemu/cfg"
+ exeinto "$(games_get_libdir)"/psemu/cfg
doexe src/cfgPeopsSoft || die "doexe failed"
prepgamesdirs
}