summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-03-31 06:59:59 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-03-31 06:59:59 +0000
commit3ee677edf1948d4aa73a506f5e94390ad3440096 (patch)
tree89ee9970b97326cebaab09079020e92774a1eb0e /games-emulation
parentPackage-Manager: portage-2.0.51.19 (diff)
downloadhistorical-3ee677edf1948d4aa73a506f5e94390ad3440096.tar.gz
historical-3ee677edf1948d4aa73a506f5e94390ad3440096.tar.bz2
historical-3ee677edf1948d4aa73a506f5e94390ad3440096.zip
version bump
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/xmess/ChangeLog7
-rw-r--r--games-emulation/xmess/Manifest4
-rw-r--r--games-emulation/xmess/files/digest-xmess-0.951
-rw-r--r--games-emulation/xmess/xmess-0.95.ebuild209
4 files changed, 219 insertions, 2 deletions
diff --git a/games-emulation/xmess/ChangeLog b/games-emulation/xmess/ChangeLog
index 5b2dcd524a50..87311de41154 100644
--- a/games-emulation/xmess/ChangeLog
+++ b/games-emulation/xmess/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/xmess
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/ChangeLog,v 1.24 2005/03/17 03:12:09 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/ChangeLog,v 1.25 2005/03/31 06:59:59 mr_bones_ Exp $
+
+*xmess-0.95 (31 Mar 2005)
+
+ 31 Mar 2005; Michael Sterrett <mr_bones_@gentoo.org> +xmess-0.95.ebuild:
+ version bump
*xmess-0.94 (16 Mar 2005)
diff --git a/games-emulation/xmess/Manifest b/games-emulation/xmess/Manifest
index 14cbb042e82d..338cb38544f1 100644
--- a/games-emulation/xmess/Manifest
+++ b/games-emulation/xmess/Manifest
@@ -1,4 +1,5 @@
-MD5 b13cd9f4179475604c879f6d433789e6 ChangeLog 3688
+MD5 1ab254c04e01dd2196371c50d9df5192 ChangeLog 3806
+MD5 b4e3f51811e533d52319578b9bf8d232 xmess-0.95.ebuild 5638
MD5 30c9b8b73945531fe1c8d554e29857db xmess-0.92.ebuild 5656
MD5 f74c4ee109477b5f5e721400ff5cc6ac xmess-0.94.ebuild 5736
MD5 0234d9024c471faf92bb1219242614ef metadata.xml 1566
@@ -15,6 +16,7 @@ MD5 0f77c568ca5f6a46b543e899c910d38a files/0.78.1-osd_die.patch 521
MD5 13dc5b32bbff98dec74c41dd0c9b33a1 files/0.80.1-glx-fix.patch 597
MD5 93b9c4a740015eb7262b223c7b8b7bbf files/0.80.1-icc.patch 584
MD5 a956d1afa6724941d56732f2b91f42eb files/0.80.1-make.patch 1243
+MD5 4510ec28e6e4e66892e55b85cbe5ea0a files/digest-xmess-0.95 65
MD5 240bd404f0deb6cd68bf6a98a5fb76db files/0.81.1-glx-fix.patch 386
MD5 240bd404f0deb6cd68bf6a98a5fb76db files/0.82.1-glx-fix.patch 386
MD5 240bd404f0deb6cd68bf6a98a5fb76db files/0.83.1-glx-fix.patch 386
diff --git a/games-emulation/xmess/files/digest-xmess-0.95 b/games-emulation/xmess/files/digest-xmess-0.95
new file mode 100644
index 000000000000..1e30fc9a4652
--- /dev/null
+++ b/games-emulation/xmess/files/digest-xmess-0.95
@@ -0,0 +1 @@
+MD5 e2571ce90bdf1517eea4d8085170fe6c xmame-0.95.tar.bz2 15460834
diff --git a/games-emulation/xmess/xmess-0.95.ebuild b/games-emulation/xmess/xmess-0.95.ebuild
new file mode 100644
index 000000000000..7de205fd2ca1
--- /dev/null
+++ b/games-emulation/xmess/xmess-0.95.ebuild
@@ -0,0 +1,209 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.95.ebuild,v 1.1 2005/03/31 06:59:59 mr_bones_ Exp $
+
+inherit flag-o-matic gcc eutils games
+
+TARGET="${PN}"
+
+DESCRIPTION="Multiple Arcade Machine Emulator for X11"
+HOMEPAGE="http://x.mame.net/"
+SRC_URI="http://x.mame.net/download/xmame-${PV}.tar.bz2"
+
+LICENSE="xmame"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="3dfx alsa arts dga esd expat ggi joystick mmx net opengl sdl svga X xv"
+
+RDEPEND="sys-libs/zlib
+ sdl? ( >=media-libs/libsdl-1.2.0 )
+ alsa? ( media-libs/alsa-lib )
+ xv? ( virtual/x11 )
+ dga? ( virtual/x11 )
+ X? ( virtual/x11 )
+ opengl? (
+ virtual/x11
+ virtual/opengl
+ virtual/glu )
+ expat? ( dev-libs/expat )
+ esd? ( >=media-sound/esound-0.2.29 )
+ svga? ( media-libs/svgalib )
+ ggi? ( media-libs/libggi )
+ arts? ( kde-base/arts )"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+# Icc sucks. bug #41342
+# icc? ( dev-lang/icc )
+
+S="${WORKDIR}/xmame-${PV}"
+
+toggle_feature() {
+ if use $1 ; then
+ sed -i \
+ -e "/$2.*=/s:#::" Makefile \
+ || die "sed Makefile ($1 / $2) failed"
+ fi
+}
+toggle_feature2() {
+ use $1 && toggle_feature $2 $3
+}
+
+src_unpack() {
+ local mycpu=
+
+ unpack ${A}
+ cd "${S}"
+
+ case ${ARCH} in
+ x86) mycpu="i386";;
+ ia64) mycpu="ia64";;
+ amd64) mycpu="amd64";;
+ ppc) mycpu="risc";;
+ sparc) mycpu="risc";;
+ hppa) mycpu="risc";;
+ alpha) mycpu="alpha";;
+ mips) mycpu="mips";;
+ esac
+
+ sed -i \
+ -e '/^BUILD_EXPAT/s/^/#/' \
+ -e "/^PREFIX/s:=.*:=/usr:" \
+ -e "/^MY_CPU/s:i386:${mycpu}:" \
+ -e "/^BINDIR/s:=.*:=${GAMES_BINDIR}:" \
+ -e "/^MANDIR/s:=.*:=/usr/share/man/man6:" \
+ -e "/^XMAMEROOT/s:=.*:=${GAMES_DATADIR}/${TARGET}:" \
+ -e "/^TARGET/s:mame:${TARGET:1}:" \
+ -e "/^CFLAGS =/d" \
+ Makefile \
+ || die "sed Makefile failed"
+
+ if use ppc ; then
+ sed -i \
+ -e '/LD.*--relax/s:^# ::' Makefile \
+ || die "sed Makefile (ppc/LD) failed"
+ fi
+
+
+ toggle_feature x86 X86_MIPS3_DRC
+ toggle_feature2 x86 mmx EFFECT_MMX_ASM
+ toggle_feature joystick JOY_STANDARD
+ use net && ewarn "Network support is currently (${PV}) broken :("
+ #toggle_feature net XMAME_NET # Broken
+ toggle_feature esd SOUND_ESOUND
+ toggle_feature alsa SOUND_ALSA
+ toggle_feature arts SOUND_ARTS
+ toggle_feature dga X11_DGA
+ toggle_feature xv X11_XV
+ toggle_feature expat BUILD_EXPAT
+ toggle_feature opengl X11_OPENGL
+
+ case ${ARCH} in
+ x86|ia64|amd64)
+ append-flags -Wno-unused -fomit-frame-pointer -fstrict-aliasing -fstrength-reduce
+ use amd64 || append-flags -ffast-math #54270
+ [ $(gcc-major-version) -eq 3 ] \
+ && append-flags -falign-functions=2 -falign-jumps=2 -falign-loops=2 \
+ || append-flags -malign-functions=2 -malign-jumps=2 -malign-loops=2
+ ;;
+ ppc)
+ append-flags -Wno-unused -funroll-loops -fstrength-reduce -fomit-frame-pointer -ffast-math -fsigned-char
+ ;;
+ hppa)
+ append-flags -ffunction-sections
+ ;;
+ esac
+
+ sed -i \
+ -e "s:[Xx]mame:${TARGET}:g" \
+ doc/*.6 \
+ || die "sed man pages failed"
+ # no, we don't want to install setuid (bug #81693)
+ sed -i \
+ -e 's/^doinstallsuid/notforus/' \
+ -e 's/doinstallsuid/doinstall/' \
+ -e '/^QUIET/s:^:#:' src/unix/unix.mak \
+ || die "sed src/unix/unix.mak failed"
+}
+
+src_compile() {
+ local disp=0
+ if use sdl ; then
+ emake DISPLAY_METHOD=SDL || die "emake failed (SDL)"
+ disp=1
+ fi
+ if use svga ; then
+ emake DISPLAY_METHOD=svgalib || die "emake failed (svgalib)"
+ disp=1
+ fi
+ if use ggi ; then
+ #emake DISPLAY_METHOD=ggi || die "emake failed (ggi)"
+ #disp=1
+ ewarn "GGI support is currently (${PV}) broken :("
+ fi
+ if [ ${disp} -eq 0 ] || use opengl || use X || use dga || use xv ; then
+ emake DISPLAY_METHOD=x11 || die "emake failed (x11)"
+ fi
+}
+
+src_install() {
+ local disp=0
+
+ sed -i \
+ -e "s:^PREFIX.*:PREFIX=${D}/usr:" \
+ -e "s:^BINDIR.*:BINDIR=${D}/${GAMES_BINDIR}:" \
+ -e "s:^MANDIR.*:MANDIR=${D}/usr/share/man/man6:" \
+ -e "s:^XMAMEROOT.*:XMAMEROOT=${D}/${GAMES_DATADIR}/${TARGET}:" \
+ Makefile \
+ || die "sed Makefile failed"
+
+ if use sdl ; then
+ make DISPLAY_METHOD=SDL install || die "install failed (sdl)"
+ disp=1
+ fi
+ if use svga ; then
+ make DISPLAY_METHOD=svgalib install || die "install failed (svga)"
+ disp=1
+ fi
+ if use ggi ; then
+ #make DISPLAY_METHOD=ggi install || die "install failed (ggi)"
+ #disp=1
+ ewarn "GGI support is currently (${PV}) broken :("
+ fi
+ if [ ${disp} -eq 0 ] || use opengl || use X || use dga || use xv ; then
+ make DISPLAY_METHOD=x11 install || die "install failed (x11)"
+ fi
+ exeinto "${GAMES_LIBDIR}/${PN}"
+ doexe chdman || die "doexe failed"
+ if [[ ${PN} == "xmame" ]] ; then
+ doexe xml2info || die "doexe failed"
+ fi
+
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r ctrlr "${D}/${GAMES_DATADIR}/${PN}/" || die "cp failed"
+ dodoc doc/{changes.*,*.txt,mame/*,${TARGET}rc.dist} README todo \
+ || die "dodoc failed"
+ dohtml -r doc/* || die "dohtml failed"
+
+ # default to sdl since the client is a bit more featureful
+ if use sdl ; then
+ dosym "${TARGET}.SDL" "${GAMES_BINDIR}/${TARGET}"
+ elif [ ${disp} -eq 0 ] || use opengl || use X || use dga || use xv ; then
+ dosym "${TARGET}.x11" "${GAMES_BINDIR}/${TARGET}"
+ elif use svga ; then
+ dosym ${TARGET}.svgalib "${GAMES_BINDIR}/${TARGET}"
+ #elif use ggi ; then
+ #dosym ${TARGET}.ggi "${GAMES_BINDIR}/${TARGET}"
+ fi
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "Your available MAME binaries are: ${TARGET}"
+ if useq opengl || useq X || useq dga || useq xv ; then
+ einfo " ${TARGET}.x11"
+ fi
+ useq sdl && einfo " ${TARGET}.SDL"
+ #useq ggi && einfo " ${TARGET}.ggi"
+ useq svga && einfo " ${TARGET}.svgalib"
+}