summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-04-11 16:19:13 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-04-11 16:19:13 +0000
commit4566b01281e3b51602da1ae91b02ef71643fb9dd (patch)
treec52f87e30a2d2af088ba7fa4c060d2151a96a8a7 /games-emulation
parentNew version, see bug #83646 (diff)
downloadhistorical-4566b01281e3b51602da1ae91b02ef71643fb9dd.tar.gz
historical-4566b01281e3b51602da1ae91b02ef71643fb9dd.tar.bz2
historical-4566b01281e3b51602da1ae91b02ef71643fb9dd.zip
version bump
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/advancemame/ChangeLog8
-rw-r--r--games-emulation/advancemame/Manifest5
-rw-r--r--games-emulation/advancemame/advancemame-0.95.0.ebuild84
-rw-r--r--games-emulation/advancemame/files/0.95.0-pic.patch13
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.95.01
5 files changed, 109 insertions, 2 deletions
diff --git a/games-emulation/advancemame/ChangeLog b/games-emulation/advancemame/ChangeLog
index 68f3b5ec9dd4..3b2591ce0dd3 100644
--- a/games-emulation/advancemame/ChangeLog
+++ b/games-emulation/advancemame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/advancemame
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.27 2005/04/02 20:53:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.28 2005/04/11 16:19:13 mr_bones_ Exp $
+
+*advancemame-0.95.0 (11 Apr 2005)
+
+ 11 Apr 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/0.95.0-pic.patch, +advancemame-0.95.0.ebuild:
+ version bump
02 Apr 2005; Michael Sterrett <mr_bones_@gentoo.org>
-files/0.92.0-pic.patch, -files/0.92.1-pic.patch, -files/0.89.0-pic.patch,
diff --git a/games-emulation/advancemame/Manifest b/games-emulation/advancemame/Manifest
index 694325c9dce9..74ea9de8de03 100644
--- a/games-emulation/advancemame/Manifest
+++ b/games-emulation/advancemame/Manifest
@@ -1,5 +1,8 @@
-MD5 5dc64c3a59717d313a2bba60a80e979a ChangeLog 5251
MD5 972b8c9f939a33a7074e0819fb55455c metadata.xml 962
MD5 b2dff050faa7ce859ea2e2f4d7c39368 advancemame-0.94.0.ebuild 1994
+MD5 48b0aac93c0c286ca90a9a6405bcdb8a advancemame-0.95.0.ebuild 1994
+MD5 69f438ba4e55b7cdc98ef89fac291b6e ChangeLog 5412
MD5 0727e29d4a4d201dc55062d7e2c740e7 files/digest-advancemame-0.94.0 72
+MD5 893791a430019a7eb1c0eaf15758a93f files/0.95.0-pic.patch 344
MD5 893791a430019a7eb1c0eaf15758a93f files/0.94.0-pic.patch 344
+MD5 1b789ea9eb6e14eb14582618b754d5fc files/digest-advancemame-0.95.0 72
diff --git a/games-emulation/advancemame/advancemame-0.95.0.ebuild b/games-emulation/advancemame/advancemame-0.95.0.ebuild
new file mode 100644
index 000000000000..4e65ff8e726a
--- /dev/null
+++ b/games-emulation/advancemame/advancemame-0.95.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.95.0.ebuild,v 1.1 2005/04/11 16:19:13 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
+HOMEPAGE="http://advancemame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
+
+LICENSE="GPL-2 xmame"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE="alsa expat fbcon oss sdl slang static svga truetype zlib"
+
+RDEPEND="virtual/libc
+ app-arch/unzip
+ app-arch/zip
+ sdl? ( media-libs/libsdl )
+ slang? ( sys-libs/slang )
+ alsa? ( media-libs/alsa-lib )
+ expat? ( >=dev-libs/expat-1.95.6 )
+ zlib? ( sys-libs/zlib )
+ truetype? ( media-libs/freetype )
+ svga? ( >=media-libs/svgalib-1.9 )"
+DEPEND="${RDEPEND}
+ x86? ( >=dev-lang/nasm-0.98 )
+ virtual/os-headers"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-pic.patch" #74899
+
+ use x86 && \
+ ln -s $(which nasm) "${T}/${CHOST}-nasm"
+ use sdl && \
+ ln -s $(which sdl-config) "${T}/${CHOST}-sdl-config"
+ use truetype && \
+ ln -s $(which freetype-config) "${T}/${CHOST}-freetype-config"
+}
+
+src_compile() {
+ PATH="${PATH}:${T}"
+ egamesconf \
+ $(use_enable alsa) \
+ $(use_enable expat) \
+ $(use_enable fbcon fb) \
+ $(use_enable oss) \
+ $(use_enable sdl) \
+ $(use_enable slang) \
+ $(use_enable static) \
+ $(use_enable svga svgalib) \
+ $(use_enable truetype freetype) \
+ $(use_enable zlib) \
+ $(use_enable x86 asm) \
+ --with-emu=${PN/advance} \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ local f
+
+ for f in adv* ; do
+ if [ -L "${f}" ] ; then
+ dogamesbin "${f}" || die "dogamesbin failed"
+ fi
+ done
+
+ insinto "${GAMES_DATADIR}/advance"
+ doins support/event.dat
+ keepdir "${GAMES_DATADIR}/advance/"{artwork,diff,image,rom,sample,snap}
+
+ dodoc HISTORY README RELEASE
+ cd doc
+ dodoc *.txt
+ dohtml *.html
+ for f in *.1 ; do
+ newman ${f} ${f/1/6}
+ done
+
+ prepgamesdirs
+}
diff --git a/games-emulation/advancemame/files/0.95.0-pic.patch b/games-emulation/advancemame/files/0.95.0-pic.patch
new file mode 100644
index 000000000000..049befbfac2c
--- /dev/null
+++ b/games-emulation/advancemame/files/0.95.0-pic.patch
@@ -0,0 +1,13 @@
+--- ./advance/blit/blit.c.orig 2004-12-19 01:01:46.039956536 -0500
++++ ./advance/blit/blit.c 2004-12-19 01:01:19.566981040 -0500
+@@ -28,6 +28,10 @@
+ * do so, delete this exception statement from your version.
+ */
+
++#if defined(USE_ASM_INLINE) && defined(__PIC__)
++# undef USE_ASM_INLINE
++#endif
++
+ #include "portable.h"
+
+ #include "blit.h"
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.95.0 b/games-emulation/advancemame/files/digest-advancemame-0.95.0
new file mode 100644
index 000000000000..980e86f8b6fa
--- /dev/null
+++ b/games-emulation/advancemame/files/digest-advancemame-0.95.0
@@ -0,0 +1 @@
+MD5 e487ced9e9bf396f79646ed50ecb0b41 advancemame-0.95.0.tar.gz 14656588