summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2005-04-17 22:39:37 +0000
committerDaniel Goller <morfic@gentoo.org>2005-04-17 22:39:37 +0000
commit5d28cc866f0bf3e42549a4b21fb19d47fef2b4a7 (patch)
tree340174e90dcd40524048cfc7b410af31f2a514f1 /games-emulation
parentUnmask xchat-xsys 1.9.3 (diff)
downloadhistorical-5d28cc866f0bf3e42549a4b21fb19d47fef2b4a7.tar.gz
historical-5d28cc866f0bf3e42549a4b21fb19d47fef2b4a7.tar.bz2
historical-5d28cc866f0bf3e42549a4b21fb19d47fef2b4a7.zip
fix dependency logic/defaults
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mupen64-alsasnd/ChangeLog5
-rw-r--r--games-emulation/mupen64-alsasnd/Manifest10
-rw-r--r--games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild15
3 files changed, 14 insertions, 16 deletions
diff --git a/games-emulation/mupen64-alsasnd/ChangeLog b/games-emulation/mupen64-alsasnd/ChangeLog
index 9877f9633c7e..c3dc8f2e06ac 100644
--- a/games-emulation/mupen64-alsasnd/ChangeLog
+++ b/games-emulation/mupen64-alsasnd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/mupen64-alsasnd
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/ChangeLog,v 1.4 2005/04/17 21:56:05 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/ChangeLog,v 1.5 2005/04/17 22:39:37 morfic Exp $
+
+ 17 Apr 2005; Daniel Goller <morfic@gentoo.org> mupen64-alsasnd-0.4.ebuild:
+ fix dependency logic/defaults
17 Apr 2005; Daniel Goller <morfic@gentoo.org> mupen64-alsasnd-0.4.ebuild:
add missing IUSE
diff --git a/games-emulation/mupen64-alsasnd/Manifest b/games-emulation/mupen64-alsasnd/Manifest
index fab6fbb3008b..e2c967f3bcdf 100644
--- a/games-emulation/mupen64-alsasnd/Manifest
+++ b/games-emulation/mupen64-alsasnd/Manifest
@@ -1,8 +1,8 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 64066a80f873689d679fc82ebba96a87 mupen64-alsasnd-0.4.ebuild 1525
-MD5 41384aeeefd76d3ebd7e3e46ec1b3270 ChangeLog 687
+MD5 d4c259d60e8be7d203961000e3894a28 mupen64-alsasnd-0.4.ebuild 1415
+MD5 6875daf698c78fa0c949f48420f288b1 ChangeLog 797
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 658b03e564090a62ea13902273e73ae4 files/digest-mupen64-alsasnd-0.4 70
MD5 49a9052e77c664f4a2c6b092c62b39f6 files/0.4-gentoo.patch 560
@@ -10,7 +10,7 @@ MD5 15dd3b6cd3a33e7fcba000b2b38b9bd2 files/0.4-gtk.patch 1203
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
-iD8DBQFCYtyyUpKYMelfdYERAiWvAJ9+8K4rn156yGCWDyANiXiHXdiHjwCaAkj7
-Bq/yetADvnRMU4pMcaUX/Bc=
-=Zk0Y
+iD8DBQFCYubhUpKYMelfdYERApRmAJ9K+Vmce6OFYXYogJrUTclCycM6UgCgjIUr
+nV9q81fkvKulbQCFpk+nODw=
+=k0Sj
-----END PGP SIGNATURE-----
diff --git a/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild b/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild
index 0fabe52ca759..515605964200 100644
--- a/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild
+++ b/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild,v 1.8 2005/04/17 21:56:05 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild,v 1.9 2005/04/17 22:39:37 morfic Exp $
inherit games eutils
@@ -16,9 +16,10 @@ RESTRICT="fetch"
DEPEND=">=media-libs/alsa-lib-0.9.0
|| (
- gtk? ( =x11-libs/gtk+-1* )
- gtk2? ( =x11-libs/gtk+-2* )
+ gtk? ( !gtk2? (=x11-libs/gtk+-1* )
+ gtk2? ( =x11-libs/gtk+-2* ) )
qt? ( >=x11-libs/qt-3 )
+ =x11-libs/gtk+-2*
)"
S="${WORKDIR}/alsa_plugin"
@@ -29,13 +30,6 @@ pkg_nofetch() {
einfo "Then just put ${A} in ${DISTDIR} !"
}
-pkg_setup() {
- if ! use gtk && ! use gtk2 && ! use qt ; then
- eerror "You must choose either gtk, gtk2 or qt as interface"
- die "User Choice of Interface required"
- fi
-}
-
src_unpack() {
unpack ${A}
cd "${S}"
@@ -44,6 +38,7 @@ src_unpack() {
}
src_compile() {
+ export GRAPHICAL_INTERFACE=gtk2
use qt && export GRAPHICAL_INTERFACE=qt3
use gtk && export GRAPHICAL_INTERFACE=gtk1
use gtk2 && export GRAPHICAL_INTERFACE=gtk2