summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2007-04-06 05:47:54 +0000
committerTristan Heaven <tristan@gentoo.org>2007-04-06 05:47:54 +0000
commit644abe84a2bf0dafa33285130bece8316844082d (patch)
treea248263ce612004b8f65dbd5764507ce60f3b9d7 /games-emulation
parentBump to 2.0RC4. 965GM support and several fixes. (diff)
downloadhistorical-644abe84a2bf0dafa33285130bece8316844082d.tar.gz
historical-644abe84a2bf0dafa33285130bece8316844082d.tar.bz2
historical-644abe84a2bf0dafa33285130bece8316844082d.zip
use games_get_libdir
Package-Manager: portage-2.1.2.3
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild21
-rw-r--r--games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild21
-rw-r--r--games-emulation/pcsx/pcsx-1.5-r1.ebuild8
3 files changed, 25 insertions, 25 deletions
diff --git a/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild b/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild
index 3294d0aa5e0d..28400e0f50a9 100644
--- a/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild
+++ b/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild,v 1.9 2007/02/22 05:23:18 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild,v 1.10 2007/04/06 05:42:40 nyhm Exp $
inherit flag-o-matic eutils games
@@ -25,11 +25,12 @@ src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${P}-compile.patch" \
- "${FILESDIR}/${P}-inifix.patch" \
- "${FILESDIR}/${P}-gtk2.patch"
+ epatch \
+ "${FILESDIR}"/${P}-compile.patch \
+ "${FILESDIR}"/${P}-inifix.patch \
+ "${FILESDIR}"/${P}-gtk2.patch
- make clean || die "couldn't clean"
+ emake -j1 clean
# gcc 3.4 at least has a problem with -O3 and inline asm
replace-flags -O3 -O2
@@ -38,7 +39,7 @@ src_unpack() {
sed -i \
-e "s:CFLAGS.*=\(.*\):CFLAGS=\1 ${CFLAGS}:" \
Makefile \
- || die "sed failed"
+ || die "sed failed"
}
src_compile() {
@@ -46,9 +47,9 @@ src_compile() {
}
src_install() {
- exeinto "${GAMES_LIBDIR}/mupen64/plugins"
+ exeinto "$(games_get_libdir)"/mupen64/plugins
doexe Glide64.so || die "doexe failed"
- insinto "${GAMES_LIBDIR}/mupen64/plugins"
- doins Glide64.ini
+ insinto "$(games_get_libdir)"/mupen64/plugins
+ doins Glide64.ini || die "doins failed"
prepgamesdirs
}
diff --git a/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild b/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild
index d86d38245798..284fbdceeb42 100644
--- a/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild
+++ b/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild,v 1.10 2006/06/01 18:51:02 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild,v 1.11 2007/04/06 05:46:11 nyhm Exp $
-inherit toolchain-funcs eutils libtool flag-o-matic games
+inherit toolchain-funcs eutils flag-o-matic games
DESCRIPTION="an graphics plugin for mupen64"
SRC_URI="http://mupen64.emulation64.com/files/0.4/riceplugin.tar.bz2"
@@ -18,17 +18,16 @@ RDEPEND="sys-libs/zlib
media-libs/libsdl
virtual/glu
virtual/opengl"
-
DEPEND="${RDEPEND}
dev-lang/nasm"
-S="${WORKDIR}/riceplugin"
+S=${WORKDIR}/riceplugin
src_unpack() {
unpack ${A}
cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-makefile.patch \
+ epatch \
+ "${FILESDIR}"/${PN}-makefile.patch \
"${FILESDIR}"/${PN}-gtk2.patch \
"${FILESDIR}"/${PN}-compile.patch \
"${FILESDIR}"/${PN}-gcc4.patch
@@ -40,9 +39,9 @@ src_compile() {
}
src_install() {
- exeinto "${GAMES_LIBDIR}"/mupen64/plugins
- doexe *.so
- insinto "${GAMES_LIBDIR}"/mupen64/plugins
- doins *.ini
+ exeinto "$(games_get_libdir)"/mupen64/plugins
+ doexe *.so || die "doexe failed"
+ insinto "$(games_get_libdir)"/mupen64/plugins
+ doins *.ini || die "doins failed"
prepgamesdirs
}
diff --git a/games-emulation/pcsx/pcsx-1.5-r1.ebuild b/games-emulation/pcsx/pcsx-1.5-r1.ebuild
index 9e3fdfc637b8..2e0fbf6490d8 100644
--- a/games-emulation/pcsx/pcsx-1.5-r1.ebuild
+++ b/games-emulation/pcsx/pcsx-1.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx/pcsx-1.5-r1.ebuild,v 1.10 2007/02/24 00:53:40 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx/pcsx-1.5-r1.ebuild,v 1.11 2007/04/06 05:47:54 nyhm Exp $
inherit eutils games
@@ -36,14 +36,14 @@ src_unpack() {
"${FILESDIR}"/${PV}-gentoo.patch \
"${FILESDIR}"/${P}-gcc41.patch
sed -i \
- -e "s:Plugin/:${GAMES_LIBDIR}/psemu/plugins/:" \
- -e "s:Bios/:${GAMES_LIBDIR}/psemu/bios/:" \
+ -e "s:Plugin/:$(games_get_libdir)/psemu/plugins/:" \
+ -e "s:Bios/:$(games_get_libdir)/psemu/bios/:" \
-e 's:Pcsx.cfg:~/.pcsx/config:' \
Linux/LnxMain.c \
|| die "sed LnxMain.c failed"
sed \
-e "s:GAMES_DATADIR:${GAMES_DATADIR}:" \
- -e "s:GAMES_LIBDIR:${GAMES_LIBDIR}:" \
+ -e "s:GAMES_LIBDIR:$(games_get_libdir):" \
-e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
"${FILESDIR}"/pcsx > "${T}"/pcsx \
|| die "sed failed"