summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-08-29 06:25:33 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-08-29 06:25:33 +0000
commit1cd678d4a771f2e16c70ae986a77b7611a2a44fa (patch)
tree4fd4db8ecad762a37997aa1a92f377c03ffd9cf5 /games-roguelike/scourge/scourge-0.20.ebuild
parentversion bump (diff)
downloadhistorical-1cd678d4a771f2e16c70ae986a77b7611a2a44fa.tar.gz
historical-1cd678d4a771f2e16c70ae986a77b7611a2a44fa.tar.bz2
historical-1cd678d4a771f2e16c70ae986a77b7611a2a44fa.zip
Version bump to 0.20. Bug #222667
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'games-roguelike/scourge/scourge-0.20.ebuild')
-rw-r--r--games-roguelike/scourge/scourge-0.20.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/games-roguelike/scourge/scourge-0.20.ebuild b/games-roguelike/scourge/scourge-0.20.ebuild
new file mode 100644
index 000000000000..4889a6fa9a5b
--- /dev/null
+++ b/games-roguelike/scourge/scourge-0.20.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/scourge-0.20.ebuild,v 1.1 2008/08/29 06:25:33 tupone Exp $
+
+inherit autotools eutils wxwidgets games
+
+DESCRIPTION="A graphical rogue-like adventure game"
+HOMEPAGE="http://scourgeweb.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.src.tar.gz
+ mirror://sourceforge/${PN}/${P}.data.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/glu
+ virtual/opengl
+ >=media-libs/freetype-2
+ media-libs/libsdl
+ media-libs/sdl-net
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ virtual/libintl
+ "
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ eautoreconf
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-data-dir="${GAMES_DATADIR}"/${PN} \
+ --localedir=/usr/share/locale \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r ../scourge_data/* || die "doins failed"
+ doicon assets/scourge.png
+ make_desktop_entry scourge S.C.O.U.R.G.E.
+ dodoc AUTHORS README
+ prepgamesdirs
+}