summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-07-03 02:13:53 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-07-03 02:13:53 +0000
commit7260f4669c0c3a5dcc85a40fb47204542a721bc9 (patch)
treedd2eb50355de06c3574035ca970cdebc1a56575d /games-simulation
parentbump x11-plugins/wmix to version 3.1. (diff)
downloadhistorical-7260f4669c0c3a5dcc85a40fb47204542a721bc9.tar.gz
historical-7260f4669c0c3a5dcc85a40fb47204542a721bc9.tar.bz2
historical-7260f4669c0c3a5dcc85a40fb47204542a721bc9.zip
don't mess with MAKEOPTS; unpack in unpack; use games eclass functions; tidy
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/openttd/ChangeLog6
-rw-r--r--games-simulation/openttd/Manifest4
-rw-r--r--games-simulation/openttd/openttd-20040626.ebuild50
3 files changed, 30 insertions, 30 deletions
diff --git a/games-simulation/openttd/ChangeLog b/games-simulation/openttd/ChangeLog
index 6f6dce9df198..b30ba32f7fd7 100644
--- a/games-simulation/openttd/ChangeLog
+++ b/games-simulation/openttd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/openttd
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.1 2004/06/26 22:25:55 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.2 2004/07/03 02:13:53 mr_bones_ Exp $
+
+ 02 Jul 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ openttd-20040626.ebuild:
+ don't mess with MAKEOPTS; unpack in unpack; use games eclass functions; tidy
*openttd-20040626 (27 Jun 2004)
diff --git a/games-simulation/openttd/Manifest b/games-simulation/openttd/Manifest
index ce5f3a7cb953..0069855617be 100644
--- a/games-simulation/openttd/Manifest
+++ b/games-simulation/openttd/Manifest
@@ -1,4 +1,4 @@
-MD5 26380f62595167717b1fec268b79d36c ChangeLog 419
-MD5 9f9f7e01569f1bbca615c97d8d70fc01 openttd-20040626.ebuild 2230
+MD5 271f057ab4c3744b17703eb9f706eb53 ChangeLog 585
MD5 7efefbbe81a05cbc5d4e96203f047fda metadata.xml 245
+MD5 37b0940b191ce0d7ccabd9c05aef7ee0 openttd-20040626.ebuild 2157
MD5 d843b4d40c78f879ad70c5cc231bd815 files/digest-openttd-20040626 133
diff --git a/games-simulation/openttd/openttd-20040626.ebuild b/games-simulation/openttd/openttd-20040626.ebuild
index 5cc15106a24f..a35d868f130c 100644
--- a/games-simulation/openttd/openttd-20040626.ebuild
+++ b/games-simulation/openttd/openttd-20040626.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-20040626.ebuild,v 1.1 2004/06/26 22:25:55 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-20040626.ebuild,v 1.2 2004/07/03 02:13:53 mr_bones_ Exp $
inherit games
@@ -8,10 +8,12 @@ DESCRIPTION="OpenTTD is a clone of Transport Tycoon Deluxe"
HOMEPAGE="http://www.openttd.com/"
SRC_URI="mirror://gentoo/${P}.tar.bz2
mirror://sourceforge/openttd/openttd-useful.zip"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
IUSE="debug png zlib"
+
DEPEND="virtual/libc
media-libs/libsdl
media-sound/timidity++
@@ -23,43 +25,37 @@ src_unpack() {
unpack ${P}.tar.bz2
# unpack the title screen
- mkdir ${WORKDIR}/useful
- cd ${WORKDIR}/useful
+ mkdir "${WORKDIR}/useful"
+ cd "${WORKDIR}/useful"
unpack openttd-useful.zip
+
+ # openttd doesn't create ~/.openttd/ so we must do that inside the wrapper
+ cat << EOF > "${T}/openttd"
+#!/bin/sh
+test -d ~/.openttd/ || mkdir -p ~/.openttd
+cd ${GAMES_BINDIR}
+exec ./ttd -m extmidi "\$@"
+EOF
+
}
src_compile() {
- # parallel make causes problems
- MAKEOPTS="${MAKEOPTS} -j1"
-
local myopts="MANUAL_CONFIG=1 UNIX=1 WITH_SDL=1 WITH_NETWORK=1 USE_HOMEDIR=1 PERSONAL_DIR=.openttd GAME_DATA_DIR=${GAMES_DATADIR}/${PN}/"
use debug && myopts="${myopts} DEBUG=1"
use png && myopts="${myopts} WITH_PNG=1"
use zlib && myopts="${myopts} WITH_ZLIB=1"
- emake ${myopts} || die "emake failed"
+ emake -j1 ${myopts} || die "emake failed"
}
src_install() {
- exeinto ${GAMES_BINDIR}
- doexe ttd
-
- # openttd doesn't create ~/.openttd/ so we must do that inside the wrapper
- #games_make_wrapper openttd "./ttd -m extmidi" ${GAMES_BINDIR}
-
- cat << EOF > ${D}/${GAMES_BINDIR}/openttd
-#!/bin/sh
-test -d ~/.openttd/ || mkdir -p ~/.openttd
-cd ${GAMES_BINDIR}
-exec ./ttd -m extmidi "\$@"
-EOF
+ dogamesbin "${T}/openttd" ttd || die "dogamesbin failed"
- insinto ${GAMES_DATADIR}/${PN}/data
- doins data/*
- doins ${WORKDIR}/useful/opntitle.dat
+ insinto "${GAMES_DATADIR}/${PN}/data"
+ doins data/* "${WORKDIR}/useful/opntitle.dat" || die "doins failed"
- insinto ${GAMES_DATADIR}/${PN}/lang
- doins lang/*.lng
+ insinto "${GAMES_DATADIR}/${PN}/lang"
+ doins lang/*.lng || die "doins failed"
insinto /usr/share/pixmaps
newins media/icon128.png openttd.png
@@ -74,10 +70,10 @@ pkg_postinst() {
einfo "In order to play, you must copy the following 6 files from "
einfo "the *WINDOWS* version of TTD to ${GAMES_DATADIR}/${PN}/data/"
- einfo ""
+ echo
einfo "sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
- einfo ""
+ echo
einfo "If you want music, you must copy the gm/ directory"
einfo "to ${GAMES_DATADIR}/${PN}/"
- einfo ""
+ echo
}