summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2007-06-16 21:02:27 +0000
committerTristan Heaven <tristan@gentoo.org>2007-06-16 21:02:27 +0000
commitdfd447b3a1bb88808d512f24799562c92f5afe69 (patch)
tree0955de0c34cfd3184fd1d256ea5a727df5c90a9c /games-strategy/outerspace/outerspace-0.5.64.ebuild
parentAdded maintainer. (diff)
downloadhistorical-dfd447b3a1bb88808d512f24799562c92f5afe69.tar.gz
historical-dfd447b3a1bb88808d512f24799562c92f5afe69.tar.bz2
historical-dfd447b3a1bb88808d512f24799562c92f5afe69.zip
Version bump
Package-Manager: portage-2.1.3_rc2
Diffstat (limited to 'games-strategy/outerspace/outerspace-0.5.64.ebuild')
-rw-r--r--games-strategy/outerspace/outerspace-0.5.64.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-strategy/outerspace/outerspace-0.5.64.ebuild b/games-strategy/outerspace/outerspace-0.5.64.ebuild
new file mode 100644
index 000000000000..45a750009710
--- /dev/null
+++ b/games-strategy/outerspace/outerspace-0.5.64.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/outerspace-0.5.64.ebuild,v 1.1 2007/06/16 21:02:27 nyhm Exp $
+
+inherit eutils games
+
+MY_PN=${PN/outerspace/OuterSpace}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="on-line strategy game taking place in the dangerous universe"
+HOMEPAGE="http://www.ospace.net/"
+SRC_URI="mirror://sourceforge/ospace/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pygame-1.7
+ >=dev-lang/python-2.4"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ -e "s:@GENTOO_LIBDIR@:$(games_get_libdir)/${PN}:" \
+ "${FILESDIR}"/${PN} > ${PN} \
+ || die "sed failed"
+}
+
+src_install() {
+ insinto "$(games_get_libdir)"/${PN}
+ doins -r osc.py lib libsrvr || die "doins lib failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r res || die "doins data failed"
+ dogamesbin ${PN} || die "dogamesbin failed"
+ newicon res/icon32.png ${PN}.png
+ make_desktop_entry ${PN} ${MY_PN}
+ prepgamesdirs
+}