summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-11-09 03:13:24 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-11-09 03:13:24 +0000
commitbf80049620a573dbd8618d12da7d19c04868577c (patch)
tree357b1b5a76884a0fa2b100b32b17209f33f59a1f /games-strategy/spacehulk
parentversion bump (diff)
downloadhistorical-bf80049620a573dbd8618d12da7d19c04868577c.tar.gz
historical-bf80049620a573dbd8618d12da7d19c04868577c.tar.bz2
historical-bf80049620a573dbd8618d12da7d19c04868577c.zip
version bump
Diffstat (limited to 'games-strategy/spacehulk')
-rw-r--r--games-strategy/spacehulk/Manifest4
-rw-r--r--games-strategy/spacehulk/files/digest-spacehulk-1.4.992
-rw-r--r--games-strategy/spacehulk/spacehulk-1.4.99.ebuild33
3 files changed, 37 insertions, 2 deletions
diff --git a/games-strategy/spacehulk/Manifest b/games-strategy/spacehulk/Manifest
index 4077b73e078a..d0eeaf2be555 100644
--- a/games-strategy/spacehulk/Manifest
+++ b/games-strategy/spacehulk/Manifest
@@ -1,8 +1,8 @@
-MD5 411332caecc5f057eaa36a2c424632dc ChangeLog 666
+MD5 5ae929b7ae3e6308508d106b1430d2f8 ChangeLog 800
MD5 ebfb43ab7f755a85b9b748c856252781 spacehulk-1.4.3.ebuild 925
MD5 d8fbdadabf76e88420c031145ded26d3 spacehulk-1.4.4.ebuild 925
MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
-MD5 08d36811e7b9f834af65ac9437ddc418 spacehulk-1.4.99.ebuild 1041
+MD5 033aa41b69f4b7168d6c77af787cb79b spacehulk-1.4.99.ebuild 1045
MD5 e85894dd2ba2799879e477d80eb2c527 spacehulk-1.4.5.ebuild 925
MD5 3da58dc2f4e345288ee5bbe8058f93be files/digest-spacehulk-1.4.3 143
MD5 ae56cfc18bb656e1e2e006662d51af3a files/digest-spacehulk-1.4.4 143
diff --git a/games-strategy/spacehulk/files/digest-spacehulk-1.4.99 b/games-strategy/spacehulk/files/digest-spacehulk-1.4.99
new file mode 100644
index 000000000000..ea0e07aa44aa
--- /dev/null
+++ b/games-strategy/spacehulk/files/digest-spacehulk-1.4.99
@@ -0,0 +1,2 @@
+MD5 e240be6302bd70cd75113436433c58c4 spacehulk-1.4.99.tar.gz 887335
+MD5 2d60fcf80e726656121cf6e6ef3a52f9 spacehulk-themespack-1.0.tar.gz 198051
diff --git a/games-strategy/spacehulk/spacehulk-1.4.99.ebuild b/games-strategy/spacehulk/spacehulk-1.4.99.ebuild
new file mode 100644
index 000000000000..042055dacf56
--- /dev/null
+++ b/games-strategy/spacehulk/spacehulk-1.4.99.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/spacehulk/spacehulk-1.4.99.ebuild,v 1.1 2003/11/09 03:13:16 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A boardgame in the world of Warhammer 40k"
+HOMEPAGE="http://r.vinot.free.fr/spacehulk/"
+SRC_URI="http://freesoftware.fsf.org/download/spacehulk/main.pkg/${PV}/${P}.tar.gz
+ http://freesoftware.fsf.org/download/spacehulk/themespack.pkg/1.0/spacehulk-themespack-1.0.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+IUSE="xinerama"
+
+DEPEND=">=x11-libs/qt-3
+ sys-libs/zlib
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/nas"
+
+src_compile() {
+ egamesconf `use_with xinerama` || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ egamesinstall || die
+ cp -R ../themes/* ${D}${GAMES_DATADIR}/${PN}/themes || die "cp failed"
+ dodoc AUTHORS ChangeLog README TODO || die "dodoc failed"
+ prepgamesdirs
+}