summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-18 23:26:21 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-18 23:26:21 +0000
commit599dc43bc2eb2711e8c631e4433bdfef7f0fdb2b (patch)
tree6179a799a1f17eec543711082abb9b591578b2f0 /games-strategy
parenttesting version of gcc-3.3.3-r2, should be unmasked on the 20th (diff)
downloadhistorical-599dc43bc2eb2711e8c631e4433bdfef7f0fdb2b.tar.gz
historical-599dc43bc2eb2711e8c631e4433bdfef7f0fdb2b.tar.bz2
historical-599dc43bc2eb2711e8c631e4433bdfef7f0fdb2b.zip
version bump
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog7
-rw-r--r--games-strategy/wesnoth/Manifest4
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.7.31
-rw-r--r--games-strategy/wesnoth/wesnoth-0.7.3.ebuild40
4 files changed, 50 insertions, 2 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 7d122ec88cd4..37e5be8ddd49 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.19 2004/04/09 09:41:58 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.20 2004/04/18 23:26:21 mr_bones_ Exp $
+
+*wesnoth-0.7.3 (18 Apr 2004)
+
+ 18 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-0.7.3.ebuild:
+ version bump
*wesnoth-0.7.2 (09 Apr 2004)
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index a51818c12bac..56f0f5e0b825 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,8 +1,10 @@
MD5 4e2b8d7f20404e2ec067f052d1142fba wesnoth-0.7.ebuild 955
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 28e456711152a3db16430a0d5090b058 ChangeLog 2771
+MD5 af893cde1822416d506b93127e46c48b ChangeLog 2894
MD5 8e682d1d562a88ad935d27893417ffac wesnoth-0.7.2.ebuild 1011
MD5 68343aa5c3c7919a357a99c16b316431 wesnoth-0.7.1.ebuild 957
+MD5 22412e6a25826d9766dfc9574e5d27f5 wesnoth-0.7.3.ebuild 1042
MD5 2218dd653ddf591503d9bde5beb4df8c files/digest-wesnoth-0.7 65
MD5 943fc665866e98d256c99403826c7cbd files/digest-wesnoth-0.7.2 67
MD5 eed8758f69d700eedc02234ae1a428d8 files/digest-wesnoth-0.7.1 67
+MD5 30a5ab6c2f9337bb39ceb1fa8e5118c7 files/digest-wesnoth-0.7.3 67
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.7.3 b/games-strategy/wesnoth/files/digest-wesnoth-0.7.3
new file mode 100644
index 000000000000..c5ae8dc68b7f
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.7.3
@@ -0,0 +1 @@
+MD5 cde46ceb3d1342cda6cf512c7b182cab wesnoth-0.7.3.tar.gz 19715749
diff --git a/games-strategy/wesnoth/wesnoth-0.7.3.ebuild b/games-strategy/wesnoth/wesnoth-0.7.3.ebuild
new file mode 100644
index 000000000000..5bcd3033e455
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.7.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.7.3.ebuild,v 1.1 2004/04/18 23:26:21 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="http://www.wesnoth.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64 ppc ~sparc"
+IUSE="server editor tools gnome kde"
+
+DEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-ttf-2.0
+ media-libs/sdl-net
+ virtual/x11"
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ `use_enable server` \
+ `use_enable editor` \
+ `use_enable tools` \
+ `use_enable gnome` \
+ `use_enable kde` \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ mv "${D}${GAMES_DATADIR}/icons" "${D}/usr/share/"
+ dodoc MANUAL changelog || die "dodoc failed"
+ prepgamesdirs
+}