summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-10-05 10:02:19 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-10-05 10:02:19 +0000
commit528d4a6923d4ab0e90b921f527d84b2e526b0615 (patch)
treeb70f4804d9ed9ea69b60e341c7a3011d90f93865 /gnome-base/ORBit
parentremoved gnome-pilot-conduits (diff)
downloadhistorical-528d4a6923d4ab0e90b921f527d84b2e526b0615.tar.gz
historical-528d4a6923d4ab0e90b921f527d84b2e526b0615.tar.bz2
historical-528d4a6923d4ab0e90b921f527d84b2e526b0615.zip
updated to 0.5.10, changes at: http://mail.gnome.org/archives/gnome-announce-list/2001-October/msg00002.html
Diffstat (limited to 'gnome-base/ORBit')
-rw-r--r--gnome-base/ORBit/ORBit-0.5.10.ebuild54
-rw-r--r--gnome-base/ORBit/files/digest-ORBit-0.5.101
2 files changed, 55 insertions, 0 deletions
diff --git a/gnome-base/ORBit/ORBit-0.5.10.ebuild b/gnome-base/ORBit/ORBit-0.5.10.ebuild
new file mode 100644
index 000000000000..26e46c3d358c
--- /dev/null
+++ b/gnome-base/ORBit/ORBit-0.5.10.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/ORBit/ORBit-0.5.10.ebuild,v 1.1 2001/10/05 10:02:19 hallski Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A high-performance, lightweight CORBA ORB aiming for CORBA 2.2 compliance"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
+HOMEPAGE="http://www.labs.redhat.com/orbit/"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ >=sys-apps/tcp-wrappers-7.6
+ >=dev-libs/glib-1.2.8
+ >=gnome-base/gnome-env-1.0"
+
+RDEPEND="virtual/glibc
+ >=gnome-base/gnome-env-1.0
+ >=dev-libs/glib-1.2.8"
+
+
+src_compile() {
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --host=${CHOST} --prefix=/opt/gnome \
+ --sysconfdir=/etc/opt/gnome $myconf
+
+ assert "Configure failed."
+
+ make || die "Building failed." # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Installation failed."
+
+ dosed /opt/gnome/lib/*.la
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+ dodoc docs/*.txt docs/IDEA1
+ docinto idl
+
+ cd libIDL
+ dodoc AUTHORS BUGS COPYING NEWS README*
+ docinto popt
+
+ cd ../popt
+ dodoc CHANGES COPYING README
+}
+
+
+
+
diff --git a/gnome-base/ORBit/files/digest-ORBit-0.5.10 b/gnome-base/ORBit/files/digest-ORBit-0.5.10
new file mode 100644
index 000000000000..012708fa6d4a
--- /dev/null
+++ b/gnome-base/ORBit/files/digest-ORBit-0.5.10
@@ -0,0 +1 @@
+MD5 84e818d9f6fa4f389b9ea82aa00e8f6c ORBit-0.5.10.tar.gz