summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2006-08-09 23:05:26 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2006-08-09 23:05:26 +0000
commit652cc26704c6669bb76aeaf17c7ca811a95c1ab7 (patch)
treeb408e71bad256f2a37db8f5758a0fe8ec6e096d9 /gnome-base/eel/eel-2.14.3.ebuild
parentRemoving dependency on CVS snapshots for openal, to force users onto the new ... (diff)
downloadhistorical-652cc26704c6669bb76aeaf17c7ca811a95c1ab7.tar.gz
historical-652cc26704c6669bb76aeaf17c7ca811a95c1ab7.tar.bz2
historical-652cc26704c6669bb76aeaf17c7ca811a95c1ab7.zip
new version for 2.14.3
Package-Manager: portage-2.1.1_pre4
Diffstat (limited to 'gnome-base/eel/eel-2.14.3.ebuild')
-rw-r--r--gnome-base/eel/eel-2.14.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnome-base/eel/eel-2.14.3.ebuild b/gnome-base/eel/eel-2.14.3.ebuild
new file mode 100644
index 000000000000..8ebeffa0b45b
--- /dev/null
+++ b/gnome-base/eel/eel-2.14.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/eel/eel-2.14.3.ebuild,v 1.1 2006/08/09 23:05:26 allanonjl Exp $
+
+inherit virtualx gnome2
+
+DESCRIPTION="The Eazel Extentions Library"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libart_lgpl-2.3.8
+ >=gnome-base/gconf-1.1.11
+ >=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.6
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2.7.92
+ >=gnome-base/gnome-vfs-2.9.1
+ >=dev-libs/libxml2-2.4.7
+ >=gnome-base/gail-0.16
+ >=gnome-base/libglade-2
+ >=gnome-base/gnome-desktop-2.1.4
+ >=gnome-base/gnome-menus-2.14.0
+ >=dev-util/desktop-file-utils-0.9"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.23
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README THANKS TODO"
+
+src_test() {
+ if hasq userpriv $FEATURES;
+ then
+ Xmake check || die "make check failed"
+ else
+ einfo "Not running tests without userpriv"
+ fi
+}