summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-02-06 19:43:47 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-02-06 19:43:47 +0000
commit0c8b91c78f82af2f704606a8c15c4d62cf7bfc8c (patch)
tree1a1a7f91b03d77077fea01eb6566652e21324c66 /gnome-base/gnome-panel/gnome-panel-2.12.3.ebuild
parentMark 1.8.11 stable on alpha/ia64 #111738 (diff)
downloadhistorical-0c8b91c78f82af2f704606a8c15c4d62cf7bfc8c.tar.gz
historical-0c8b91c78f82af2f704606a8c15c4d62cf7bfc8c.tar.bz2
historical-0c8b91c78f82af2f704606a8c15c4d62cf7bfc8c.zip
Version bump from upstream
Package-Manager: portage-2.1_pre4-r1
Diffstat (limited to 'gnome-base/gnome-panel/gnome-panel-2.12.3.ebuild')
-rw-r--r--gnome-base/gnome-panel/gnome-panel-2.12.3.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/gnome-base/gnome-panel/gnome-panel-2.12.3.ebuild b/gnome-base/gnome-panel/gnome-panel-2.12.3.ebuild
new file mode 100644
index 000000000000..c71fc667e73c
--- /dev/null
+++ b/gnome-base/gnome-panel/gnome-panel-2.12.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-panel/gnome-panel-2.12.3.ebuild,v 1.1 2006/02/06 19:43:47 compnerd Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="The GNOME panel"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc eds"
+
+RDEPEND=">=gnome-base/gnome-desktop-2.11.92
+ >=x11-libs/gtk+-2.7.1
+ >=gnome-base/libglade-2.5
+ >=gnome-base/libgnome-2.1.1
+ >=gnome-base/libgnomeui-2.5.4
+ >=gnome-base/libbonoboui-2.1.1
+ >=gnome-base/orbit-2.4
+ >=gnome-base/gnome-vfs-2.9.1
+ >=x11-libs/libwnck-2.11.91
+ >=gnome-base/gconf-2.6.1
+ >=gnome-base/gnome-menus-2.11.1
+ >=gnome-base/libbonobo-2
+ media-libs/libpng
+ eds? ( >=gnome-extra/evolution-data-server-1.2 )"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.3.2
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.31
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+USE_DESTDIR="1"
+
+
+pkg_setup() {
+ G2CONF="--disable-scrollkeeper \
+ $(use_enable eds)"
+
+ if ! built_with_use dev-libs/libxml2 python; then
+ einfo "Please re-emerge dev-libs/libxml2 with the python USE flag set"
+ die "libxml2 needs the python use flag set"
+ fi
+}
+
+src_unpack() {
+ unpack "${A}"
+
+ # FIXME : uh yeah, this is nice
+ # We should patch in a switch here and send it upstream
+ sed -i 's:--load:-v:' ${S}/gnome-panel/Makefile.in || die "sed failed"
+}
+
+pkg_postinst() {
+
+ local entries="/etc/gconf/schemas/panel-default-setup.entries"
+ if [ -e "$entries" ]; then
+ einfo "setting panel gconf defaults..."
+ GCONF_CONFIG_SOURCE=`${ROOT}/usr/bin/gconftool-2 --get-default-source`
+ ${ROOT}/usr/bin/gconftool-2 --direct --config-source \
+ ${GCONF_CONFIG_SOURCE} --load=${entries}
+ fi
+
+ # Calling this late so it doesn't process the GConf schemas file we already
+ # took care of.
+ gnome2_pkg_postinst
+
+}
+