summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-09-24 15:24:03 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-09-24 15:24:03 +0000
commitabd2dd308ad031fae28e83678ba9e805b5d9a27d (patch)
tree9806f71244e0c156fa2573c3efa8c93d12900975 /gnome-base/nautilus
parentadded mozilla-0.9.4-r1 from Martin Schlemmer, also removed old ebuilds (diff)
downloadhistorical-abd2dd308ad031fae28e83678ba9e805b5d9a27d.tar.gz
historical-abd2dd308ad031fae28e83678ba9e805b5d9a27d.tar.bz2
historical-abd2dd308ad031fae28e83678ba9e805b5d9a27d.zip
updated to use the MOZILLA_FIVE_HOME variable instead of hardcoded paths to Mozilla
Diffstat (limited to 'gnome-base/nautilus')
-rw-r--r--gnome-base/nautilus/files/digest-nautilus-1.0.4-r31
-rw-r--r--gnome-base/nautilus/files/nautilus-1.0.4-mozilla-0.9.4.patch26
-rw-r--r--gnome-base/nautilus/nautilus-1.0.4-r3.ebuild71
3 files changed, 98 insertions, 0 deletions
diff --git a/gnome-base/nautilus/files/digest-nautilus-1.0.4-r3 b/gnome-base/nautilus/files/digest-nautilus-1.0.4-r3
new file mode 100644
index 000000000000..aba4416e68d3
--- /dev/null
+++ b/gnome-base/nautilus/files/digest-nautilus-1.0.4-r3
@@ -0,0 +1 @@
+MD5 e024b3d994838c4469ddbd8c1fbb4e28 nautilus-1.0.4.tar.gz
diff --git a/gnome-base/nautilus/files/nautilus-1.0.4-mozilla-0.9.4.patch b/gnome-base/nautilus/files/nautilus-1.0.4-mozilla-0.9.4.patch
new file mode 100644
index 000000000000..cdd9b4ff0efd
--- /dev/null
+++ b/gnome-base/nautilus/files/nautilus-1.0.4-mozilla-0.9.4.patch
@@ -0,0 +1,26 @@
+diff -Nrc -x *~ nautilus-1.0.4.orig/components/mozilla/mozilla-events.cpp nautilus-1.0.4/components/mozilla/mozilla-events.cpp
+*** nautilus-1.0.4.orig/components/mozilla/mozilla-events.cpp Tue Feb 27 04:38:53 2001
+--- nautilus-1.0.4/components/mozilla/mozilla-events.cpp Wed Aug 8 16:16:10 2001
+***************
+*** 60,65 ****
+--- 60,66 ----
+ #include "nsIDocShellTreeOwner.h"
+ #include "nsIDocument.h"
+ #include "nsIContent.h"
++ #include "nsIContentViewer.h"
+ #include "nsIDOMHTMLElement.h"
+ #include "nsIDOMHTMLAnchorElement.h"
+ #include "nsIDOMHTMLDocument.h"
+diff -Nrc -x *~ nautilus-1.0.4.orig/components/mozilla/nautilus-mozilla-embed-extensions.cpp nautilus-1.0.4/components/mozilla/nautilus-mozilla-embed-extensions.cpp
+*** nautilus-1.0.4.orig/components/mozilla/nautilus-mozilla-embed-extensions.cpp Thu Feb 22 07:40:40 2001
+--- nautilus-1.0.4/components/mozilla/nautilus-mozilla-embed-extensions.cpp Wed Aug 8 16:15:37 2001
+***************
+*** 41,46 ****
+--- 41,47 ----
+ #include "nsIMarkupDocumentViewer.h"
+ #include "nsICharsetConverterManager.h"
+ #include "nsICharsetConverterManager2.h"
++ #include "nsIContentViewer.h"
+ #include <vector>
+ #include <string>
+
diff --git a/gnome-base/nautilus/nautilus-1.0.4-r3.ebuild b/gnome-base/nautilus/nautilus-1.0.4-r3.ebuild
new file mode 100644
index 000000000000..ba1e55982b42
--- /dev/null
+++ b/gnome-base/nautilus/nautilus-1.0.4-r3.ebuild
@@ -0,0 +1,71 @@
+## Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# Updated by Sebastian Werner <sebastian@werner-productions.de>
+# /home/cvsroot/gentoo-x86/gnome-apps/nautilus/nautilus-1.0.ebuild,v 1.3 2001/04/29 18:42:54 achim Exp
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-1.0.4-r3.ebuild,v 1.1 2001/09/24 15:24:03 hallski Exp $
+
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="nautilus"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}
+ ftp://rpmfind.net/linux/gnome.org/stable/latest/sources/${A}"
+
+HOMEPAGE="http://www.gnome.org/"
+
+RDEPEND="mozilla? ( >=net-www/mozilla-0.9.4 )
+ >=media-sound/cdparanoia-3.9.8
+ >=gnome-base/bonobo-1.0.2
+ >=gnome-base/gnome-core-1.4.0.4
+ >=gnome-libs/medusa-0.5.1
+ >=gnome-base/libghttp-1.0.9
+ >=gnome-libs/eel-1.0"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=gnome-base/scrollkeeper-0.2
+ >=dev-util/xml-i18n-tools-0.8.4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/nautilus-1.0.4-mozilla-0.9.4.patch
+}
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ if [ "`use mozilla`" ]
+ then
+ MOZILLA=${MOZILLA_FIVE_HOME}
+ myconf="${myconf} --with-mozilla-lib-place=$MOZILLA \
+ --with-mozilla-include-place=$MOZILLA/include"
+
+ export MOZILLA_FIVE_HOME=$MOZILLA
+ export LD_LIBRARY_PATH=$MOZILLA_FIVE_HOME
+ else
+ myconf="${myconf} --disable-mozilla-component"
+ fi
+
+ ./configure --host=${CHOST} --prefix=/opt/gnome \
+ --sysconfdir=/etc/opt/gnome \
+ --infodir=/opt/gnome/info \
+ --mandir=/opt/gnome/man \
+ --enable-eazel-services=0 ${myconf}
+ assert
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING* ChangeLog* NEWS TODO
+}
+