summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-08-20 08:26:02 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-08-20 08:26:02 +0000
commit606166f1b0679bb4ac43bed30c9185e3b86a0b99 (patch)
treeac289e5b94d4a86b2bdd2546ab1d2c6a51e8dbfe /gnome-base
parentfixing Group line in config file so it'll start. (diff)
downloadhistorical-606166f1b0679bb4ac43bed30c9185e3b86a0b99.tar.gz
historical-606166f1b0679bb4ac43bed30c9185e3b86a0b99.tar.bz2
historical-606166f1b0679bb4ac43bed30c9185e3b86a0b99.zip
updated to 1.0.4
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gconf/files/digest-gconf-1.0.41
-rw-r--r--gnome-base/gconf/gconf-1.0.4.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/gnome-base/gconf/files/digest-gconf-1.0.4 b/gnome-base/gconf/files/digest-gconf-1.0.4
new file mode 100644
index 000000000000..4e926a61ae4c
--- /dev/null
+++ b/gnome-base/gconf/files/digest-gconf-1.0.4
@@ -0,0 +1 @@
+MD5 6eb7072552d8d9a02bdca38376f58863 GConf-1.0.4.tar.gz
diff --git a/gnome-base/gconf/gconf-1.0.4.ebuild b/gnome-base/gconf/gconf-1.0.4.ebuild
new file mode 100644
index 000000000000..99ac3e529dac
--- /dev/null
+++ b/gnome-base/gconf/gconf-1.0.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-1.0.4.ebuild,v 1.1 2001/08/20 08:26:02 hallski Exp $
+
+P=GConf-${PV}
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Gconf"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/GConf/${A}
+ ftp://gnome.eazel.com/pub/gnome/unstable/sources/GConf/${A}"
+
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="nls? ( sys-devel/gettext )
+ >=sys-libs/db-3.2.3h
+ >=gnome-base/gnome-env-1.0
+ >=gnome-base/oaf-0.6.5
+ >=gnome-base/gnome-libs-1.2.10
+ >=dev-util/guile-1.4"
+
+RDEPEND=">=sys-libs/db-3.2.3h
+ >=gnome-base/gnome-env-1.0
+ >=gnome-base/oaf-0.6.5
+ >=gnome-base/gnome-libs-1.2.10"
+
+#src_unpack() {
+# unpack ${A}
+ # for some reason, the GConf package doesn't come w/ an intl directory,
+ # so I copied it from another package, and made a diff
+# cd ${S}
+# try patch -p1 < ${FILESDIR}/${PF}-gentoo-intl.diff
+#}
+
+src_compile() {
+
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome ${myconf} || die
+
+ make || die # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
+
+}
+
+
+
+
+