summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2008-03-10 22:35:27 +0000
committerMart Raudsepp <leio@gentoo.org>2008-03-10 22:35:27 +0000
commit750f8d25c519a042901c0528ba76f2e0579439d6 (patch)
tree6b0df4cec4bf2e1020ea955c7f966e763556a483 /gnome-base
parentRemove GNOME 2.18 (diff)
downloadhistorical-750f8d25c519a042901c0528ba76f2e0579439d6.tar.gz
historical-750f8d25c519a042901c0528ba76f2e0579439d6.tar.bz2
historical-750f8d25c519a042901c0528ba76f2e0579439d6.zip
Remove old GNOME 2.16 version
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-volume-manager/files/gnome-volume-manager-2.15.0-check_local_user.patch246
-rw-r--r--gnome-base/gnome-volume-manager/gnome-volume-manager-2.15.0-r1.ebuild59
-rw-r--r--gnome-base/libgnomeui/Manifest16
3 files changed, 11 insertions, 310 deletions
diff --git a/gnome-base/gnome-volume-manager/files/gnome-volume-manager-2.15.0-check_local_user.patch b/gnome-base/gnome-volume-manager/files/gnome-volume-manager-2.15.0-check_local_user.patch
deleted file mode 100644
index 985da86c8c7d..000000000000
--- a/gnome-base/gnome-volume-manager/files/gnome-volume-manager-2.15.0-check_local_user.patch
+++ /dev/null
@@ -1,246 +0,0 @@
-# patch to g-v-m 2.15.0 to fix the startx session bug which is caused by
-# gvm_local_user, where ut_line is returned as ttyN rather than :0.
-===================================================================
-RCS file: src/manager.c,v
-retrieving revision 1.152
-retrieving revision 1.153
-diff -u -r1.152 -r1.153
---- src/manager.c 2006/08/07 13:47:31 1.152
-+++ src/manager.c 2006/08/11 18:01:08 1.153
-@@ -1717,6 +1717,58 @@
- }
-
-
-+static gboolean
-+gvm_mount_options (GPtrArray *options, guint32 opts, const char *type, const char *where)
-+{
-+ char *option, *key, *tmp, *p;
-+ GSList *list, *l, *n;
-+ GConfClient *gconf;
-+ const char *dir;
-+
-+ if (!strncmp (where, "/org/freedesktop/Hal/", 21)) {
-+ /* flatten the UDI */
-+ dir = p = tmp = g_strdup (where);
-+ while (*p != '\0') {
-+ if (*p == '/')
-+ *p = '_';
-+ p++;
-+ }
-+ } else {
-+ dir = where;
-+ tmp = NULL;
-+ }
-+
-+ key = g_strdup_printf ("/system/storage/%s/%s/mount_options", type, dir);
-+ g_free (tmp);
-+
-+ gconf = gconf_client_get_default ();
-+ list = gconf_client_get_list (gconf, key, GCONF_VALUE_STRING, NULL);
-+ g_object_unref (gconf);
-+ g_free (key);
-+
-+ if (list == NULL) {
-+ fprintf (stderr, "no mount options found for %s::%s\n", type, where);
-+ return FALSE;
-+ }
-+
-+ for (l = list; l != NULL; l = n) {
-+ option = l->data;
-+ n = l->next;
-+
-+ g_ptr_array_add (options, option);
-+
-+ g_slist_free_1 (l);
-+ }
-+
-+ if (opts & MOUNT_UID) {
-+ option = g_strdup_printf ("uid=%u", getuid ());
-+ g_ptr_array_add (options, option);
-+ }
-+
-+ return TRUE;
-+}
-+
-+
- /*
- * gvm_device_mount - mount the given device.
- *
-@@ -1761,10 +1813,13 @@
-
- return retval;
- } else {
-- char *mount_point, *fstype, fmask_opt[12], *charset_opt = NULL;
-+ char *mount_point, *fstype, *drive, **moptions, fmask_opt[12], *charset_opt = NULL;
- DBusMessage *dmesg, *reply;
-+ gboolean freev = FALSE;
- GPtrArray *options;
-+ guint32 opts = 0;
- DBusError error;
-+ size_t i, j;
-
- if (!(dmesg = dbus_message_new_method_call ("org.freedesktop.Hal", udi,
- "org.freedesktop.Hal.Device.Volume",
-@@ -1773,26 +1828,48 @@
- return FALSE;
- }
-
-+ if ((moptions = libhal_device_get_property_strlist (hal_ctx, udi, "volume.mount.valid_options", NULL))) {
-+ for (i = 0; moptions[i]; i++) {
-+ for (j = 0; j < G_N_ELEMENTS (mount_options); j++) {
-+ if (!strcmp (moptions[i], mount_options[j].name))
-+ opts |= mount_options[j].flag;
-+ }
-+ }
-+
-+ libhal_free_string_array (moptions);
-+ }
-+
- options = g_ptr_array_new ();
-+
-+ /* check volume-specific mount options */
-+ if (gvm_mount_options (options, opts, "volumes", udi)) {
-+ freev = TRUE;
-+ goto mount;
-+ }
-+
-+ /* check drive specific mount options */
-+ if ((drive = libhal_device_get_property_string (hal_ctx, udi, "block.storage_device", NULL))) {
-+ if (gvm_mount_options (options, opts, "drives", drive)) {
-+ libhal_free_string (drive);
-+ freev = TRUE;
-+ goto mount;
-+ }
-+ libhal_free_string (drive);
-+ }
-+
- if ((fstype = libhal_device_get_property_string (hal_ctx, udi, "volume.fstype", NULL))) {
-- char **moptions = NULL;
- const char *iocharset;
-- guint32 opts = 0;
- char uid[32];
-- size_t i, j;
- mode_t mask;
-
-- if ((moptions = libhal_device_get_property_strlist (hal_ctx, udi, "volume.mount.valid_options", NULL))) {
-- for (i = 0; moptions[i]; i++) {
-- for (j = 0; j < G_N_ELEMENTS (mount_options); j++) {
-- if (!strcmp (moptions[i], mount_options[j].name))
-- opts |= mount_options[j].flag;
-- }
-- }
--
-- libhal_free_string_array (moptions);
-+ /* fall back to using fstype-specific mount options */
-+ if (gvm_mount_options (options, opts, "default_options", fstype)) {
-+ libhal_free_string (fstype);
-+ freev = TRUE;
-+ goto mount;
- }
-
-+ /* take our best guess at what the user would want */
- if (!strcmp (fstype, "vfat")) {
- if (opts & MOUNT_NOEXEC)
- g_ptr_array_add (options, "noexec");
-@@ -1843,9 +1920,11 @@
- g_ptr_array_add (options, uid);
- }
-
-- g_free (fstype);
-+ libhal_free_string (fstype);
- }
-
-+ mount:
-+
- mount_point = "";
- fstype = "";
-
-@@ -1857,6 +1936,11 @@
- return FALSE;
- }
-
-+ if (freev) {
-+ for (i = 0; i < options->len; i++)
-+ g_free (options->pdata[i]);
-+ }
-+
- g_ptr_array_free (options, TRUE);
- g_free (charset_opt);
-
-@@ -3080,31 +3164,64 @@
- }
-
-
-+enum {
-+ LOCAL_USER_CHECKED = (1 << 0),
-+ LOCAL_USER_FOUND = (1 << 1)
-+};
-+
- /* checks that the user is logged-in at a local X session (which does not necessarily infer an *active* session) */
- static gboolean
- gvm_local_user (void)
- {
-- gboolean local = FALSE;
-+ static guint32 local = 0;
-+ struct dirent *dent;
- struct utmp *utmp;
- const char *user;
-- size_t ulen;
-+ char *vtend;
-+ size_t n;
-+ DIR *dir;
-+ int vt;
-+
-+ if (local & LOCAL_USER_CHECKED)
-+ return (local & LOCAL_USER_FOUND);
-
- user = g_get_user_name ();
-- ulen = strlen (user);
-+ n = strlen (user);
-
-- setutent ();
-+ if (!(dir = opendir (GVM_CONSOLE_AUTH_DIR)))
-+ goto fallback;
-
-- while (!local && (utmp = getutent ())) {
-- if (utmp->ut_type != USER_PROCESS || strncmp (utmp->ut_user, user, ulen) != 0)
-- continue;
-+ /* this works for pam_console ($path/user) and pam_foreground ($path/user:vt) - see bug #336932 */
-+ while ((dent = readdir (dir))) {
-+ if (!strncmp (user, dent->d_name, n) && dent->d_name[n] == '\0'
-+ || (dent->d_name[n] == ':' && ((vt = strtol (dent->d_name + n + 1, &vtend, 10)) >= 0) && *vtend == '\0')) {
-+ local = LOCAL_USER_FOUND;
-+ break;
-+ }
-+ }
-+
-+ closedir (dir);
-+
-+ fallback:
-+
-+ if (!(local & LOCAL_USER_FOUND)) {
-+ setutent ();
-+
-+ while (!(local & LOCAL_USER_FOUND) && (utmp = getutent ())) {
-+ if (utmp->ut_type != USER_PROCESS || strncmp (utmp->ut_user, user, n) != 0)
-+ continue;
-+
-+ /* only accept local X sessions or local tty's (user started X via `startx`) */
-+ local = utmp->ut_line[0] == ':' && utmp->ut_line[1] >= '0' && utmp->ut_line[1] <= '9'
-+ || !strncmp (utmp->ut_line, "tty", 3) ? LOCAL_USER_FOUND : 0;
-+ }
-
-- /* only accept local X sessions */
-- local = utmp->ut_line[0] == ':' && utmp->ut_line[1] >= '0' && utmp->ut_line[1] <= '9';
-+ endutent ();
- }
-
-- endutent ();
-+ local |= LOCAL_USER_CHECKED;
-
-- return local;
-+ return (local & LOCAL_USER_FOUND);
- }
-
- /* checks that the user is at the local active X session */
-
diff --git a/gnome-base/gnome-volume-manager/gnome-volume-manager-2.15.0-r1.ebuild b/gnome-base/gnome-volume-manager/gnome-volume-manager-2.15.0-r1.ebuild
deleted file mode 100644
index 9f943956ba39..000000000000
--- a/gnome-base/gnome-volume-manager/gnome-volume-manager-2.15.0-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-volume-manager/gnome-volume-manager-2.15.0-r1.ebuild,v 1.7 2007/08/02 05:37:56 mr_bones_ Exp $
-
-inherit gnome2 eutils autotools
-
-DESCRIPTION="Daemon that enforces volume-related policies"
-HOMEPAGE="http://www.gnome.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-IUSE="crypt debug doc"
-
-RDEPEND="gnome-base/nautilus
- >=gnome-base/libgnomeui-2.1.5
- >=dev-libs/dbus-glib-0.71
- >=sys-apps/hal-0.5.6
- >=x11-libs/gtk+-2.6
- >=gnome-base/libglade-2
- >=x11-libs/libnotify-0.3
- >=gnome-base/gconf-2
- >=gnome-base/control-center-2.0
- gnome-base/gnome-mime-data
- gnome-base/gnome-mount"
-
-DEPEND="${RDEPEND}
- sys-devel/gettext
- >=dev-util/pkgconfig-0.20
- >=dev-util/intltool-0.35"
-
-DOCS="AUTHORS ChangeLog README HACKING NEWS TODO"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- epatch "${FILESDIR}/${P}-check_local_user.patch"
-}
-
-pkg_setup() {
- G2CONF="${G2CONF} \
- $(use_enable crypt) \
- $(use_enable debug) \
- $(use_enable doc)"
-
- # FIXME: We should be more intelligent about disabling multiuser support
- # (like enable it when pam_console is available?). For now, this is a
- # slightly nicer solution than applying ${PN}-1.5.9-no-pam_console.patch
- G2CONF="${G2CONF} --disable-multiuser"
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
-
- elog "To start the gnome-volume-manager daemon you need to configure"
- elog "it through it's preferences capplet. Also the HAL daemon (hald)"
- elog "needs to be running or it will shut down."
-}
diff --git a/gnome-base/libgnomeui/Manifest b/gnome-base/libgnomeui/Manifest
index e85e0d398368..f84a032ecdc1 100644
--- a/gnome-base/libgnomeui/Manifest
+++ b/gnome-base/libgnomeui/Manifest
@@ -1,13 +1,19 @@
-AUX libgnomeui-2.13.2-gentoo.patch 3851 RMD160 7939b9a03e8eed1e04a2b2482a2a185c99d9254f SHA1 b2716ff83c387d5fdfd508b2d234a3eb214eaa49 SHA256 db4a93f86075ff1b719de5a4342c9371cd2d887453d7c7be4a39525534178db5
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
AUX libgnomeui-2.19.1-enable-druid.patch 3371 RMD160 5db849ebe6c6f9498e308cb2b0de8afe3192ee4e SHA1 2e568fcc8d02cfa97b1daa08106f3ab85f7b576f SHA256 0dbdc0dc893c480a02c552555ea13ef9077f58e470738a573a196b5fdbf54f01
-AUX libgnomeui-2.8.0-ditch_ancient_pics.patch 505 RMD160 cdba46b36bb82187b5c91616ff11303e7cb7b4e1 SHA1 ce89d17f3a909955e174a843eb6bf1d7173e0b9d SHA256 ad344da3b6d62633463a33388eb5d6673549016f1b89589db2eede7e37abcb63
-DIST libgnomeui-2.14.1.tar.bz2 1891798 RMD160 a8600bf65ef5cb98af9cbba29789395e595299f1 SHA1 67eb151f4c8f4c1148bda3a97b36e57d4d9a49e0 SHA256 e1029ed0c69d7e1259c48d9ff1afdd87505182e0a1ef28ef3b48592a3a3c1c88
DIST libgnomeui-2.16.1.tar.bz2 1482097 RMD160 9cb97cb90014df2f477c24b7c41873a74704dff8 SHA1 13154032427c0599ca741de50301cdc3a9ab3088 SHA256 552c34d20f30847429e342e6c6ddeece707b69a5abe9aeeafcfeb65cec2eebd7
DIST libgnomeui-2.18.1.tar.bz2 1462027 RMD160 e1394f2fa4ba92554b48f5d3a3fd767b60b0c6cd SHA1 20f57e5a73f3d5570d331182dba45ff8943ef659 SHA256 d6eef491e70fcc2c1e5b94f6a8dbb3774443b3b76b1ca5d62bfb5b802df14120
DIST libgnomeui-2.20.1.1.tar.bz2 1445994 RMD160 90caad97c85250435299923c90ffa730dbdfd288 SHA1 e1704b328de6f6f7130147062b3262b3df77484a SHA256 133933c70234ecd4560cec165034c21c94598c24c34138ed1ee1770f52328cef
-EBUILD libgnomeui-2.14.1.ebuild 1362 RMD160 4ff04f33ef26ce2535d9dc16421b391b58c6b8b1 SHA1 95b00166b3e56d183ce2e44544b1734c9388ae92 SHA256 6712195b877a2eb4915dc12ef82a160e85dc7c79607e89da053038511edd6419
-EBUILD libgnomeui-2.16.1.ebuild 1031 RMD160 2e5dbbc68d2cf9880066f579c954bd744327be30 SHA1 9fff9526644394e027d8244c9bc4a7f8eb5673f6 SHA256 9c641b9b3b7e87eb40627c1801709acad5f0fdc25a85d5eac891b2a75ae89bf4
+EBUILD libgnomeui-2.16.1.ebuild 972 RMD160 1da06a15e52ec38c3b5c97aab51d86e7c5a356f7 SHA1 cc22d3a93ecfab6bae9656e1a500697cbb3a5f8a SHA256 95232d2d532d112adb19e7eaad3ca4a5f05358d1a8472d26a0fcff60ba53a0fc
EBUILD libgnomeui-2.18.1.ebuild 1052 RMD160 77501c1a02aed0aa8e2dcfbeb3990fcccd37ee07 SHA1 d9601f2d482742e2e97edde20692d6f592f16571 SHA256 54183c7925ee07d4238a28f717517aec555f1596d28b6e488829f2c271f1c70f
EBUILD libgnomeui-2.20.1.1.ebuild 1191 RMD160 88668bbaeadf7ee5e99c9cde853dd2702b7e4455 SHA1 0dccdfb3fbaeb40f8c7c384c622b42eae366e5bd SHA256 a9b202c59b4b628aa0750775ed5b72fcf56ad92e1cec7e31fcf2ba7d576f5fbf
MISC ChangeLog 18308 RMD160 2aa8947d927048c300d7ac03ec20c58c41f65488 SHA1 4c5c3558a6ea6fef0b13364ccf4ffa2e57d4c7ae SHA256 a6ab63a4b0396a9c4864770088f8ee3f1823ab57a3ca3e8b64b011ec846215db
MISC metadata.xml 158 RMD160 c0e2bae8e91bb6be8922bac5e4f597302e06587e SHA1 38f78e9790bcd4382b4a49aa226aa6dda1d3a3d7 SHA256 3a7dbca0fdc557de69783e0663e2d76ddab129ea8a19b2d0ef6d3e5d1b947ce1
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.8 (GNU/Linux)
+
+iEYEARECAAYFAkfVuGQACgkQkeYb6olFHJdpGACfbeEU7x+OcQw9kcmOzCWyb5rD
+oc0AoO2zhpMmVT34/mXBwsX7iyWl7t26
+=lEde
+-----END PGP SIGNATURE-----