summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-05 05:40:18 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-05 05:40:18 +0000
commitd2ba1e64518ad627ebb38e567b006e8cf2aec321 (patch)
tree196ccee789fbfc62e442d0d7a771fe9a24f03dd4 /gnome-base
parentsh love (diff)
downloadhistorical-d2ba1e64518ad627ebb38e567b006e8cf2aec321.tar.gz
historical-d2ba1e64518ad627ebb38e567b006e8cf2aec321.tar.bz2
historical-d2ba1e64518ad627ebb38e567b006e8cf2aec321.zip
sh love
Package-Manager: portage-2.1.1_pre2-r2
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/bonobo/bonobo-1.0.22.ebuild34
-rw-r--r--gnome-base/gnome-libs/gnome-libs-1.4.2.ebuild53
-rw-r--r--gnome-base/libglade/files/digest-libglade-2.5.12
-rw-r--r--gnome-base/libglade/libglade-0.17-r6.ebuild16
-rw-r--r--gnome-base/libglade/libglade-2.5.0.ebuild21
-rw-r--r--gnome-base/libglade/libglade-2.5.1.ebuild21
-rw-r--r--gnome-base/oaf/oaf-0.6.10.ebuild23
-rw-r--r--gnome-base/orbit/files/digest-orbit-0.5.172
-rw-r--r--gnome-base/orbit/files/digest-orbit-0.5.17-r12
-rw-r--r--gnome-base/orbit/files/digest-orbit-2.12.42
-rw-r--r--gnome-base/orbit/orbit-0.5.17-r1.ebuild23
-rw-r--r--gnome-base/orbit/orbit-2.12.5.ebuild4
-rw-r--r--gnome-base/orbit/orbit-2.14.0.ebuild4
13 files changed, 83 insertions, 124 deletions
diff --git a/gnome-base/bonobo/bonobo-1.0.22.ebuild b/gnome-base/bonobo/bonobo-1.0.22.ebuild
index 63898cf814e0..2b9602d34215 100644
--- a/gnome-base/bonobo/bonobo-1.0.22.ebuild
+++ b/gnome-base/bonobo/bonobo-1.0.22.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/bonobo/bonobo-1.0.22.ebuild,v 1.24 2006/03/31 14:14:02 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/bonobo/bonobo-1.0.22.ebuild,v 1.25 2006/07/05 05:39:38 vapier Exp $
-inherit gnome.org libtool gnuconfig eutils multilib
+inherit gnome.org libtool eutils multilib
DESCRIPTION="A set of language and system independent CORBA interfaces"
HOMEPAGE="http://www.gnome.org/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86"
IUSE="nls"
RDEPEND=">=gnome-base/oaf-0.6.8
@@ -23,29 +23,23 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
- epatch ${FILESDIR}/${P}-gcc4.patch
- sed -i -e "s:libdir=@prefix@/lib:libdir=@prefix@/$(get_libdir):" \
- libefs/libefs.pc.in
-}
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+ sed -i \
+ -e "s:libdir=@prefix@/lib:libdir=@prefix@/$(get_libdir):" \
+ libefs/libefs.pc.in || die
-src_compile() {
- #libtoolize to fix relink bug
+ # libtoolize to fix relink bug
elibtoolize
+}
- use ppc64 && gnuconfig_update
-
- local myconf=""
- use nls || myconf="${myconf} --disable-nls"
-
- econf ${myconf} || die
-
- make || die # make -j 4 didn't work
+src_compile() {
+ econf $(use_enable nls) || die
+ emake -j1 || die # make -j 4 didn't work
}
src_install() {
einstall || die
-
- dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+ dodoc AUTHORS ChangeLog README NEWS TODO
}
diff --git a/gnome-base/gnome-libs/gnome-libs-1.4.2.ebuild b/gnome-base/gnome-libs/gnome-libs-1.4.2.ebuild
index 7132d20fedfc..7f8b684d24c6 100644
--- a/gnome-base/gnome-libs/gnome-libs-1.4.2.ebuild
+++ b/gnome-base/gnome-libs/gnome-libs-1.4.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-libs/gnome-libs-1.4.2.ebuild,v 1.32 2006/06/25 20:16:31 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-libs/gnome-libs-1.4.2.ebuild,v 1.33 2006/07/05 05:36:12 vapier Exp $
-inherit eutils libtool multilib autotools
+inherit eutils libtool multilib autotools flag-o-matic
DESCRIPTION="GNOME Core Libraries"
HOMEPAGE="http://www.gnome.org/"
@@ -10,11 +10,11 @@ SRC_URI="ftp://ftp.gnome.org/pub/GNOME/sources/${PN}/1.4/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="1"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
-IUSE="doc nls kde"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86"
+IUSE="doc esd nls kde"
RDEPEND=">=media-libs/imlib-1.9.10
- >=media-sound/esound-0.2.23
+ esd? ( >=media-sound/esound-0.2.23 )
=gnome-base/orbit-0*
=x11-libs/gtk+-1.2*
<=sys-libs/db-2
@@ -38,24 +38,14 @@ src_unpack() {
}
src_compile() {
- CFLAGS="$CFLAGS -I/usr/include/db1"
-
- # On alpha with 3.3.2 compilers we need to restrict options to
- # make this actually build. I don't know what the upper limit is
- # but the following works (and who really cares about
- # gnome-libs-1.4.x performance)
- # (12 Nov 2003 agriffis)
- if use alpha; then
- # hopefully this overrides whatever is earlier on the line
- # since working out the replacements would be a pain
- CFLAGS="${CFLAGS} -O0 -mcpu=ev4"
- fi
+ append-flags -I/usr/include/db1
local myconf
use nls || myconf="${myconf} --disable-nls"
use kde && myconf="${myconf} --with-kde-datadir=/usr/share"
use doc || myconf="${myconf} --disable-gtk-doc"
+ use esd || export ESD_CONFIG=no
# libtoolize
elibtoolize
@@ -73,28 +63,27 @@ src_compile() {
# gnome-libs does not like parallel building, bug #117644
emake -j1 || die
- #do the docs (maby add a use variable or put in seperate
- #ebuild since it is mostly developer docs?)
- if use doc
- then
- cd ${S}/devel-docs
+ # do the docs (maby add a use variable or put in seperate
+ # ebuild since it is mostly developer docs?)
+ if use doc ; then
+ cd "${S}"/devel-docs
emake || die
- cd ${S}
+ cd "${S}"
fi
}
src_install() {
- make prefix=${D}/usr \
- libdir=${D}/usr/$(get_libdir) \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- sysconfdir=${D}/etc \
- localstatedir=${D}/var/lib \
- docdir=${D}/usr/share/doc/${P} \
- HTML_DIR=${D}/usr/share/gnome/html \
+ make prefix="${D}"/usr \
+ libdir="${D}"/usr/$(get_libdir) \
+ mandir="${D}"/usr/share/man \
+ infodir="${D}"/usr/share/info \
+ sysconfdir="${D}"/etc \
+ localstatedir="${D}"/var/lib \
+ docdir="${D}"/usr/share/doc/${PF} \
+ HTML_DIR="${D}"/usr/share/gnome/html \
install || die
- rm ${D}/usr/share/gtkrc*
+ rm "${D}"/usr/share/gtkrc*
dodoc AUTHORS ChangeLog README NEWS HACKING
}
diff --git a/gnome-base/libglade/files/digest-libglade-2.5.1 b/gnome-base/libglade/files/digest-libglade-2.5.1
index 928d680bdc1b..a82ab4dbea27 100644
--- a/gnome-base/libglade/files/digest-libglade-2.5.1
+++ b/gnome-base/libglade/files/digest-libglade-2.5.1
@@ -1 +1,3 @@
MD5 e4734a59f1f2308d7714dc0ebf8163f1 libglade-2.5.1.tar.bz2 317524
+RMD160 9d8b8720453b9764833facc5ca0abab6f4c9fa41 libglade-2.5.1.tar.bz2 317524
+SHA256 15e4c95402caa3c97394189a6b1b693eced23d80e292fcca12585317434adc2e libglade-2.5.1.tar.bz2 317524
diff --git a/gnome-base/libglade/libglade-0.17-r6.ebuild b/gnome-base/libglade/libglade-0.17-r6.ebuild
index ea58154a6815..b8bc5c76095d 100644
--- a/gnome-base/libglade/libglade-0.17-r6.ebuild
+++ b/gnome-base/libglade/libglade-0.17-r6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/libglade-0.17-r6.ebuild,v 1.30 2005/07/24 15:49:26 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/libglade-0.17-r6.ebuild,v 1.31 2006/07/05 05:40:18 vapier Exp $
#provide Xmake and Xemake
@@ -12,7 +12,7 @@ SRC_URI="ftp://ftp.gnome.org/pub/GNOME/sources/${PN}/${PV}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86"
IUSE="nls bonobo"
#please dont add gnome-libs as an optional DEPEND, as
@@ -46,12 +46,12 @@ src_compile() {
}
src_install() {
- make prefix=${D}/usr \
- libdir=${D}/usr/$(get_libdir) \
- sysconfdir=${D}/etc \
- localstatedir=${D}/var/lib \
+ make prefix="${D}"/usr \
+ libdir="${D}"/usr/$(get_libdir) \
+ sysconfdir="${D}"/etc \
+ localstatedir="${D}"/var/lib \
install || die
- dodoc AUTHORS COPYING* ChangeLog NEWS
+ dodoc AUTHORS ChangeLog NEWS
dodoc doc/*.txt
}
diff --git a/gnome-base/libglade/libglade-2.5.0.ebuild b/gnome-base/libglade/libglade-2.5.0.ebuild
index 0f73e2ad0103..31a7c800e6ba 100644
--- a/gnome-base/libglade/libglade-2.5.0.ebuild
+++ b/gnome-base/libglade/libglade-2.5.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/libglade-2.5.0.ebuild,v 1.11 2005/07/12 03:04:34 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/libglade-2.5.0.ebuild,v 1.12 2006/07/05 05:40:18 vapier Exp $
# FIXME : catalog stuff
inherit gnome2 eutils
@@ -10,7 +10,7 @@ HOMEPAGE="http://www.gnome.org/"
LICENSE="LGPL-2"
SLOT="2.0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86"
IUSE="doc"
RDEPEND=">=dev-libs/glib-2.5
@@ -18,46 +18,35 @@ RDEPEND=">=dev-libs/glib-2.5
>=dev-libs/atk-1
>=dev-libs/libxml2-2.4.10
>=dev-lang/python-2.0-r7"
-
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.12.0
doc? ( >=dev-util/gtk-doc-1 )"
-DOCS="ABOUT-NLS AUTHORS ChangeLog NEWS README"
+DOCS="AUTHORS ChangeLog NEWS README"
src_compile() {
-
- cd ${S}
# patch to stop make install installing the xml catalog
# because we do it ourselves in postinst()
- epatch ${FILESDIR}/Makefile.in.am-2.4.2-xmlcatalog.patch
+ epatch "${FILESDIR}"/Makefile.in.am-2.4.2-xmlcatalog.patch
gnome2_src_compile
-
}
src_install() {
-
dodir /etc/xml
gnome2_src_install
-
}
-
pkg_postinst() {
-
echo ">>> Updating XML catalog"
/usr/bin/xmlcatalog --noout --add "system" \
"http://glade.gnome.org/glade-2.0.dtd" \
/usr/share/xml/libglade/glade-2.0.dtd /etc/xml/catalog
gnome2_pkg_postinst
-
}
pkg_postrm() {
-
echo ">>> removing entries from the XML catalog"
/usr/bin/xmlcatalog --noout --del \
/usr/share/xml/libglade/glade-2.0.dtd /etc/xml/catalog
-
}
diff --git a/gnome-base/libglade/libglade-2.5.1.ebuild b/gnome-base/libglade/libglade-2.5.1.ebuild
index ec1233fc29d4..478b6b03f1a1 100644
--- a/gnome-base/libglade/libglade-2.5.1.ebuild
+++ b/gnome-base/libglade/libglade-2.5.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/libglade-2.5.1.ebuild,v 1.11 2005/10/09 22:38:02 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/libglade-2.5.1.ebuild,v 1.12 2006/07/05 05:40:18 vapier Exp $
# FIXME : catalog stuff
inherit gnome2 eutils
@@ -10,7 +10,7 @@ HOMEPAGE="http://www.gnome.org/"
LICENSE="LGPL-2"
SLOT="2.0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86"
IUSE="doc"
RDEPEND=">=dev-libs/glib-2.5
@@ -18,46 +18,35 @@ RDEPEND=">=dev-libs/glib-2.5
>=dev-libs/atk-1.9
>=dev-libs/libxml2-2.4.10
>=dev-lang/python-2.0-r7"
-
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.12.0
doc? ( >=dev-util/gtk-doc-1 )"
-DOCS="ABOUT-NLS AUTHORS ChangeLog NEWS README"
+DOCS="AUTHORS ChangeLog NEWS README"
src_compile() {
-
- cd ${S}
# patch to stop make install installing the xml catalog
# because we do it ourselves in postinst()
- epatch ${FILESDIR}/Makefile.in.am-2.4.2-xmlcatalog.patch
+ epatch "${FILESDIR}"/Makefile.in.am-2.4.2-xmlcatalog.patch
gnome2_src_compile
-
}
src_install() {
-
dodir /etc/xml
gnome2_src_install
-
}
-
pkg_postinst() {
-
echo ">>> Updating XML catalog"
/usr/bin/xmlcatalog --noout --add "system" \
"http://glade.gnome.org/glade-2.0.dtd" \
/usr/share/xml/libglade/glade-2.0.dtd /etc/xml/catalog
gnome2_pkg_postinst
-
}
pkg_postrm() {
-
echo ">>> removing entries from the XML catalog"
/usr/bin/xmlcatalog --noout --del \
/usr/share/xml/libglade/glade-2.0.dtd /etc/xml/catalog
-
}
diff --git a/gnome-base/oaf/oaf-0.6.10.ebuild b/gnome-base/oaf/oaf-0.6.10.ebuild
index a83bbe16d5fb..97e23d288c7f 100644
--- a/gnome-base/oaf/oaf-0.6.10.ebuild
+++ b/gnome-base/oaf/oaf-0.6.10.ebuild
@@ -1,19 +1,18 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/oaf/oaf-0.6.10.ebuild,v 1.22 2005/08/18 23:14:21 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/oaf/oaf-0.6.10.ebuild,v 1.23 2006/07/05 05:40:09 vapier Exp $
-inherit gnome.org libtool gnuconfig multilib
+inherit gnome.org libtool multilib
DESCRIPTION="Object Activation Framework for GNOME"
HOMEPAGE="http://www.gnome.org/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86"
IUSE="nls"
-RDEPEND="virtual/libc
- >=dev-libs/popt-1.5
+RDEPEND=">=dev-libs/popt-1.5
=gnome-base/orbit-0*
>=dev-libs/libxml-1.8.15"
DEPEND="${RDEPEND}
@@ -23,8 +22,6 @@ DEPEND="${RDEPEND}
src_compile() {
elibtoolize
- gnuconfig_update
-
local myconf=""
use nls || myconf="--disable-nls"
@@ -40,11 +37,11 @@ src_compile() {
}
src_install() {
- make prefix=${D}/usr \
- libdir=${D}/usr/$(get_libdir) \
- mandir=${D}/usr/share/man \
- sysconfdir=${D}/etc \
- localstatedir=${D}/var/lib \
+ make prefix="${D}"/usr \
+ libdir="${D}"/usr/$(get_libdir) \
+ mandir="${D}"/usr/share/man \
+ sysconfdir="${D}"/etc \
+ localstatedir="${D}"/var/lib \
install || die
dodoc AUTHORS ChangeLog README NEWS TODO
diff --git a/gnome-base/orbit/files/digest-orbit-0.5.17 b/gnome-base/orbit/files/digest-orbit-0.5.17
index 0acb59acfc03..9c8db5f72a18 100644
--- a/gnome-base/orbit/files/digest-orbit-0.5.17
+++ b/gnome-base/orbit/files/digest-orbit-0.5.17
@@ -1 +1,3 @@
MD5 35acc6f8d49d930b566104fcceb893d3 ORBit-0.5.17.tar.bz2 1065003
+RMD160 9087d6659adbd0066d76a3eed5cc2799de640df4 ORBit-0.5.17.tar.bz2 1065003
+SHA256 e83403a357d6e2339a3c4b6f191fcd7a1342d6bbe3391d6b03cf66f051b9a95e ORBit-0.5.17.tar.bz2 1065003
diff --git a/gnome-base/orbit/files/digest-orbit-0.5.17-r1 b/gnome-base/orbit/files/digest-orbit-0.5.17-r1
index 0acb59acfc03..9c8db5f72a18 100644
--- a/gnome-base/orbit/files/digest-orbit-0.5.17-r1
+++ b/gnome-base/orbit/files/digest-orbit-0.5.17-r1
@@ -1 +1,3 @@
MD5 35acc6f8d49d930b566104fcceb893d3 ORBit-0.5.17.tar.bz2 1065003
+RMD160 9087d6659adbd0066d76a3eed5cc2799de640df4 ORBit-0.5.17.tar.bz2 1065003
+SHA256 e83403a357d6e2339a3c4b6f191fcd7a1342d6bbe3391d6b03cf66f051b9a95e ORBit-0.5.17.tar.bz2 1065003
diff --git a/gnome-base/orbit/files/digest-orbit-2.12.4 b/gnome-base/orbit/files/digest-orbit-2.12.4
index 140b7f8ecc67..ef2b82d9c8c4 100644
--- a/gnome-base/orbit/files/digest-orbit-2.12.4
+++ b/gnome-base/orbit/files/digest-orbit-2.12.4
@@ -1 +1,3 @@
MD5 aa2cae6e7957c369edccbd98ba78dea9 ORBit2-2.12.4.tar.bz2 676951
+RMD160 30b1acee0bd662e7ffc563bd203d0489405e1a07 ORBit2-2.12.4.tar.bz2 676951
+SHA256 3c0aa4b5c09fccacb0a5f1fea676d6732f1b2cb3a4675d9ffe7894b01fae862d ORBit2-2.12.4.tar.bz2 676951
diff --git a/gnome-base/orbit/orbit-0.5.17-r1.ebuild b/gnome-base/orbit/orbit-0.5.17-r1.ebuild
index b4a0c3ce4ab8..7c567058b3a7 100644
--- a/gnome-base/orbit/orbit-0.5.17-r1.ebuild
+++ b/gnome-base/orbit/orbit-0.5.17-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-0.5.17-r1.ebuild,v 1.10 2006/03/24 16:23:46 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-0.5.17-r1.ebuild,v 1.11 2006/07/05 05:38:36 vapier Exp $
-inherit gnome.org libtool gnuconfig eutils multilib
+inherit gnome.org libtool eutils multilib
MY_P="ORBit-${PV}"
PVP=(${PV//[-\._]/ })
@@ -14,12 +14,12 @@ SRC_URI="mirror://gnome/sources/ORBit/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="1"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86"
IUSE=""
DEPEND="sys-devel/gettext
- >=sys-apps/tcp-wrappers-7.6
- =dev-libs/glib-1.2*"
+ >=sys-apps/tcp-wrappers-7.6
+ =dev-libs/glib-1.2*"
RDEPEND="=dev-libs/glib-1.2*
dev-util/indent"
@@ -28,7 +28,6 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-m4.patch
epatch "${FILESDIR}"/${P}-rpath-security-fix.patch
- gnuconfig_update
# Libtoolize to fix "relink bug" in older libtool's distributed
# with packages.
elibtoolize
@@ -36,7 +35,6 @@ src_unpack() {
src_compile() {
econf \
- --host=${CHOST} \
--prefix=/usr \
--libdir=/usr/$(get_libdir) \
--infodir=/usr/share/info \
@@ -48,12 +46,6 @@ src_compile() {
}
src_install() {
- #make prefix=${D}/usr \
- # libdir=${D}/usr/$(get_libdir) \
- # sysconfdir=${D}/etc \
- # infodir=${D}/usr/share/info \
- # localstatedir=${D}/var/lib \
- # install || die
make install DESTDIR="${D}" || die
dodoc AUTHORS ChangeLog README NEWS TODO
@@ -67,6 +59,7 @@ src_install() {
cd ../popt
dodoc CHANGES README
- sed -i -e 's:-I/usr/include":-I/usr/include/libIDL-1.0":' \
- ${D}/usr/$(get_libdir)/libIDLConf.sh || die
+ sed -i \
+ -e 's:-I/usr/include":-I/usr/include/libIDL-1.0":' \
+ "${D}"/usr/$(get_libdir)/libIDLConf.sh || die
}
diff --git a/gnome-base/orbit/orbit-2.12.5.ebuild b/gnome-base/orbit/orbit-2.12.5.ebuild
index 8bf4883af030..6a87763a665e 100644
--- a/gnome-base/orbit/orbit-2.12.5.ebuild
+++ b/gnome-base/orbit/orbit-2.12.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.12.5.ebuild,v 1.9 2006/04/21 20:24:10 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.12.5.ebuild,v 1.10 2006/07/05 05:38:36 vapier Exp $
inherit gnome2
@@ -14,7 +14,7 @@ SRC_URI="mirror://gnome/sources/ORBit2/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
LICENSE="GPL-2 LGPL-2"
SLOT="2"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86"
IUSE="doc ssl static"
RDEPEND=">=dev-libs/glib-2
diff --git a/gnome-base/orbit/orbit-2.14.0.ebuild b/gnome-base/orbit/orbit-2.14.0.ebuild
index 923f65019088..cabf1f21e1a1 100644
--- a/gnome-base/orbit/orbit-2.14.0.ebuild
+++ b/gnome-base/orbit/orbit-2.14.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.0.ebuild,v 1.1 2006/03/16 07:51:07 joem Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.0.ebuild,v 1.2 2006/07/05 05:38:36 vapier Exp $
inherit gnome2
@@ -14,7 +14,7 @@ SRC_URI="mirror://gnome/sources/ORBit2/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
LICENSE="GPL-2 LGPL-2"
SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
IUSE="doc ssl static"
RDEPEND=">=dev-libs/glib-2