summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-03-13 23:22:21 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-03-13 23:22:21 +0000
commit6c37e43955acc3a4c348d20ef97c73882dcc6720 (patch)
tree410a260c952e27279f4cff135f2397b7c9e09952 /gnome-extra/gal
parentgcc3 patch (diff)
downloadhistorical-6c37e43955acc3a4c348d20ef97c73882dcc6720.tar.gz
historical-6c37e43955acc3a4c348d20ef97c73882dcc6720.tar.bz2
historical-6c37e43955acc3a4c348d20ef97c73882dcc6720.zip
version bump
Diffstat (limited to 'gnome-extra/gal')
-rw-r--r--gnome-extra/gal/ChangeLog8
-rw-r--r--gnome-extra/gal/files/digest-gal-1.99.21
-rw-r--r--gnome-extra/gal/gal-1.99.2.ebuild53
3 files changed, 61 insertions, 1 deletions
diff --git a/gnome-extra/gal/ChangeLog b/gnome-extra/gal/ChangeLog
index bb927b7ea27b..b84833186520 100644
--- a/gnome-extra/gal/ChangeLog
+++ b/gnome-extra/gal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/gal
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gal/ChangeLog,v 1.21 2003/03/09 12:04:14 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gal/ChangeLog,v 1.22 2003/03/13 23:22:21 liquidx Exp $
+
+*gal-1.99.2 (13 Mar 2003)
+
+ 13 Mar 2003; Alastair Tse <liquidx@gentoo.org> gal-1.99.2.ebuild:
+ version bump. this is a new gtk2 version of gal. slotted to co-exist with
+ gal-0.*.
*gal-0.23 (04 Mar 2003)
diff --git a/gnome-extra/gal/files/digest-gal-1.99.2 b/gnome-extra/gal/files/digest-gal-1.99.2
new file mode 100644
index 000000000000..7d695e28b80e
--- /dev/null
+++ b/gnome-extra/gal/files/digest-gal-1.99.2
@@ -0,0 +1 @@
+MD5 52cfc2ddf0050e74d65995b4029396e8 gal-1.99.2.tar.gz 1042251
diff --git a/gnome-extra/gal/gal-1.99.2.ebuild b/gnome-extra/gal/gal-1.99.2.ebuild
new file mode 100644
index 000000000000..8a69d07e68a6
--- /dev/null
+++ b/gnome-extra/gal/gal-1.99.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gal/gal-1.99.2.ebuild,v 1.1 2003/03/13 23:22:21 liquidx Exp $
+
+IUSE="doc"
+
+inherit libtool
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="The Gnome Application Libraries"
+# also appears in gnome.org, but their latest is only 1.99.1 - 13 Mar 03
+SRC_URI="ftp://ftp.ximian.com/pub/ximian-evolution-beta/source/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="2"
+KEYWORDS="~x86"
+
+RDEPEND=">=gnome-base/libgnomeprint-2.2.0
+ >=gnome-base/libgnomeprintui-2.2.1
+ >=gnome-base/libglade-2.0
+ >=gnome-base/libgnomeui-2.0
+ >=gnome-base/libgnomecanvas-2.0
+ >=dev-libs/libxml2-2.0"
+
+DEPEND="sys-devel/gettext
+ doc? ( dev-util/gtk-doc )
+ ${RDEPEND}"
+
+src_compile() {
+ elibtoolize
+
+ local myconf=""
+
+ if [ -n "`use doc`" ]; then
+ myconf="${myconf} --enable-gtk-doc"
+ else
+ myconf="${myconf} --disable-gtk-doc"
+ fi
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+}
+