summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-09-16 14:59:12 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-09-16 14:59:12 +0000
commit01e8c231a64185ee22045c0ef9d219a45ee00d58 (patch)
tree4b6ce4fbaa8b1ac24d91f2953007cea1432280df /gnome-extra/libgda
parentversion bump (diff)
downloadhistorical-01e8c231a64185ee22045c0ef9d219a45ee00d58.tar.gz
historical-01e8c231a64185ee22045c0ef9d219a45ee00d58.tar.bz2
historical-01e8c231a64185ee22045c0ef9d219a45ee00d58.zip
version bump
Diffstat (limited to 'gnome-extra/libgda')
-rw-r--r--gnome-extra/libgda/Manifest4
-rw-r--r--gnome-extra/libgda/files/digest-libgda-1.0.01
-rw-r--r--gnome-extra/libgda/libgda-1.0.0.ebuild101
3 files changed, 104 insertions, 2 deletions
diff --git a/gnome-extra/libgda/Manifest b/gnome-extra/libgda/Manifest
index 0ba8016ccf5c..70148a2fee46 100644
--- a/gnome-extra/libgda/Manifest
+++ b/gnome-extra/libgda/Manifest
@@ -1,10 +1,10 @@
-MD5 6cf9c3c371747ddb39b250c5ec490f7c ChangeLog 4151
+MD5 10e28d9c4f764fa78820012131af36ae ChangeLog 4266
MD5 21d7bf915f9fdd61a090b47644a39662 libgda-0.12.1.ebuild 2570
MD5 37f9b04c394742e1ffcb6bf1218b6358 libgda-0.2.95-r1.ebuild 3283
MD5 ec4c66af4e7ca373e370223b7d126a4b libgda-0.2.96-r2.ebuild 3495
MD5 c19c0993d2f98e805569ab396e6e9bcb libgda-0.90.0.ebuild 2571
MD5 6bcaaa395f9f33c972852adc62b6f044 libgda-0.91.0.ebuild 2538
-MD5 6bcaaa395f9f33c972852adc62b6f044 libgda-1.0.0.ebuild 2538
+MD5 fccb16ab9d293633d8534799a15dad21 libgda-1.0.0.ebuild 2536
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 b8ef30c01c11ee3f373d99d6173d71a9 files/digest-libgda-0.12.1 66
MD5 40bbf8acf6e08a15e8e61573f6f07724 files/digest-libgda-0.2.95-r1 66
diff --git a/gnome-extra/libgda/files/digest-libgda-1.0.0 b/gnome-extra/libgda/files/digest-libgda-1.0.0
new file mode 100644
index 000000000000..459099ad1360
--- /dev/null
+++ b/gnome-extra/libgda/files/digest-libgda-1.0.0
@@ -0,0 +1 @@
+MD5 7e5f5c0943600236ec16df35119af86a libgda-1.0.0.tar.bz2 1026627
diff --git a/gnome-extra/libgda/libgda-1.0.0.ebuild b/gnome-extra/libgda/libgda-1.0.0.ebuild
new file mode 100644
index 000000000000..03bab267e212
--- /dev/null
+++ b/gnome-extra/libgda/libgda-1.0.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-1.0.0.ebuild,v 1.1 2003/09/16 14:58:32 liquidx Exp $
+
+IUSE="odbc postgres mysql ldap firebird freetds sqlite mdb oci8 doc"
+
+inherit gnome2
+
+DESCRIPTION="Gnome Database Access Library"
+HOMEPAGE="http://www.gnome-db.org/"
+SLOT="1"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~x86 ~ppc"
+
+RDEPEND=">=dev-libs/glib-2.0
+ >=dev-libs/libxml2-2.0
+ >=dev-libs/libxslt-1.0.9
+ >=gnome-base/gnome-vfs-2.0
+ dev-libs/popt
+ sys-libs/ncurses
+ mysql? ( >=dev-db/mysql-3.23.51 )
+ postgres? ( >=dev-db/postgresql-7.2.1 )
+ odbc? ( >=dev-db/unixODBC-2.0.6 )
+ ldap? ( >=net-nds/openldap-2.0.25 )
+ firebird? ( >=dev-db/firebird-1.0 )
+ freetds? ( >=dev-db/freetds-0.5 )
+ sqlite? ( >=dev-db/sqlite-2.4.2 )
+ mdb? ( >=app-office/mdbtools-0.5 )"
+
+DEPEND=">=dev-util/pkgconfig-0.8
+ >=dev-util/intltool-0.22
+ >=sys-devel/gettext-0.11
+ app-text/scrollkeeper
+ doc? ( dev-util/gtk-doc )
+ ${RDEPEND}"
+
+DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README"
+
+# problems with parallel builds
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_unpack() {
+ unpack ${A}
+ gnome2_omf_fix ${S}/doc/Makefile.in
+}
+
+src_compile() {
+
+ local myconf
+
+ use mysql \
+ && myconf="${myconf} --with-mysql=/usr" \
+ || myconf="${myconf} --without-mysql"
+
+ use postgres \
+ && myconf="${myconf} --with-postgres=/usr" \
+ || myconf="${myconf} --without-postgres"
+
+ use odbc \
+ && myconf="${myconf} --with-odbc=/usr" \
+ || myconf="${myconf} --without-odbc"
+
+ use ldap \
+ && myconf="${myconf} --with-ldap=/usr" \
+ || myconf="${myconf} --without-ldap"
+
+ use sqlite \
+ && myconf="$myconf --with-sqlite=/usr" \
+ || myconf="$myconf --without-sqlite"
+
+ use freetds \
+ && myconf="$myconf --with-tds=/usr" \
+ || myconf="$myconf --without-tds"
+
+ use firebird \
+ && myconf="${myconf} --with-firebird=/usr" \
+ || myconf="${myconf} --without-firebird"
+
+ use mdb \
+ && myconf="${myconf} --with-mdb=/usr" \
+ || myconf="${myconf} --without-mdb"
+
+ # not in portage (http://linux.techass.com/projects/xdb/)
+ myconf="${myconf} --without-xbase"
+ myconf="${myconf} --without-msql"
+
+ # closed source dbs
+ myconf="${myconf} --without-ibmdb2"
+ myconf="${myconf} --without-sybase"
+ use oci8 || myconf="${myconf} --without-oracle"
+
+ # workaround for readline-4.1 profile - disables building of gda-config-tool
+ if has_version "=sys-libs/readline-4.1*"; then
+ export CONFIG_TOOL_HEADERS="wrong"
+ fi
+
+ gnome2_src_compile ${myconf}
+
+ unset CONFIG_TOOL_HEADERS
+
+}