summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-01-16 16:11:53 +0000
committerAchim Gottinger <achim@gentoo.org>2001-01-16 16:11:53 +0000
commitd0f09e3c0b4c31b094300c9ae00086f28f9719ce (patch)
treeef5f7d61fd9f703a0af5d8388f6a675e54655c97 /gnome-extra/libgda
parent*** empty log message *** (diff)
downloadhistorical-d0f09e3c0b4c31b094300c9ae00086f28f9719ce.tar.gz
historical-d0f09e3c0b4c31b094300c9ae00086f28f9719ce.tar.bz2
historical-d0f09e3c0b4c31b094300c9ae00086f28f9719ce.zip
Added CORBA-ORBit dependencie
Diffstat (limited to 'gnome-extra/libgda')
-rw-r--r--gnome-extra/libgda/files/digest-libgda-0.2.1-r11
-rw-r--r--gnome-extra/libgda/libgda-0.2.1-r1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/gnome-extra/libgda/files/digest-libgda-0.2.1-r1 b/gnome-extra/libgda/files/digest-libgda-0.2.1-r1
new file mode 100644
index 000000000000..fa9eaf0e0f16
--- /dev/null
+++ b/gnome-extra/libgda/files/digest-libgda-0.2.1-r1
@@ -0,0 +1 @@
+MD5 c8085ace5cfe9beb815fba386dc21164 libgda-0.2.1.tar.gz
diff --git a/gnome-extra/libgda/libgda-0.2.1-r1.ebuild b/gnome-extra/libgda/libgda-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..cc7a70aefc1d
--- /dev/null
+++ b/gnome-extra/libgda/libgda-0.2.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gda lib"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnome-db/${A}"
+HOMEPAGE="http://www.gnome.org/gnome-db"
+
+DEPEND=">=gnome-base/gconf-0.11
+ >=dev-perl/CORBA-ORBit-0.4.3
+ >=dev-db/mysql-3.23.26
+ >=dev-db/unixODBC-1.8.13
+ >=net-nds/openldap-1.2.11"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ --with-mysql=/usr --with-ldap=/usr --with-odbc
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/opt/gnome PREFIX=${D}/usr \
+ GDA_oafinfodir=${D}/opt/gnome/share/oaf install
+
+ dodoc AUTHORS COPYING.* ChangeLog NEWS README THANKS TODO
+}
+
+
+
+