summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2009-06-27 07:40:28 +0000
committerHans de Graaff <graaff@gentoo.org>2009-06-27 07:40:28 +0000
commit93a64a2d8d88d46dba5d3b4cbcdd7479843a0aeb (patch)
treefc0638da0c1088682674a27b4667b8fcd5850818 /gnome-extra
parentInitial commit (#275548) (diff)
downloadhistorical-93a64a2d8d88d46dba5d3b4cbcdd7479843a0aeb.tar.gz
historical-93a64a2d8d88d46dba5d3b4cbcdd7479843a0aeb.tar.bz2
historical-93a64a2d8d88d46dba5d3b4cbcdd7479843a0aeb.zip
Version bump.
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-do-plugins/ChangeLog10
-rw-r--r--gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.2.ebuild59
-rw-r--r--gnome-extra/gnome-do/ChangeLog7
-rw-r--r--gnome-extra/gnome-do/gnome-do-0.8.2.ebuild55
4 files changed, 129 insertions, 2 deletions
diff --git a/gnome-extra/gnome-do-plugins/ChangeLog b/gnome-extra/gnome-do-plugins/ChangeLog
index ecafb87a46a1..5056b25f1792 100644
--- a/gnome-extra/gnome-do-plugins/ChangeLog
+++ b/gnome-extra/gnome-do-plugins/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-extra/gnome-do-plugins
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do-plugins/ChangeLog,v 1.12 2009/06/21 12:01:46 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do-plugins/ChangeLog,v 1.13 2009/06/27 07:40:28 graaff Exp $
+
+*gnome-do-plugins-0.8.2 (27 Jun 2009)
+
+ 27 Jun 2009; Hans de Graaff <graaff@gentoo.org>
+ +gnome-do-plugins-0.8.2.ebuild:
+ Version bump. Switch to EAPI=2 to be able to use more default phases. Use
+ new --enable switches instead of sed to turn on or off certain dependencies.
+ Fix installation bug when building without Banshee.
*gnome-do-plugins-0.8.1.3-r2 (21 Jun 2009)
diff --git a/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.2.ebuild b/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.2.ebuild
new file mode 100644
index 000000000000..44ae6515ce10
--- /dev/null
+++ b/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.2.ebuild,v 1.1 2009/06/27 07:40:28 graaff Exp $
+
+EAPI=2
+
+inherit eutils autotools gnome2 mono versionator
+
+MY_PN="do-plugins"
+PVC=$(get_version_component_range 1-3)
+
+DESCRIPTION="Plugins to put the Do in Gnome Do"
+HOMEPAGE="http://do.davebsd.com/"
+SRC_URI="https://launchpad.net/${MY_PN}/0.8/${PVC}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="banshee evo"
+
+RDEPEND=">=gnome-extra/gnome-do-${PV}
+ dev-dotnet/wnck-sharp
+ banshee? ( >=media-sound/banshee-1.4.2 )
+ evo? ( dev-dotnet/evolution-sharp )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/monodevelop"
+
+src_prepare() {
+ # Filed upstream as https://bugs.launchpad.net/do/+bug/392422
+ use banshee || sed -i -r -e "/(BANSHEE_INDEXER_DLL)/d" BundledLibraries/Makefile.am
+ eautomake
+}
+
+src_configure() {
+ econf --enable-debug=no --enable-release=yes \
+ $(use banshee) \
+ $(use evo evolution) \
+ --disable-flickr || die "configure failed"
+}
+
+src_compile()
+{
+ # The make system is unfortunately broken for parallel builds and
+ # upstream indicated on IRC that they have no intention to fix
+ # that.
+ emake -j1 || die "make failed"
+}
+
+pkg_postinst()
+{
+ ewarn "Plugin handling has changed since gnome-do 0.4."
+ ewarn "If you install the gnome-do-plugins package you will have local copies"
+ ewarn "of the plugins, but you still need to manually enable them in Preferences."
+ ewarn "Also note that plugins installed from upstream may not be compatible with"
+ ewarn "your system. When in doubt check the output from gnome-do itself".
+ ewarn "Old plugins may not be compatible either."
+ ewarn "Check ~/.local/share/gnome-do/ if you have problems with plugins."
+}
diff --git a/gnome-extra/gnome-do/ChangeLog b/gnome-extra/gnome-do/ChangeLog
index 433ce304f8d1..3e2e97024d76 100644
--- a/gnome-extra/gnome-do/ChangeLog
+++ b/gnome-extra/gnome-do/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/gnome-do
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do/ChangeLog,v 1.15 2009/05/31 09:36:14 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do/ChangeLog,v 1.16 2009/06/27 07:37:13 graaff Exp $
+
+*gnome-do-0.8.2 (27 Jun 2009)
+
+ 27 Jun 2009; Hans de Graaff <graaff@gentoo.org> +gnome-do-0.8.2.ebuild:
+ Version bump.
31 May 2009; Hans de Graaff <graaff@gentoo.org>
-gnome-do-0.4.2.0-r2.ebuild, -gnome-do-0.8.0.ebuild:
diff --git a/gnome-extra/gnome-do/gnome-do-0.8.2.ebuild b/gnome-extra/gnome-do/gnome-do-0.8.2.ebuild
new file mode 100644
index 000000000000..cad24b6c2541
--- /dev/null
+++ b/gnome-extra/gnome-do/gnome-do-0.8.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do/gnome-do-0.8.2.ebuild,v 1.1 2009/06/27 07:37:13 graaff Exp $
+
+# TODO: GNOME Do defaults to a debug build; to disable, --enable-release must
+# be passed. However, when doing this the build fails; figure out why.
+
+EAPI=2
+
+inherit gnome2 mono versionator eutils
+
+PVC=$(get_version_component_range 1-3)
+
+DESCRIPTION="GNOME Do allows you to get things done quickly"
+HOMEPAGE="http://do.davebsd.com/"
+SRC_URI="https://launchpad.net/do/0.8/${PVC}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND=">=dev-lang/mono-2.0
+ >=dev-dotnet/gconf-sharp-2.24.0
+ >=dev-dotnet/gtk-sharp-2.12.6
+ >=dev-dotnet/glade-sharp-2.12.6
+ dev-dotnet/dbus-sharp
+ dev-dotnet/dbus-glib-sharp
+ >=dev-dotnet/gnome-desktop-sharp-2.24.0
+ >=dev-dotnet/gnome-keyring-sharp-1.0.0
+ >=dev-dotnet/gnome-sharp-2.24.0
+ >=dev-dotnet/gnomevfs-sharp-2.24.0
+ >=dev-dotnet/wnck-sharp-2.24.0
+ >=dev-dotnet/art-sharp-2.24.0
+ >=dev-dotnet/rsvg-sharp-2.24.0
+ dev-dotnet/mono-addins
+ dev-dotnet/notify-sharp
+ !<gnome-extra/gnome-do-plugins-0.8"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ dev-util/pkgconfig"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_configure() {
+ gnome2_src_configure
+}
+
+src_compile() {
+ default
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+}