summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmando Di Cianno <fafhrd@gentoo.org>2005-04-15 04:31:38 +0000
committerArmando Di Cianno <fafhrd@gentoo.org>2005-04-15 04:31:38 +0000
commit845221bb4ffd09aa1acec3aa1b11f2f5978e5588 (patch)
treed1f947817dd2a7e957280c2a56ffe3e5566f6802 /gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.9.5.ebuild
parentCore GNUstep ebuild bumps; cleaned up dependencies of ancestors of gnustep-env (diff)
downloadhistorical-845221bb4ffd09aa1acec3aa1b11f2f5978e5588.tar.gz
historical-845221bb4ffd09aa1acec3aa1b11f2f5978e5588.tar.bz2
historical-845221bb4ffd09aa1acec3aa1b11f2f5978e5588.zip
Core GNUstep ebuild bumps; cleaned up dependencies of ancestors of gnustep-env
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.9.5.ebuild')
-rw-r--r--gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.9.5.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.9.5.ebuild b/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.9.5.ebuild
new file mode 100644
index 000000000000..940edad8f70d
--- /dev/null
+++ b/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.9.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.9.5.ebuild,v 1.1 2005/04/15 04:30:33 fafhrd Exp $
+
+inherit gnustep
+
+S=${WORKDIR}/gnustep-back-${PV}
+
+DESCRIPTION="Default X11 back-end component for the GNUstep GUI Library."
+
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
+KEYWORDS="~x86 ~ppc ~sparc"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+PROVIDE="virtual/gnustep-back"
+
+IUSE="${IUSE} opengl xim doc"
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ ~gnustep-base/gnustep-make-1.10.0
+ ~gnustep-base/gnustep-base-1.10.3
+ ~gnustep-base/gnustep-gui-0.9.5
+ virtual/xft
+ opengl? ( virtual/opengl virtual/glu )"
+RDEPEND="${DEPEND}
+ ${DEBUG_DEPEND}
+ ${DOC_RDEPEND}"
+
+egnustep_install_domain "System"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/font-make-fix.patch-${PV}
+}
+
+src_compile() {
+ egnustep_env
+
+ use opengl && myconf="--enable-glx"
+ myconf="$myconf `use_enable xim`"
+ myconf="$myconf --enable-server=x11"
+ myconf="$myconf --enable-graphics=xlib --with-name=xlib"
+ econf $myconf || die "configure failed"
+
+ egnustep_make
+}
+