summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-10-06 20:45:06 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-10-06 20:45:06 +0000
commit6470f4ac5b472ee7d10da40dfb9b9166e181ef01 (patch)
tree8621e1eb122f523b48febd6a5d56a7203c5878da /kde-base/kate/kate-4.3.2.ebuild
parentVersion bump. Completely rewritten. Now ship with mkl, and idb. Synchronize e... (diff)
downloadhistorical-6470f4ac5b472ee7d10da40dfb9b9166e181ef01.tar.gz
historical-6470f4ac5b472ee7d10da40dfb9b9166e181ef01.tar.bz2
historical-6470f4ac5b472ee7d10da40dfb9b9166e181ef01.zip
Version bump KDE 4.3.2
Package-Manager: portage-2.2_rc44/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kate/kate-4.3.2.ebuild')
-rw-r--r--kde-base/kate/kate-4.3.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/kde-base/kate/kate-4.3.2.ebuild b/kde-base/kate/kate-4.3.2.ebuild
new file mode 100644
index 000000000000..b5ab1cf49b05
--- /dev/null
+++ b/kde-base/kate/kate-4.3.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-4.3.2.ebuild,v 1.1 2009/10/06 18:16:46 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug +handbook +plasma"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA="doc/kate-plugins"
+ fi
+
+ kde4-meta_src_unpack
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with plasma)"
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kaddressbook:${SLOT}; then
+ echo
+ elog "File templates plugin requires kde-base/kaddressbook:${SLOT}."
+ elog "Please install it if you plan to use this plugin."
+ echo
+ fi
+}