summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-05-03 21:50:30 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-05-03 21:50:30 +0000
commitd56a49ac6fdf2ce7ddacc2a7acd2dff576228ebd (patch)
tree0e95f89e243b104e1a29dba27aede4970eb7c530 /kde-base/kcheckpass
parentUSE minimal controls now headers wrt #315567. Scribus is no reverse depend of... (diff)
downloadhistorical-d56a49ac6fdf2ce7ddacc2a7acd2dff576228ebd.tar.gz
historical-d56a49ac6fdf2ce7ddacc2a7acd2dff576228ebd.tar.bz2
historical-d56a49ac6fdf2ce7ddacc2a7acd2dff576228ebd.zip
Version bump KDE 4.4.3
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kcheckpass')
-rw-r--r--kde-base/kcheckpass/ChangeLog7
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.4.3.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/kcheckpass/ChangeLog b/kde-base/kcheckpass/ChangeLog
index 2b6e1ab24f80..44e27c0014e7 100644
--- a/kde-base/kcheckpass/ChangeLog
+++ b/kde-base/kcheckpass/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kcheckpass
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.157 2010/04/09 04:00:09 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.158 2010/05/03 20:24:25 alexxy Exp $
+
+*kcheckpass-4.4.3 (03 May 2010)
+
+ 03 May 2010; Alexey Shvetsov <alexxy@gentoo.org> +kcheckpass-4.4.3.ebuild:
+ Version bump
*kcheckpass-4.4.2-r1 (09 Apr 2010)
diff --git a/kde-base/kcheckpass/kcheckpass-4.4.3.ebuild b/kde-base/kcheckpass/kcheckpass-4.4.3.ebuild
new file mode 100644
index 000000000000..31ba9936a841
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.4.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.4.3.ebuild,v 1.1 2010/05/03 20:24:25 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdebase-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+DEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/kdebase-4.0.2-pam-optional.patch"
+ "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}