summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-05-07 10:48:07 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-05-07 10:48:07 +0000
commit4816953d7b880b98d593a026f8417178af0c61d9 (patch)
treef2e62f96dd734dff956565c230831b7cc368b4f5 /kde-base/kdebindings-perl
parentVersion bump. Remove intermediate version. (diff)
downloadhistorical-4816953d7b880b98d593a026f8417178af0c61d9.tar.gz
historical-4816953d7b880b98d593a026f8417178af0c61d9.tar.bz2
historical-4816953d7b880b98d593a026f8417178af0c61d9.zip
Version bump to KDE SC 4.6.3.
Package-Manager: portage-2.2.0_alpha31/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kdebindings-perl')
-rw-r--r--kde-base/kdebindings-perl/ChangeLog8
-rw-r--r--kde-base/kdebindings-perl/kdebindings-perl-4.6.3.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/kde-base/kdebindings-perl/ChangeLog b/kde-base/kdebindings-perl/ChangeLog
index 499f6c0dfe9c..88e4fde5cc9b 100644
--- a/kde-base/kdebindings-perl/ChangeLog
+++ b/kde-base/kdebindings-perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdebindings-perl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-perl/ChangeLog,v 1.13 2011/04/07 17:10:57 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-perl/ChangeLog,v 1.14 2011/05/07 10:47:34 scarabeus Exp $
+
+*kdebindings-perl-4.6.3 (07 May 2011)
+
+ 07 May 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ +kdebindings-perl-4.6.3.ebuild:
+ Version bump KDE SC 4.6.3
07 Apr 2011; Tomáš Chvátal <scarabeus@gentoo.org>
kdebindings-perl-4.6.2.ebuild:
diff --git a/kde-base/kdebindings-perl/kdebindings-perl-4.6.3.ebuild b/kde-base/kdebindings-perl/kdebindings-perl-4.6.3.ebuild
new file mode 100644
index 000000000000..09c31d4554f7
--- /dev/null
+++ b/kde-base/kdebindings-perl/kdebindings-perl-4.6.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-perl/kdebindings-perl-4.6.3.ebuild,v 1.1 2011/05/07 10:47:34 scarabeus Exp $
+
+EAPI=4
+
+KMNAME="kdebindings"
+KMMODULE="perl"
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+WEBKIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE Perl bindings"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi attica debug kate okular phonon plasma qimageblitz qscintilla qwt semantic-desktop"
+
+DEPEND="
+ >=dev-lang/perl-5.10.1
+ $(add_kdebase_dep smoke 'akonadi?,attica?,declarative?,kate?,multimedia?,okular?,phonon?,qimageblitz?,qscintilla?,qthelp?,qwt?,semantic-desktop=,webkit?')
+ semantic-desktop? ( >=dev-libs/soprano-2.4.64 )
+"
+RDEPEND="${DEPEND}"
+
+KMLOADLIBS="smoke"
+
+KMEXTRACTONLY="
+ smoke/
+"
+
+src_configure() {
+ mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable kate)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_with okular)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable plasma)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-meta_src_configure
+}