summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2003-04-08 19:58:09 +0000
committerHannes Mehnert <hannes@gentoo.org>2003-04-08 19:58:09 +0000
commitaadc891e549885cd6b94cc9e65394c7a4dfcd2c8 (patch)
treee60771a3353af26abf0cdd8a68d1539a41b2c4b3 /kde-base/kdegraphics
parentadding a new server to sf (diff)
downloadhistorical-aadc891e549885cd6b94cc9e65394c7a4dfcd2c8.tar.gz
historical-aadc891e549885cd6b94cc9e65394c7a4dfcd2c8.tar.bz2
historical-aadc891e549885cd6b94cc9e65394c7a4dfcd2c8.zip
kde-3.0.5b (masked via package.mask)
Diffstat (limited to 'kde-base/kdegraphics')
-rw-r--r--kde-base/kdegraphics/ChangeLog8
-rw-r--r--kde-base/kdegraphics/files/kdegraphics-3.0.5b-kghostviewrc16
-rw-r--r--kde-base/kdegraphics/kdegraphics-3.0.5b.ebuild50
3 files changed, 73 insertions, 1 deletions
diff --git a/kde-base/kdegraphics/ChangeLog b/kde-base/kdegraphics/ChangeLog
index b95069b06df8..111330277077 100644
--- a/kde-base/kdegraphics/ChangeLog
+++ b/kde-base/kdegraphics/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdegraphics
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/ChangeLog,v 1.37 2003/03/19 15:54:35 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/ChangeLog,v 1.38 2003/04/08 19:58:08 hannes Exp $
+
+*kdegraphics-3.0.5b (08 Apr 2003)
+
+ 08 Apr 2003; Hannes Mehnert <hannes@gentoo.org> kdegraphics-3.0.5b.ebuild,
+ files/kdegraphics-3.0.5b-kghostviewrc:
+ version bump
*kdegraphics-3.1.1 (14 Mar 2003)
diff --git a/kde-base/kdegraphics/files/kdegraphics-3.0.5b-kghostviewrc b/kde-base/kdegraphics/files/kdegraphics-3.0.5b-kghostviewrc
new file mode 100644
index 000000000000..5c2e48efba0c
--- /dev/null
+++ b/kde-base/kdegraphics/files/kdegraphics-3.0.5b-kghostviewrc
@@ -0,0 +1,16 @@
+[General]
+Antialiasing=true
+Interpreter=gs
+Messages=false
+Palette=color
+Platform fonts=false
+ShowPageList=true
+ShowPageNames=false
+ShowScrollBars=true
+WatchFile=false
+
+[Ghostscript]
+Antialiasing arguments=-sDEVICE=x11 -dTextAlphaBits=4 -dGraphicsAlphaBits=2 -dMaxBitmap=10000000
+Interpreter=gs
+Non-antialiasing arguments=-sDEVICE=x11
+
diff --git a/kde-base/kdegraphics/kdegraphics-3.0.5b.ebuild b/kde-base/kdegraphics/kdegraphics-3.0.5b.ebuild
new file mode 100644
index 000000000000..6268d6669879
--- /dev/null
+++ b/kde-base/kdegraphics/kdegraphics-3.0.5b.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.0.5b.ebuild,v 1.1 2003/04/08 19:58:08 hannes Exp $
+inherit kde-dist
+
+IUSE="scanner gphoto2 tetex"
+DESCRIPTION="KDE $PV - graphics-related apps"
+
+KEYWORDS="x86 ~ppc ~alpha ~sparc"
+
+newdepend "gphoto2? ( >=media-gfx/gphoto2-2.0_beta1 )
+ dev-lang/perl
+ scanner? ( media-gfx/sane-backends )
+ tetex? ( >=app-text/tetex-1.0.7 )
+ media-libs/imlib
+ app-text/ghostscript"
+# x86? ( scanner? sys-libs/libieee1284 )
+
+use gphoto2 && myconf="$myconf --with-kamera --with-gphoto2-includes=/usr/include/gphoto2 \
+ --with-gphoto2-libraries=/usr/lib/gphoto2 \
+ --with-gpio --with-gpio-includes=/usr/include \
+ --with-gpio-libraries=/usr/lib" || myconf="$myconf --without-kamera"
+
+use tetex && myconf="$myconf --with-system-kpathsea --with-tex-datadir=/usr/share"
+
+use scanner || KDE_REMOVE_DIR="kooka libkscan"
+
+myconf="$myconf --with-imlib --with-imlib-config=/usr/bin "
+
+need-autoconf 2.1
+
+src_unpack() {
+
+ kde_src_unpack
+
+ if [ -z "`use scanner`" ]; then
+ cd $S
+ mv Makefile.am Makefile.am.orig
+ sed -e 's:$(KSCANDIR)::' Makefile.am.orig > Makefile.am
+ fi
+}
+
+src_install() {
+ kde_src_install
+
+ # default kghostviewrc beacuse kghostview doesn't generate a working default run on its 1st run
+ # fix bug #6562
+ dodir $PREFIX/share/config
+ cp $FILESDIR/$P-kghostviewrc $D/$PREFIX/share/config/kghostviewrc
+}