summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-09-01 16:32:24 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-09-01 16:32:24 +0000
commit0941f8f8b9ab158f571c295f3e1a4db8e2117481 (patch)
tree395111f62c037d6bc60c879297b61c7bbb00ccc4 /kde-base/kdepimlibs
parentstable sparc, bug 282379 (diff)
downloadhistorical-0941f8f8b9ab158f571c295f3e1a4db8e2117481.tar.gz
historical-0941f8f8b9ab158f571c295f3e1a4db8e2117481.tar.bz2
historical-0941f8f8b9ab158f571c295f3e1a4db8e2117481.zip
Version bump KDE 4.3.1
Package-Manager: portage-2.2_rc38/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog8
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.3.1.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index 72700abb756f..6661dec3209a 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.36 2009/08/04 00:20:51 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.37 2009/09/01 15:15:01 tampakrap Exp $
+
+*kdepimlibs-4.3.1 (01 Sep 2009)
+
+ 01 Sep 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+ +kdepimlibs-4.3.1.ebuild:
+ Version bump
*kdepimlibs-4.3.0 (04 Aug 2009)
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.3.1.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.3.1.ebuild
new file mode 100644
index 000000000000..b75883d22748
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.3.1.ebuild,v 1.1 2009/09/01 15:15:01 tampakrap Exp $
+
+EAPI="2"
+
+CPPUNIT_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps."
+HOMEPAGE="http://www.kde.org/"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+IUSE="debug +handbook ldap"
+
+# some akonadi tests timeout, that probaly needs more work as its ~700 tests
+RESTRICT="test"
+
+DEPEND="
+ >=app-crypt/gpgme-1.1.6
+ >=app-office/akonadi-server-1.2.0
+ dev-libs/boost
+ dev-libs/libgpg-error
+ >=dev-libs/libical-0.42
+ dev-libs/cyrus-sasl
+ ldap? ( net-nds/openldap )
+"
+# @since 4.3 - libkholidays is in kdepimlibs now
+RDEPEND="${DEPEND}
+ !kdeprefix? (
+ !kde-base/akonadi:4.1
+ !kde-base/libkholidays:4.1
+ !kde-base/libkholidays:4.2
+ )
+"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_build handbook doc)
+ $(cmake-utils_use_with ldap)"
+
+ kde4-base_src_configure
+}