summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-06-04 13:56:48 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-06-04 13:56:48 +0000
commit5a13ccd21de0abab5282365a5070ba7229e9b098 (patch)
tree0793ec455fa77a823da333d1bf4faf15ecd53b10 /kde-base/kdepimlibs
parentFix variable test. Thx to salnx per forums for the fix. (diff)
downloadhistorical-5a13ccd21de0abab5282365a5070ba7229e9b098.tar.gz
historical-5a13ccd21de0abab5282365a5070ba7229e9b098.tar.bz2
historical-5a13ccd21de0abab5282365a5070ba7229e9b098.zip
Version bump KDE 4.2.4
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog7
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.2.4.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index 2f76ffb5a6f6..ca43c8f03710 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.31 2009/06/03 15:26:15 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.32 2009/06/04 12:06:52 alexxy Exp $
+
+*kdepimlibs-4.2.4 (04 Jun 2009)
+
+ 04 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org> +kdepimlibs-4.2.4.ebuild:
+ Version bump
03 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org> -kdepimlibs-4.2.2.ebuild:
Drop KDE 4.2.2
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.2.4.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.2.4.ebuild
new file mode 100644
index 000000000000..3b9db5d8948f
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.2.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.2.4.ebuild,v 1.1 2009/06/04 12:06:52 alexxy Exp $
+
+EAPI="2"
+
+CPPUNIT_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps."
+HOMEPAGE="http://www.kde.org/"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+IUSE="debug +handbook ldap +sasl"
+
+# some akonadi tests timeout, that probaly needs more work as its ~700 tests
+RESTRICT="test"
+
+DEPEND="
+ >=app-crypt/gpgme-1.1.6
+ >=app-office/akonadi-server-1.1
+ dev-libs/boost
+ dev-libs/libgpg-error
+ >=dev-libs/libical-0.33-r1
+ ldap? ( net-nds/openldap )
+ sasl? ( dev-libs/cyrus-sasl )
+"
+RDEPEND="${DEPEND}
+ !kdeprefix? ( !kde-base/akonadi:4.1 )
+"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_build handbook doc)
+ $(cmake-utils_use_with ldap Ldap)
+ $(cmake-utils_use_with sasl Sasl2)"
+
+ kde4-base_src_configure
+}