summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-05-07 00:22:11 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-05-07 00:22:11 +0000
commitee5e4f34061337ffcea150f1c790eea2f794e41c (patch)
tree823b8b79eb6d56c4166f6755dd39875eea0cc790 /kde-base/kdepimlibs
parentRename modprobe.d/alsa file to alsa.conf. (diff)
downloadhistorical-ee5e4f34061337ffcea150f1c790eea2f794e41c.tar.gz
historical-ee5e4f34061337ffcea150f1c790eea2f794e41c.tar.bz2
historical-ee5e4f34061337ffcea150f1c790eea2f794e41c.zip
Version bump KDE 4.2.3
Package-Manager: portage-2.2_rc31/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog8
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.2.3.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index 76a5644bfabf..99f817319a22 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.29 2009/04/17 06:34:17 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.30 2009/05/06 23:15:33 scarabeus Exp $
+
+*kdepimlibs-4.2.3 (06 May 2009)
+
+ 06 May 2009; Tomas Chvatal <scarabeus@gentoo.org>
+ +kdepimlibs-4.2.3.ebuild:
+ Version bump
17 Apr 2009; Alexey Shvetsov <alexxy@gentoo.org> kdepimlibs-4.2.2:
Restore ~hppa keywords
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.2.3.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.2.3.ebuild
new file mode 100644
index 000000000000..f60eb9f16736
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.2.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.2.3.ebuild,v 1.1 2009/05/06 23:15:33 scarabeus Exp $
+
+EAPI="2"
+
+CPPUNIT_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps."
+HOMEPAGE="http://www.kde.org/"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+IUSE="debug doc ldap +sasl"
+
+RESTRICT="test"
+
+DEPEND="
+ >=app-crypt/gpgme-1.1.6
+ >=app-office/akonadi-server-1.1
+ dev-libs/boost
+ dev-libs/libgpg-error
+ >=dev-libs/libical-0.33-r1
+ ldap? ( net-nds/openldap )
+ sasl? ( dev-libs/cyrus-sasl )
+"
+RDEPEND="${DEPEND}
+ !kdeprefix? ( !kde-base/akonadi:4.1 )
+"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_build doc)
+ $(cmake-utils_use_with ldap Ldap)
+ $(cmake-utils_use_with sasl Sasl2)"
+
+ kde4-base_src_configure
+}