summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-04-30 20:00:28 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-04-30 20:00:28 +0000
commitc05fb9b5ef2579cb5750febff75009f07f7951a1 (patch)
tree19eab46a9bb1d9bfad47fe26b68515cafe69a744 /kde-base/kdesktop/kdesktop-3.5.6-r2.ebuild
parentMake OpenSSL dependency mandatory, some minor fixes. (diff)
downloadhistorical-c05fb9b5ef2579cb5750febff75009f07f7951a1.tar.gz
historical-c05fb9b5ef2579cb5750febff75009f07f7951a1.tar.bz2
historical-c05fb9b5ef2579cb5750febff75009f07f7951a1.zip
Remove virtual/x11 dependency, use new patch set.
Package-Manager: portage-2.1.2.5
Diffstat (limited to 'kde-base/kdesktop/kdesktop-3.5.6-r2.ebuild')
-rw-r--r--kde-base/kdesktop/kdesktop-3.5.6-r2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/kde-base/kdesktop/kdesktop-3.5.6-r2.ebuild b/kde-base/kdesktop/kdesktop-3.5.6-r2.ebuild
new file mode 100644
index 000000000000..1f9141da7e37
--- /dev/null
+++ b/kde-base/kdesktop/kdesktop-3.5.6-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesktop/kdesktop-3.5.6-r2.ebuild,v 1.1 2007/04/30 20:00:28 carlo Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdebase-3.5-patchset-04.tar.bz2"
+
+DESCRIPTION="KDesktop is the KDE interface that handles the icons, desktop popup menus and the screensaver system."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kdehiddenvisibility xscreensaver"
+
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkonq)
+ $(deprange $PV $MAXKDEVER kde-base/kcontrol)
+ xscreensaver? ( x11-proto/scrnsaverproto )"
+ # Requires the desktop background settings module,
+ # so until we separate the kcontrol modules into separate ebuilds :-),
+ # there's a dep here
+RDEPEND="${DEPEND}
+ $(deprange $PV $MAXKDEVER kde-base/kcheckpass)
+ $(deprange 3.5.5 $MAXKDEVER kde-base/kdialog)
+ $(deprange $PV $MAXKDEVER kde-base/konqueror)
+ xscreensaver? ( x11-libs/libXScrnSaver )"
+
+KMCOPYLIB="libkonq libkonq/"
+KMEXTRACTONLY="kcheckpass/kcheckpass.h
+ libkonq/
+ kdm/kfrontend/themer/
+ kioslave/thumbnail/configure.in.in" # for the HAVE_LIBART test
+KMCOMPILEONLY="kcontrol/background
+ kdmlib/"
+KMNODOCS=true
+
+PATCHES="${FILESDIR}/${PN}-3.5.5-seli-xinerama.patch"
+
+src_unpack() {
+ kde-meta_src_unpack
+ # see bug #143375
+ sed -e "s:SUBDIRS = . lock pics patterns programs init:SUBDIRS = . lock pics patterns programs:" \
+ -i kdesktop/Makefile.am
+}
+src_compile() {
+ myconf="${myconf} $(use_with xscreensaver)"
+ kde-meta_src_compile
+}
+
+src_install() {
+ # ugly, needs fixing: don't install kcontrol/background
+ kde-meta_src_install
+
+ rmdir "${D}/${PREFIX}/share/templates/.source/emptydir"
+}
+
+pkg_postinst() {
+ kde_pkg_postinst
+ mkdir -p "${PREFIX}/share/templates/.source/emptydir"
+}