summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-09-07 20:14:08 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-09-07 20:14:08 +0000
commit5f9a89edfc761f6e642eaf86247fccacdd48d248 (patch)
treed6c5667c5d199a8f311d21b4e1273d740f0b4d06 /kde-base/korganizer/korganizer-4.7.1.ebuild
parent[profiles] Update kde mask (diff)
downloadhistorical-5f9a89edfc761f6e642eaf86247fccacdd48d248.tar.gz
historical-5f9a89edfc761f6e642eaf86247fccacdd48d248.tar.bz2
historical-5f9a89edfc761f6e642eaf86247fccacdd48d248.zip
[kde-base] Add KDE SC 4.7.1
Package-Manager: portage-2.2.0_alpha54/cvs/Linux x86_64
Diffstat (limited to 'kde-base/korganizer/korganizer-4.7.1.ebuild')
-rw-r--r--kde-base/korganizer/korganizer-4.7.1.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/kde-base/korganizer/korganizer-4.7.1.ebuild b/kde-base/korganizer/korganizer-4.7.1.ebuild
new file mode 100644
index 000000000000..abef9ace1cdb
--- /dev/null
+++ b/kde-base/korganizer/korganizer-4.7.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korganizer/korganizer-4.7.1.ebuild,v 1.1 2011/09/07 20:13:53 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+KDE_SCM="git"
+inherit kde4-meta
+
+DESCRIPTION="A Personal Organizer for KDE"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep kdepim-common-libs)
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+# Moved after 4.3.90
+add_blocker kontact-specialdates
+
+KMLOADLIBS="kdepim-common-libs"
+
+# xml targets from kmail are being uncommented by kde4-meta.eclass
+KMEXTRACTONLY="
+ akonadi_next/
+ calendarviews/
+ kdgantt2/
+ kmail/
+ knode/org.kde.knode.xml
+ libkdepimdbusinterfaces/
+"
+
+KMCOMPILEONLY="
+ incidenceeditor-ng/
+ calendarsupport/
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.5.64_missing_header.patch"
+)
+
+src_unpack() {
+ if use kontact; then
+ KMEXTRA="${KMEXTRA}
+ kontact/plugins/planner/
+ kontact/plugins/specialdates/
+ "
+ fi
+
+ kde4-meta_src_unpack
+}
+
+src_install() {
+ kde4-meta_src_install
+ # colliding with kdepim-common-libs
+ rm -rf "${ED}"/usr/share/kde4/servicetypes/calendarplugin.desktop
+ rm -rf "${ED}"/usr/share/kde4/servicetypes/calendardecoration.desktop
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
+ echo
+ fi
+}