summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Hüttel <dilfridge@gentoo.org>2012-03-06 23:35:37 +0000
committerAndreas Hüttel <dilfridge@gentoo.org>2012-03-06 23:35:37 +0000
commit1eabee5424cb6b7feaebe52560d20f05e73e82c4 (patch)
treef0cdbe1f3e025f18ec8c0d13283c9223dba031ca /kde-base/ksplash
parentAdd support for Prefix. bug #407193 (diff)
downloadhistorical-1eabee5424cb6b7feaebe52560d20f05e73e82c4.tar.gz
historical-1eabee5424cb6b7feaebe52560d20f05e73e82c4.tar.bz2
historical-1eabee5424cb6b7feaebe52560d20f05e73e82c4.zip
Version bump KDE SC 4.8.1
Package-Manager: portage-2.1.10.49/cvs/Linux x86_64
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog7
-rw-r--r--kde-base/ksplash/ksplash-4.8.1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index 1146d1203c82..2ee518293f4b 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.115 2012/02/21 12:52:23 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.116 2012/03/06 23:35:01 dilfridge Exp $
+
+*ksplash-4.8.1 (06 Mar 2012)
+
+ 06 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> +ksplash-4.8.1.ebuild:
+ Version bump KDE SC 4.8.1
20 Feb 2012; Johannes Huber <johu@gentoo.org> -ksplash-4.6.3.ebuild:
Remove KDE SC 4.6.3
diff --git a/kde-base/ksplash/ksplash-4.8.1.ebuild b/kde-base/ksplash/ksplash-4.8.1.ebuild
new file mode 100644
index 000000000000..89cf9d054ee4
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.8.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.8.1.ebuild,v 1.1 2012/03/06 23:35:01 dilfridge Exp $
+
+EAPI=4
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+COMMONDEPEND="
+ media-libs/libpng
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-4.4.2-xinerama_cmake_automagic.patch" )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_has 3dnow X86_3DNOW)
+ $(cmake-utils_use_has altivec PPC_ALTIVEC)
+ $(cmake-utils_use_has mmx X86_MMX)
+ $(cmake-utils_use_has sse X86_SSE)
+ $(cmake-utils_use_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama X11_Xinerama)
+ )
+
+ kde4-meta_src_configure
+}