summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-06-04 13:56:48 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-06-04 13:56:48 +0000
commit5a13ccd21de0abab5282365a5070ba7229e9b098 (patch)
tree0793ec455fa77a823da333d1bf4faf15ecd53b10 /kde-base/kttsd
parentFix variable test. Thx to salnx per forums for the fix. (diff)
downloadhistorical-5a13ccd21de0abab5282365a5070ba7229e9b098.tar.gz
historical-5a13ccd21de0abab5282365a5070ba7229e9b098.tar.bz2
historical-5a13ccd21de0abab5282365a5070ba7229e9b098.zip
Version bump KDE 4.2.4
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kttsd')
-rw-r--r--kde-base/kttsd/ChangeLog7
-rw-r--r--kde-base/kttsd/kttsd-4.2.4.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/kde-base/kttsd/ChangeLog b/kde-base/kttsd/ChangeLog
index b04b76cf97e7..f760d67103b4 100644
--- a/kde-base/kttsd/ChangeLog
+++ b/kde-base/kttsd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kttsd
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/ChangeLog,v 1.119 2009/06/03 19:54:33 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/ChangeLog,v 1.120 2009/06/04 13:27:12 alexxy Exp $
+
+*kttsd-4.2.4 (04 Jun 2009)
+
+ 04 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org> +kttsd-4.2.4.ebuild:
+ Version bump
03 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org> -kttsd-4.2.2.ebuild:
Drop KDE 4.2.2
diff --git a/kde-base/kttsd/kttsd-4.2.4.ebuild b/kde-base/kttsd/kttsd-4.2.4.ebuild
new file mode 100644
index 000000000000..7e219d3c4dae
--- /dev/null
+++ b/kde-base/kttsd/kttsd-4.2.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/kttsd-4.2.4.ebuild,v 1.1 2009/06/04 13:27:12 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdeaccessibility"
+inherit kde4-meta
+
+DESCRIPTION="KDE text-to-speech subsystem"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="alsa debug +handbook +ktts +phonon"
+
+DEPEND="
+ ktts? (
+ alsa? ( >=media-libs/alsa-lib-1.0.14a )
+ phonon? ( >=media-sound/phonon-4.3.1 )
+ )
+"
+RDEPEND="${DEPEND}
+ >=kde-base/kcmshell-${PV}:${SLOT}[kdeprefix=]
+ >=kde-base/knotify-${PV}:${SLOT}[kdeprefix=]
+ ktts? (
+ app-accessibility/epos
+ app-accessibility/festival
+ app-accessibility/flite
+ app-accessibility/freetts
+ )
+"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with alsa Alsa)
+ -DKDE4_KTTSD_PHONON=$(use phonon && echo OFF || echo ON)
+ -DKDE4_KTTSD_ALSA=$(use alsa && echo ON || echo OFF)
+ $(cmake-utils_use_with ktts Kttsmodule)"
+
+ kde4-meta_src_configure
+}