summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-04-25 15:38:45 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-04-25 15:38:45 +0000
commitd283bc0fd8d3cc14b7e3207356828245c6d4cca1 (patch)
treec9ca46748242faa2871af500b296ec16709b8023 /kde-base/noatun-plugins
parentRemove mask for dev-java/eclipse-{core,osgi,jface} as they were removed from ... (diff)
downloadhistorical-d283bc0fd8d3cc14b7e3207356828245c6d4cca1.tar.gz
historical-d283bc0fd8d3cc14b7e3207356828245c6d4cca1.tar.bz2
historical-d283bc0fd8d3cc14b7e3207356828245c6d4cca1.zip
Ensure libsdl is built with X support.
Package-Manager: portage-2.1.2.4
Diffstat (limited to 'kde-base/noatun-plugins')
-rw-r--r--kde-base/noatun-plugins/ChangeLog6
-rw-r--r--kde-base/noatun-plugins/noatun-plugins-3.5.6.ebuild10
2 files changed, 14 insertions, 2 deletions
diff --git a/kde-base/noatun-plugins/ChangeLog b/kde-base/noatun-plugins/ChangeLog
index 007c368e1f9d..d43d48e2cee7 100644
--- a/kde-base/noatun-plugins/ChangeLog
+++ b/kde-base/noatun-plugins/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/noatun-plugins
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/ChangeLog,v 1.65 2007/02/05 12:13:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/ChangeLog,v 1.66 2007/04/25 15:37:03 carlo Exp $
+
+ 25 Apr 2007; Carsten Lohrke <carlo@gentoo.org>
+ noatun-plugins-3.5.6.ebuild:
+ Ensure libsdl is built with X support.
05 Feb 2007; Diego Pettenò <flameeyes@gentoo.org>
-files/noatun-oblique-db-location-3.4.0_rc1.diff,
diff --git a/kde-base/noatun-plugins/noatun-plugins-3.5.6.ebuild b/kde-base/noatun-plugins/noatun-plugins-3.5.6.ebuild
index 68e917d3f99a..6c103964b693 100644
--- a/kde-base/noatun-plugins/noatun-plugins-3.5.6.ebuild
+++ b/kde-base/noatun-plugins/noatun-plugins-3.5.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/noatun-plugins-3.5.6.ebuild,v 1.2 2007/01/18 16:11:50 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/noatun-plugins-3.5.6.ebuild,v 1.3 2007/04/25 15:37:03 carlo Exp $
KMNAME=kdeaddons
MAXKDEVER=$PV
KM_DEPRANGE="$PV $MAXKDEVER"
@@ -17,6 +17,14 @@ DEPEND="$(deprange-dual $PV $MAXKDEVER kde-base/noatun)
RDEPEND="${DEPEND}"
+pkg_setup() {
+ kde_pkg_setup
+ if use sdl && ! built_with_use media-libs/libsdl X ; then
+ eerror "media-libs/libsdl is not build with X support."
+ die "Please reemerge media-libs/libsdl with USE=\"X\"."
+ fi
+}
+
src_compile() {
local myconf="$(use_with sdl)"