summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-03-04 23:02:08 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-03-04 23:02:08 +0000
commit4de417b1bb3bc2e9455805558437ef13d2cf9344 (patch)
tree870de20bd2e0eebb646138c5b5ac72aca4b40b3a /kde-base/okular
parentVersion bump. (diff)
downloadhistorical-4de417b1bb3bc2e9455805558437ef13d2cf9344.tar.gz
historical-4de417b1bb3bc2e9455805558437ef13d2cf9344.tar.bz2
historical-4de417b1bb3bc2e9455805558437ef13d2cf9344.zip
Bump KDE 4.2.1
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'kde-base/okular')
-rw-r--r--kde-base/okular/ChangeLog7
-rw-r--r--kde-base/okular/okular-4.2.1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-base/okular/ChangeLog b/kde-base/okular/ChangeLog
index cadbb4614b22..a5f9dfefc16b 100644
--- a/kde-base/okular/ChangeLog
+++ b/kde-base/okular/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/okular
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.24 2009/02/19 12:17:09 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.25 2009/03/04 22:50:30 alexxy Exp $
+
+*okular-4.2.1 (04 Mar 2009)
+
+ 04 Mar 2009; Alexey Shvetsov <alexxy@gentoo.org> +okular-4.2.1.ebuild:
+ Bump KDE 4.2.1
*okular-4.2.0-r1 (19 Feb 2009)
diff --git a/kde-base/okular/okular-4.2.1.ebuild b/kde-base/okular/okular-4.2.1.ebuild
new file mode 100644
index 000000000000..46e446a7c5ec
--- /dev/null
+++ b/kde-base/okular/okular-4.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/okular-4.2.1.ebuild,v 1.1 2009/03/04 22:50:30 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdegraphics"
+inherit kde4-meta
+
+DESCRIPTION="Okular is an universal document viewer based on KPDF for KDE 4."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="chm crypt debug +djvu +ebook jpeg +ps +pdf +tiff"
+
+DEPEND="
+ media-libs/freetype
+ chm? ( dev-libs/chmlib )
+ crypt? ( app-crypt/qca:2 )
+ djvu? ( app-text/djvu )
+ ebook? ( app-text/ebook-tools )
+ jpeg? ( media-libs/jpeg )
+ ps? ( app-text/libspectre )
+ pdf? ( >=app-text/poppler-0.8.5
+ >=app-text/poppler-bindings-0.8.5[qt4] )
+ tiff? ( media-libs/tiff )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with chm CHM)
+ $(cmake-utils_use_with crypt QCA2)
+ $(cmake-utils_use_with djvu DjVuLibre)
+ $(cmake-utils_use_with ebook EPub)
+ $(cmake-utils_use_with jpeg JPEG)
+ $(cmake-utils_use_with ps LibSpectre)
+ $(cmake-utils_use_with pdf PopplerQt4)
+ $(cmake-utils_use_with pdf Poppler)
+ $(cmake-utils_use_with tiff TIFF)"
+
+ kde4-meta_src_configure
+}