summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:22:07 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:22:07 +0000
commitda5d5f09df2e4e90c0cd74da456f5f3cb94908e4 (patch)
tree45396c85f5c09aaa486e5e0f07d22f80e4fdb148 /kde-base/smoke
parent[kde-base/kfile] Version bump to KDE SC 4.4.0 (diff)
downloadhistorical-da5d5f09df2e4e90c0cd74da456f5f3cb94908e4.tar.gz
historical-da5d5f09df2e4e90c0cd74da456f5f3cb94908e4.tar.bz2
historical-da5d5f09df2e4e90c0cd74da456f5f3cb94908e4.zip
[kde-base/smoke] Version bump to KDE SC 4.4.0
Package-Manager: portage-2.2_rc62/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/smoke')
-rw-r--r--kde-base/smoke/ChangeLog7
-rw-r--r--kde-base/smoke/smoke-4.4.0.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/kde-base/smoke/ChangeLog b/kde-base/smoke/ChangeLog
index 975768c56843..82ec2bd705d3 100644
--- a/kde-base/smoke/ChangeLog
+++ b/kde-base/smoke/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/smoke
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.91 2010/01/27 03:15:09 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.92 2010/02/09 00:22:07 alexxy Exp $
+
+*smoke-4.4.0 (09 Feb 2010)
+
+ 09 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org> +smoke-4.4.0.ebuild:
+ Version bump to KDE SC 4.4.0
27 Jan 2010; Jonathan Callen <abcd@gentoo.org> smoke-4.3.5.ebuild:
Fix deps
diff --git a/kde-base/smoke/smoke-4.4.0.ebuild b/kde-base/smoke/smoke-4.4.0.ebuild
new file mode 100644
index 000000000000..57724d696c95
--- /dev/null
+++ b/kde-base/smoke/smoke-4.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/smoke-4.4.0.ebuild,v 1.1 2010/02/09 00:22:07 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebindings"
+WEBKIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="akonadi kdevplatform okular +phonon qimageblitz qtmultimedia qscintilla qwt semantic-desktop"
+
+COMMON_DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ akonadi? ( $(add_kdebase_dep kdepimlibs) )
+ kdevplatform? ( dev-util/kdevplatform:4 )
+ okular? ( $(add_kdebase_dep okular) )
+ phonon? ( >=media-sound/phonon-4.3.80[xcb] )
+ qimageblitz? ( >=kde-base/qimageblitz-0.0.4 )
+ qscintilla? ( x11-libs/qscintilla )
+ qwt? ( x11-libs/qwt:5 )
+"
+
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+KMEXTRA="generator/"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_enable akonadi)
+ $(cmake-utils_use_enable akonadi Kdepimlibs)
+ $(cmake-utils_use_enable kdevplatform KDEVPLATFORM_SMOKE)
+ $(cmake-utils_use_enable okular)
+ $(cmake-utils_use_enable phonon PHONON_SMOKE)
+ $(cmake-utils_use_enable qimageblitz QIMAGEBLITZ_SMOKE)
+ $(cmake-utils_use_enable qscintilla QSCI_SMOKE)
+ $(cmake-utils_use_enable qtmultimedia QTMULTIMEDIA_SMOKE)
+ $(cmake-utils_use_enable qwt QWT_SMOKE)
+ $(cmake-utils_use_enable semantic-desktop Nepomuk)
+ $(cmake-utils_use_enable semantic-desktop Soprano)
+ $(cmake-utils_use_enable webkit QTWEBKIT_SMOKE)
+ )
+ kde4-meta_src_configure
+}