summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-03-30 22:09:01 +0000
committerDror Levin <spatz@gentoo.org>2010-03-30 22:09:01 +0000
commitc7727be4b0afc8770706af012e82f18d8ebbe310 (patch)
tree5159793e5568a4b70770653cf9afd9c74989ef2e /kde-base/step
parentold (diff)
downloadhistorical-c7727be4b0afc8770706af012e82f18d8ebbe310.tar.gz
historical-c7727be4b0afc8770706af012e82f18d8ebbe310.tar.bz2
historical-c7727be4b0afc8770706af012e82f18d8ebbe310.zip
Version bump KDE 4.4.2
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/step')
-rw-r--r--kde-base/step/ChangeLog7
-rw-r--r--kde-base/step/step-4.4.2.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/kde-base/step/ChangeLog b/kde-base/step/ChangeLog
index 8e15e8542e5d..db6c90ffc667 100644
--- a/kde-base/step/ChangeLog
+++ b/kde-base/step/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/step
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.46 2010/03/11 18:38:29 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.47 2010/03/30 22:06:16 spatz Exp $
+
+*step-4.4.2 (30 Mar 2010)
+
+ 30 Mar 2010; Dror Levin <spatz@gentoo.org> +step-4.4.2.ebuild:
+ Version bump
11 Mar 2010; Brent Baude <ranger@gentoo.org> step-4.3.5.ebuild:
Marking step-4.3.5 ppc stable for bug 300393
diff --git a/kde-base/step/step-4.4.2.ebuild b/kde-base/step/step-4.4.2.ebuild
new file mode 100644
index 000000000000..cb3f1d47a2be
--- /dev/null
+++ b/kde-base/step/step-4.4.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/step-4.4.2.ebuild,v 1.1 2010/03/30 22:06:16 spatz Exp $
+
+EAPI="3"
+
+KMNAME="kdeedu"
+inherit kde4-meta
+
+DESCRIPTION="The KDE physics simulator"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook +gsl +qalculate"
+
+DEPEND="
+ >=dev-cpp/eigen-2.0.3:2
+ sci-libs/cln
+ >=sci-mathematics/gmm-3.0
+ gsl? ( >=sci-libs/gsl-1.9-r1 )
+ qalculate? ( >=sci-libs/libqalculate-0.9.5 )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.2-solaris.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with gsl)
+ $(cmake-utils_use_with qalculate)
+ )
+
+ kde4-meta_src_configure
+}