summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-04-05 12:34:25 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-04-05 12:34:25 +0000
commit17eeae897110dd59a4f3ebed170661eaabbb4c0a (patch)
tree2676af6ce2c2885dfa6d0a547c971f4909764c0d /kde-base
parentRemove old files. (diff)
downloadhistorical-17eeae897110dd59a4f3ebed170661eaabbb4c0a.tar.gz
historical-17eeae897110dd59a4f3ebed170661eaabbb4c0a.tar.bz2
historical-17eeae897110dd59a4f3ebed170661eaabbb4c0a.zip
Remove old ebuild.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/arts/arts-1.3.1.ebuild85
-rw-r--r--kde-base/arts/files/arts-1.3.1-alsa-bigendian.patch15
-rw-r--r--kde-base/arts/files/digest-arts-1.3.11
3 files changed, 0 insertions, 101 deletions
diff --git a/kde-base/arts/arts-1.3.1.ebuild b/kde-base/arts/arts-1.3.1.ebuild
deleted file mode 100644
index 5de1e8035e0d..000000000000
--- a/kde-base/arts/arts-1.3.1.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.3.1.ebuild,v 1.15 2005/01/15 12:54:34 danarmak Exp $
-
-inherit kde flag-o-matic eutils
-set-kdedir 3.3
-
-DESCRIPTION="aRts, the KDE sound (and all-around multimedia) server/output manager"
-HOMEPAGE="http://multimedia.kde.org/"
-SRC_URI="mirror://kde/stable/${PV/1.3.1/3.3.1}/src/${PN}-${PV}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="3.3"
-KEYWORDS="amd64 hppa ppc ppc64 sparc x86 alpha"
-IUSE="alsa oggvorbis esd artswrappersuid jack mad"
-
-DEPEND="alsa? ( media-libs/alsa-lib virtual/alsa )
- oggvorbis? ( media-libs/libvorbis media-libs/libogg )
- esd? ( media-sound/esound )
- jack? ( media-sound/jack-audio-connection-kit )
- mad? ( media-libs/libmad media-libs/libid3tag )
- media-libs/audiofile
- >=dev-libs/glib-2
- >=x11-libs/qt-3.3
- >=sys-apps/portage-2.0.49-r8"
-
-# patch to configure.in.in that makes the vorbis, libmad deps optional
-# has no version number in its filename because it's the same for all
-# arts versions - the patched file hasn't changed in a year's time
-# PATCHES="$FILESDIR/optional-deps.diff"
-
-src_unpack() {
- kde_src_unpack
- epatch ${FILESDIR}/1.3.0-jack-configure.in.in.patch
- epatch ${FILESDIR}/${P}-alsa-bigendian.patch
- kde_sandbox_patch ${S}/soundserver
- # for the configure.in.in patch, for some reason it's not automatically picked up
- # rm -f $S/configure
-
- cd ${S} && make -f admin/Makefile.common
- # use amd64 && epatch ${FILESDIR}/arts-${PV}-buffer.patch
- # this patch fixes the high cpu usage of mp3 and vorbis
- # epatch ${FILESDIR}/arts-vorbis-fix.dif
-}
-
-src_compile() {
-
- #fix bug 13453
- filter-flags -foptimize-sibling-calls
-
- #fix bug 41980
- use sparc && filter-flags -fomit-frame-pointer
-
- myconf="$myconf $(use_enable alsa) $(use_enable oggvorbis vorbis) $(use_enable mad libmad) $(use_enable jack)"
-
- kde_src_compile
-}
-
-src_install() {
- kde_src_install
- dodoc ${S}/doc/{NEWS,README,TODO}
-
- # moved here from kdelibs so that when arts is installed
- # without kdelibs it's still in the path.
- dodir /etc/env.d
-echo "PATH=${PREFIX}/bin
-ROOTPATH=${PREFIX}/sbin:${PREFIX}/bin
-LDPATH=${PREFIX}/lib
-CONFIG_PROTECT=\"${PREFIX}/share/config ${PREFIX}/env ${PREFIX}/shutdown\"" > ${D}/etc/env.d/47kdepaths-3.3.1 # number goes down with version upgrade
-
- echo "KDEDIR=$PREFIX" > ${D}/etc/env.d/58kdedir-3.3.1 # number goes up with version upgrade
-
- # used for realtime priority, but off by default as it is a security hazard
- use artswrappersuid && chmod u+s ${D}/${PREFIX}/bin/artswrapper
-}
-
-pkg_postinst() {
- if ! use artswrappersuid ; then
- einfo "Run chmod +s ${PREFIX}/bin/artswrapper to let artsd use realtime priority"
- einfo "and so avoid possible skips in sound. However, on untrusted systems this"
- einfo "creates the possibility of a DoS attack that'll use 100% cpu at realtime"
- einfo "priority, and so is off by default. See bug #7883."
- einfo "Or, you can set the local artswrappersuid USE flag to make the ebuild do this."
- fi
-}
diff --git a/kde-base/arts/files/arts-1.3.1-alsa-bigendian.patch b/kde-base/arts/files/arts-1.3.1-alsa-bigendian.patch
deleted file mode 100644
index c4dc0754c29f..000000000000
--- a/kde-base/arts/files/arts-1.3.1-alsa-bigendian.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -ruN arts-1.3.1.orig/flow/audioioalsa.cc arts-1.3.1/flow/audioioalsa.cc
---- arts-1.3.1.orig/flow/audioioalsa.cc 2004-11-14 17:58:25.343403280 +0100
-+++ arts-1.3.1/flow/audioioalsa.cc 2004-11-14 17:54:27.951492336 +0100
-@@ -114,7 +114,11 @@
- */
- m_card = snd_defaults_pcm_card(); //!! need interface !!
- m_device = snd_defaults_pcm_device(); //!!
-+#ifdef WORDS_BIGENDIAN
-+ m_format = SND_PCM_SFMT_S16_BE;
-+#else
- m_format = SND_PCM_SFMT_S16_LE;
-+#endif
- m_bufferMode = block; //block/stream (stream mode doesn't work yet)
-
- if(m_card >= 0) {
diff --git a/kde-base/arts/files/digest-arts-1.3.1 b/kde-base/arts/files/digest-arts-1.3.1
deleted file mode 100644
index 90d364d32d4d..000000000000
--- a/kde-base/arts/files/digest-arts-1.3.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 26554e4c47d9a52bc20a07e39d32a731 arts-1.3.1.tar.bz2 967242