summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2011-04-10 17:04:18 +0000
committerChristian Faulhammer <fauli@gentoo.org>2011-04-10 17:04:18 +0000
commit153c98c8732c5866ed2042d3d8544176e130bdb5 (patch)
treee2ac5e0e0e0eb1fe1402e37becaaf53f28f641a7 /mail-client/claws-mail-geolocation
parentNew ebuild; required dependency for FindBugs. (diff)
downloadhistorical-153c98c8732c5866ed2042d3d8544176e130bdb5.tar.gz
historical-153c98c8732c5866ed2042d3d8544176e130bdb5.tar.bz2
historical-153c98c8732c5866ed2042d3d8544176e130bdb5.zip
version bump
Package-Manager: portage-2.1.9.42/cvs/Linux i686
Diffstat (limited to 'mail-client/claws-mail-geolocation')
-rw-r--r--mail-client/claws-mail-geolocation/ChangeLog8
-rw-r--r--mail-client/claws-mail-geolocation/claws-mail-geolocation-0.0.5.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/mail-client/claws-mail-geolocation/ChangeLog b/mail-client/claws-mail-geolocation/ChangeLog
index 2e7301b44d5c..8bf738a2bc1c 100644
--- a/mail-client/claws-mail-geolocation/ChangeLog
+++ b/mail-client/claws-mail-geolocation/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/claws-mail-geolocation
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-geolocation/ChangeLog,v 1.8 2011/03/06 13:18:12 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-geolocation/ChangeLog,v 1.9 2011/04/10 16:50:19 fauli Exp $
+
+*claws-mail-geolocation-0.0.5 (10 Apr 2011)
+
+ 10 Apr 2011; Christian Faulhammer <fauli@gentoo.org>
+ +claws-mail-geolocation-0.0.5.ebuild:
+ version bump
06 Mar 2011; Christian Faulhammer <fauli@gentoo.org>
claws-mail-geolocation-0.0.4.ebuild:
diff --git a/mail-client/claws-mail-geolocation/claws-mail-geolocation-0.0.5.ebuild b/mail-client/claws-mail-geolocation/claws-mail-geolocation-0.0.5.ebuild
new file mode 100644
index 000000000000..266df45927e1
--- /dev/null
+++ b/mail-client/claws-mail-geolocation/claws-mail-geolocation-0.0.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-geolocation/claws-mail-geolocation-0.0.5.ebuild,v 1.1 2011/04/10 16:50:19 fauli Exp $
+
+EAPI=3
+
+inherit autotools
+
+MY_P="geolocation_plugin-${PV}"
+
+DESCRIPTION="GeoLocation functionality for Claws Mail"
+HOMEPAGE="http://www.claws-mail.org/"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Check if other versions of libchamplain ship the same pc file
+RDEPEND=">=mail-client/claws-mail-3.7.9
+ media-libs/clutter-gtk:0.10
+ =media-libs/libchamplain-0.6*[gtk]
+ sys-devel/gettext"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # geolocation checks for the exact version, so fix the code
+ # see bug 326981
+ sed -e "s:champlain-gtk-0.4:champlain-gtk-0.6:" -i "${S}"/configure.ac || die
+ eautoconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README
+}