summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2004-10-17 23:10:46 +0000
committerMarius Mauch <genone@gentoo.org>2004-10-17 23:10:46 +0000
commit6f09d6e3fca97eed4528987bf1e0a3c8bc73a631 (patch)
tree82d70701e62a27979b2dc1f5412bb43174acb43e /mail-client/sylpheed-claws-vcalendar
parentFixed broken Manifest. (diff)
downloadhistorical-6f09d6e3fca97eed4528987bf1e0a3c8bc73a631.tar.gz
historical-6f09d6e3fca97eed4528987bf1e0a3c8bc73a631.tar.bz2
historical-6f09d6e3fca97eed4528987bf1e0a3c8bc73a631.zip
sylpheed-claws plugin splitup
Diffstat (limited to 'mail-client/sylpheed-claws-vcalendar')
-rw-r--r--mail-client/sylpheed-claws-vcalendar/ChangeLog11
-rw-r--r--mail-client/sylpheed-claws-vcalendar/Manifest3
-rw-r--r--mail-client/sylpheed-claws-vcalendar/files/digest-sylpheed-claws-vcalendar-0.41
-rw-r--r--mail-client/sylpheed-claws-vcalendar/files/vcalendar-0.4-ical.patch57
-rw-r--r--mail-client/sylpheed-claws-vcalendar/metadata.xml15
-rw-r--r--mail-client/sylpheed-claws-vcalendar/sylpheed-claws-vcalendar-0.4.ebuild35
6 files changed, 122 insertions, 0 deletions
diff --git a/mail-client/sylpheed-claws-vcalendar/ChangeLog b/mail-client/sylpheed-claws-vcalendar/ChangeLog
new file mode 100644
index 000000000000..1c5556e3a6b1
--- /dev/null
+++ b/mail-client/sylpheed-claws-vcalendar/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for mail-client/sylpheed-claws-vcalendar
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-vcalendar/ChangeLog,v 1.1 2004/10/17 23:10:46 genone Exp $
+
+*sylpheed-claws-vcalendar-0.4 (18 Oct 2004)
+
+ 18 Oct 2004; <genone@gentoo.org> +metadata.xml,
+ +files/vcalendar-0.4-ical.patch, +sylpheed-claws-vcalendar-0.4.ebuild:
+ initial commit, this package was split from the main sylpheed-claws package
+ for easier maintenance.
+
diff --git a/mail-client/sylpheed-claws-vcalendar/Manifest b/mail-client/sylpheed-claws-vcalendar/Manifest
new file mode 100644
index 000000000000..645ac73cd291
--- /dev/null
+++ b/mail-client/sylpheed-claws-vcalendar/Manifest
@@ -0,0 +1,3 @@
+MD5 f4b7f3585adda440b21d79eaf261d356 sylpheed-claws-vcalendar-0.4.ebuild 642
+MD5 b37803e0c16b331a3c49b1e252491791 files/digest-sylpheed-claws-vcalendar-0.4 65
+MD5 613d1581a8bff15e6aa7e083ae3cca37 files/vcalendar-0.4-ical.patch 2308
diff --git a/mail-client/sylpheed-claws-vcalendar/files/digest-sylpheed-claws-vcalendar-0.4 b/mail-client/sylpheed-claws-vcalendar/files/digest-sylpheed-claws-vcalendar-0.4
new file mode 100644
index 000000000000..0749ea13fb6e
--- /dev/null
+++ b/mail-client/sylpheed-claws-vcalendar/files/digest-sylpheed-claws-vcalendar-0.4
@@ -0,0 +1 @@
+MD5 53b4cd6e33ac89658a9a832d9d82d5d4 vcalendar-0.4.tar.gz 326637
diff --git a/mail-client/sylpheed-claws-vcalendar/files/vcalendar-0.4-ical.patch b/mail-client/sylpheed-claws-vcalendar/files/vcalendar-0.4-ical.patch
new file mode 100644
index 000000000000..254d0881572d
--- /dev/null
+++ b/mail-client/sylpheed-claws-vcalendar/files/vcalendar-0.4-ical.patch
@@ -0,0 +1,57 @@
+--- src/vcal_manager.c.org 2004-09-22 15:08:20.000000000 +0200
++++ src/vcal_manager.c 2004-10-07 21:40:33.522688052 +0200
+@@ -326,8 +326,8 @@
+ icalproperty_new_description(event->description),
+ icalproperty_new_summary(event->summary),
+ icalproperty_new_sequence(event->sequence + 1),
+- icalproperty_new_class("PUBLIC"),
+- icalproperty_new_transp("OPAQUE"),
++ icalproperty_new_class(ICAL_CLASS_PUBLIC),
++ icalproperty_new_transp(ICAL_TRANSP_OPAQUE),
+ orgprop,
+ 0
+ );
+@@ -440,11 +440,15 @@
+ event->uid = g_strdup(uid?uid:"");
+ event->organizer = g_strdup(organizer?organizer:"");
+
+- if (dtend)
+- event->end = g_strdup(icaltime_as_ctime(icaltime_as_local(icaltime_from_string(dtend))));
++ if (dtend) {
++ time_t tmp = icaltime_as_timet(icaltime_as_local(icaltime_from_string(dtend)));
++ event->end = g_strdup(ctime(&tmp));
++ }
+
+- if (dtstart)
+- event->start = g_strdup(icaltime_as_ctime(icaltime_as_local(icaltime_from_string(dtstart))));
++ if (dtstart) {
++ time_t tmp = icaltime_as_timet(icaltime_as_local(icaltime_from_string(dtstart)));
++ event->start = g_strdup(ctime(&tmp));
++ }
+
+ event->dtstart = g_strdup(dtstart?dtstart:"");
+ event->dtend = g_strdup(dtend?dtend:"");
+--- src/vcalendar.c.org 2004-09-22 15:08:20.000000000 +0200
++++ src/vcalendar.c 2004-10-07 21:38:29.549822328 +0200
+@@ -720,8 +720,8 @@
+ iprop = vcalviewer_get_property(vcalviewer, ICAL_DTSTART_PROPERTY);
+ if (iprop) {
+ struct icaltimetype itt = icaltime_as_local(icalproperty_get_dtstart(iprop));
+- gtk_label_set_text(GTK_LABEL(vcalviewer->start),
+- icaltime_as_ctime(itt));
++ time_t tmp = icaltime_as_timet(itt);
++ gtk_label_set_text(GTK_LABEL(vcalviewer->start), ctime(&tmp));
+ icalproperty_free(iprop);
+ } else
+ gtk_label_set_text(GTK_LABEL(vcalviewer->start), "-");
+@@ -729,8 +729,8 @@
+ iprop = vcalviewer_get_property(vcalviewer, ICAL_DTEND_PROPERTY);
+ if (iprop) {
+ struct icaltimetype itt = icaltime_as_local(icalproperty_get_dtstart(iprop));
+- gtk_label_set_text(GTK_LABEL(vcalviewer->end),
+- icaltime_as_ctime(itt));
++ time_t tmp = icaltime_as_timet(itt);
++ gtk_label_set_text(GTK_LABEL(vcalviewer->end), ctime(&tmp));
+ icalproperty_free(iprop);
+ } else
+ gtk_label_set_text(GTK_LABEL(vcalviewer->end), "-");
diff --git a/mail-client/sylpheed-claws-vcalendar/metadata.xml b/mail-client/sylpheed-claws-vcalendar/metadata.xml
new file mode 100644
index 000000000000..770af1a84c86
--- /dev/null
+++ b/mail-client/sylpheed-claws-vcalendar/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+<maintainer>
+ <email>genone@gentoo.org</email>
+ <description>Primary maintainer</description>
+</maintainer>
+<maintainer>
+ <email>seemant@gentoo.org</email>
+</maintainer>
+<maintainer>
+ <email>bcowan@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/mail-client/sylpheed-claws-vcalendar/sylpheed-claws-vcalendar-0.4.ebuild b/mail-client/sylpheed-claws-vcalendar/sylpheed-claws-vcalendar-0.4.ebuild
new file mode 100644
index 000000000000..4a128674f50a
--- /dev/null
+++ b/mail-client/sylpheed-claws-vcalendar/sylpheed-claws-vcalendar-0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-vcalendar/sylpheed-claws-vcalendar-0.4.ebuild,v 1.1 2004/10/17 23:10:46 genone Exp $
+
+inherit eutils
+
+MY_P="${P##sylpheed-claws-}"
+
+DESCRIPTION="Plugin for sylpheed-claws to send and receive vcal messages"
+HOMEPAGE="http://sylpheed-claws.sourceforge.net"
+SRC_URI="http://sylpheed-claws.sourceforge.net/downloads/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+DEPEND=">=mail-client/sylpheed-claws-0.9.12b-r1
+ >=dev-libs/libical-0.24_rc4-r1"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${MY_P}-ical.patch"
+}
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+}