summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2009-02-09 19:49:56 +0000
committerMarkus Meier <maekke@gentoo.org>2009-02-09 19:49:56 +0000
commit1479f6562b4636f5f80d93f1237fa303697204bd (patch)
treec1b411a587ea6d18ef67a085cf87b8a1b4ee4960 /media-gfx/aoi/aoi-2.5.ebuild
parentRemoved old (diff)
downloadhistorical-1479f6562b4636f5f80d93f1237fa303697204bd.tar.gz
historical-1479f6562b4636f5f80d93f1237fa303697204bd.tar.bz2
historical-1479f6562b4636f5f80d93f1237fa303697204bd.zip
convert to gen-2 java eclasses by Vlastimil Babka in bug #258334
Package-Manager: portage-2.2_rc23/cvs/Linux i686
Diffstat (limited to 'media-gfx/aoi/aoi-2.5.ebuild')
-rw-r--r--media-gfx/aoi/aoi-2.5.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/media-gfx/aoi/aoi-2.5.ebuild b/media-gfx/aoi/aoi-2.5.ebuild
index 4a82a80e2c8b..0742ceafc54b 100644
--- a/media-gfx/aoi/aoi-2.5.ebuild
+++ b/media-gfx/aoi/aoi-2.5.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/aoi/aoi-2.5.ebuild,v 1.1 2007/12/10 16:02:04 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/aoi/aoi-2.5.ebuild,v 1.2 2009/02/09 19:49:56 maekke Exp $
-inherit java-pkg eutils
+inherit java-pkg-2 eutils
MY_P="aoi25"
MY_MANUAL_V="2.3"
@@ -15,13 +15,10 @@ KEYWORDS="~amd64 ~ppc ~x86"
LICENSE="GPL-2"
SLOT="0"
DEPEND="app-arch/unzip"
-RDEPEND=">=virtual/jdk-1.2"
+RDEPEND=">=virtual/jre-1.4"
IUSE="doc"
src_install() {
- # wrapper script
- dobin "${FILESDIR}"/aoi
-
# documentation
dodoc HISTORY README
if use doc ; then
@@ -32,6 +29,11 @@ src_install() {
# main app
java-pkg_dojar ArtOfIllusion.jar
+ # run script
+ java-pkg_dolauncher aoi \
+ --jar ArtOfIllusion.jar \
+ --java_args -Xmx128M
+
# plugins
mv Plugins "${D}"/usr/share/${PN}/lib